Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

hsrp ip addresses

Hi all, can anyone tell me why hsrp has to have a real ip and virtual on the router, is the real one for management ? and takes the subnet mask to be used for the virtual one ?

2 REPLIES

Re: hsrp ip addresses

Hi Carl,

when you wanted to have HSRP on the network, u need minimum 2 devices it can be a Layer3 switch or a router, which means both the devices should have an ip address assigned on the same subnet, once the HSRP configuration has been added in that switch or router, the standby IP address should be common on the both the L3switches or routers & all the PC's running on the network will have their gateway IP address as the virtual IP address & not the real Ip address, by doing this, even if 1 switch fails the other switch will act the main, so that the user will not know that the network is down. eg. lets say that L3switch-1 IP address is 192.168.1.2 & L3 switch-2 IP address is 192.168.1.3 & standby IP for both the switches is 192.168.1.1(in HSRP configuration), & all the client PC's gateway IP address is set to 192.168.1.1, by doing this,192.168.1.1 will act as 192.168.1.2 or 192.168.1.3(based on the priority), even 192.168.1.2 goes down, 192.168.1.1 will act as 192.168.1.3.

hope you understood.

rate this post if cleared.

Re: hsrp ip addresses

Hi Carl,

to make you more clear abour HSRP, juz go thru the diagram attached to this. on the diagram you can see that a virtual router is created once the HSRP commands are issued properly.

typical the commands looks like this....

Rotuer A

interface vlan 2

ip address 192.168.1.2 255.255.255.0

standby 1 ip 192.168.1.1

standby 1 pripority 108

standby 1 preempt

standby 2 timers 5 15

Router B

interface vlan 2

ip address 192.168.1.3 255.255.255.0

standby 1 ip 192.168.1.1

standby 1 pripority 108

standby 1 preempt

standby 2 timers 5 15

hope this helps.

rate this post if cleared

238
Views
7
Helpful
2
Replies
CreatePlease to create content