Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

HSRP on Catalyst 3550

Hello.

I've some questions about HSRP on Catalyst 3550.

I'm working with 2 Catalyst 3550-EMI (12.1(9)EA1c).

And I need to configure HSRP to ensure network redundancy.

I've made below configuration.

SW1#

interface FastEthernet0/1

no switchport

ip address 10.1.1.100 255.255.255.0

no ip redirects

standby 1 ip 10.1.1.2

standby 1 priority 200

standby 1 preempt

standby 1 track FastEthernet0/24 150

interface FastEthernet0/24

no switchport

ip address 192.168.1.100 255.255.255.0

no ip redirects

standby 2 ip 192.168.1.254

standby 2 priority 200

standby 2 preempt

SW2#

interface FastEthernet0/1

no switchport

ip address 10.1.1.200 255.255.255.0

no ip redirects

standby 1 ip 10.1.1.2

standby 1 priority 100

interface FastEthernet0/24

no switchport

ip address 192.168.1.200 255.255.255.0

no ip redirects

standby 2 ip 192.168.1.254

standby 2 priority 100

After configure completed.

The result of 'show standby' command is like below.

SW1#show standby

FastEthernet0/1 - Group 1

Local state is Active, priority 200, may preempt

Hellotime 3 holdtime 10

Next hello sent in 00:00:02.170

Virtual IP address is 10.1.1.2 configured

Active router is local

Standby router is 10.1.1.200 expires in 00:00:07

Standby virtual mac address is 0000.0c07.ac01

5 state changes, last state change 02:01:23

Tracking interface states for 1 interface, 1 up:

Up FastEthernet0/24 Priority decrement: 150

FastEthernet0/24 - Group 2

Local state is Active, priority 200, may preempt

Hellotime 3 holdtime 10

Next hello sent in 00:00:02.570

Virtual IP address is 192.168.1.254 configured

Active router is local

Standby router is 192.168.1.200 expires in 00:00:07

Standby virtual mac address is 0000.0c07.ac02

9 state changes, last state change 02:05:28

SW2#show standby

FastEthernet0/1 - Group 1

Local state is Standby, priority 100

Hellotime 3 holdtime 10

Next hello sent in 00:00:01.416

Virtual IP address is 10.1.1.2 configured

Active router is 10.1.1.100 expires in 00:00:07, priority 200

Standby router is local

4 state changes, last state change 01:59:39

FastEthernet0/24 - Group 2

Local state is Standby, priority 100

Hellotime 3 holdtime 10

Next hello sent in 00:00:00.118

Virtual IP address is 192.168.1.254 configured

Active router is 192.168.1.100 expires in 00:00:09, priority 200

Standby router is local

10 state changes, last state change 02:03:53

My purpose is the SW2 will take over all of the jobs processed by SW1

while I disconncet the cable on F0/24 at SW1.

But it doesn't work. After I disconnected the cable on F0/24@SW1.

The F0/24@SW1 will be standby. The F0/24@SW2 will be Active.

But the F0/1@SW1 still be Active! The standby track command seems not effected.

SW1#show standby

FastEthernet0/1 - Group 1

Local state is Active, priority 50 (confgd 200), may preempt

Hellotime 3 holdtime 10

Next hello sent in 00:00:00.174

Virtual IP address is 10.1.1.2 configured

Active router is local

Standby router is 10.1.1.200 expires in 00:00:08

Standby virtual mac address is 0000.0c07.ac01

5 state changes, last state change 02:12:36

Tracking interface states for 1 interface, 0 up:

Down FastEthernet0/24 Priority decrement: 150

FastEthernet0/24 - Group 2

Local state is Init (interface down), priority 200, may preempt

Hellotime 3 holdtime 10

Virtual IP address is 192.168.1.254 configured

Active router is unknown expired

Standby router is unknown expired

10 state changes, last state change 00:01:42

SW2#show standby

FastEthernet0/1 - Group 1

Local state is Standby, priority 100

Hellotime 3 holdtime 10

Next hello sent in 00:00:00.516

Virtual IP address is 10.1.1.2 configured

Active router is 10.1.1.100 expires in 00:00:09, priority 50

Standby router is local

4 state changes, last state change 02:15:59

FastEthernet0/24 - Group 2

Local state is Active, priority 100

Hellotime 3 holdtime 10

Next hello sent in 00:00:01.940

Virtual IP address is 192.168.1.254 configured

Active router is local

Standby router is 192.168.1.200 expired

Standby virtual mac address is 0000.0c07.ac02

11 state changes, last state change 00:05:18

See? The priority of the F0/1@SW1 is decresed to 50.

And the priority of the F0/1@SW2 is still 100.

But the state of the F0/1@SW1 is still Active.

And the state of the F0/1@SW2 is still Standby.

Please give some suggestions.

Please forgive my poor English. Thank you very much.

Allen Huang

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: HSRP on Catalyst 3550

You just have to add the word "preempt" on your standby configuration of F0/1 of your SW2:

standby 1 preempt

It allows the interface to be active when it has the highest priority.

2 REPLIES
New Member

Re: HSRP on Catalyst 3550

There is an open caveat relating to "standby track" in the version of IOS you are using. Check BugID CSCdt48614. Suggest contacting TAC for assistance. Also, the version indicated by this BugID as having this resolved (12.1(11)EA1) also has problems, but may work for your circumstance.

New Member

Re: HSRP on Catalyst 3550

You just have to add the word "preempt" on your standby configuration of F0/1 of your SW2:

standby 1 preempt

It allows the interface to be active when it has the highest priority.

152
Views
5
Helpful
2
Replies
CreatePlease to create content