Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP priority changed automatically!

We have two 7513's each has a number of subinterfaces for each VLAN.

There was a problem with just one of the VLAN's/subinterfaces earlier, the HSRP priority of the sub-int chaged by itself and I can't change it back, it's just stuck with a priority of 100.

I've checked the running config and it's definately set to 110 but when you show the standy int it shows 100.

Here's the running config.

interface FastEthernet5/0/0.12

encapsulation isl 12

ip address 10.20.24.2 255.255.252.0

standby ip 10.20.24.1

standby 12 priority 110 preempt

Here's the output from the sh stand

FastEthernet5/0/0.12 - Group 0

Local state is Standby, priority 100

Hellotime 3 holdtime 10

Next hello sent in 00:00:00.472

Hot standby IP address is 10.20.24.1 configured

Active router is 10.20.24.3 expires in 00:00:08

Standby router is local

Standby virtual mac address is 0000.0c07.ac00

As you can see the priority is 100 not the configured 110.

There are numerous other sub-ints configured with HSRP all using the priority of 110 which are fine. I've tried shut, noshut on the sub int and I've tried removing the HSRP config from the sub-int.

The only other option I can see is to reload the routers - This exact same problem is on the other 7513.

This looks like a bug to me can anyone else throw any light on this?

Thanks in advance

Steve

3 REPLIES
New Member

Re: HSRP priority changed automatically!

Perform a "sh standby all" and you will see your subtle configuration error. You configured your standby IP with no explicit group and then you configured your priority explicitly for group 12. Try configuring:

standby 12 ip x.x.x.x

standby 12 priority 110 preempt

Good luck.

New Member

Re: HSRP priority changed automatically!

Yup because you left out the group number, it assumes the IP belongs to group 0. Hence your output shows "Group 0" instead of "Group 12".

New Member

Re: HSRP priority changed automatically!

Thanks guys, I've just check the old configs and it's been like that for at least 6 months!

Thanks again.

Steve

216
Views
5
Helpful
3
Replies