Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

HSRP (Simple) Standby Config Question

I'm a bit of a newbie with HSRP - not that it is too complicated for basic operation. I cannot seem to find the answer to my question or if the answer is out there, I'm to new to realize it. That being said, I apologize if this has been asked too many times.

I have a simple setup. (2) 3640 Routers. 3 FE interfaces on each being used. On the "outside", (1) interface goes to ISP-A, (1) interface to ISP-B. The 3rd interface is in the inside.

FE 0/0 - ISPA

FE 1/0 - ISPB

FE 1/1 - "Inside" Network

Being a newbie to HSRP, I'm confused on the behavior when it comes to failing over to a standby unit. I'd like my situation to be an "all-or-none" setup, so if FE 0/0 fails on Router1 then ALL interfaces (regardless of their current state) go to their standby partner interfaces on Router2.

Do I do this by having all interfaces use the same standby group? I thought no, but if not, then I don't know how to ensure the behavoir is an all-or-none setup (unless this IS the behavior by default).

EXAMPLE INTERFACE:

Router1 - FE 0/0

interface Ethernet0/0

ip address 1.1.1.1 255.255.255.0

standby 100 ip 1.1.1.3

standby 100 timers 5 15

standby 100 priority 200

standby 100 preempt

Router2 - FE 0/0

interface Ethernet0/0

ip address 1.1.1.2 255.255.255.0

standby 100 ip 1.1.1.3

standby 100 timers 5 15

standby 100 preempt

[I won't bother putting the other interfaces as they would be set up in a similar fashion.]

Question: How can I ensure that if ANY interface on the primary router enters a failed state that ALL interfaces on the other router will assume the role as active?

Thank you in advance,

Hutch

1 ACCEPTED SOLUTION

Accepted Solutions

Re: HSRP (Simple) Standby Config Question

Hello Hutch,

What you are looking for is available through interface tracking. A good description and examples are found at "How to Use the standby preempt and standby track Commands"

http://www.cisco.com/en/US/tech/tk648/tk362/technologies_tech_note09186a0080094e8c.shtml

Basically you reduce the priority of the active router, when an interface goes down to a value that it is becoming standby.

Router1 - FE 0/0

interface Ethernet0/0

ip address 1.1.1.1 255.255.255.0

standby 100 ip 1.1.1.3

standby 100 timers 5 15

standby 100 priority 105

standby 100 track FastEthernet1/0

standby 100 track FastEthernet1/1

standby 100 preempt

You can solve your issue in configuring each HSRP group to track both other interfaces.

Hope this helps! Please rate all posts.

Regards, Martin

6 REPLIES

Re: HSRP (Simple) Standby Config Question

Hello Hutch,

What you are looking for is available through interface tracking. A good description and examples are found at "How to Use the standby preempt and standby track Commands"

http://www.cisco.com/en/US/tech/tk648/tk362/technologies_tech_note09186a0080094e8c.shtml

Basically you reduce the priority of the active router, when an interface goes down to a value that it is becoming standby.

Router1 - FE 0/0

interface Ethernet0/0

ip address 1.1.1.1 255.255.255.0

standby 100 ip 1.1.1.3

standby 100 timers 5 15

standby 100 priority 105

standby 100 track FastEthernet1/0

standby 100 track FastEthernet1/1

standby 100 preempt

You can solve your issue in configuring each HSRP group to track both other interfaces.

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: HSRP (Simple) Standby Config Question

Martin-

Sorry for the delayed reply - I was reading your link and performing some tests on a pair of 2610s this morning. Thanks so much for your input. This is exactly what I'm looking for.

Everything seems to be working - pulling either interface's Ethernet cable out or shutting one down causes the standby router to be the primary for both interfaces/groups.

...So by default an interface monitors itself (or the group does) and as long as I monitor the other interfaces from each individual interface I should be set.

Would you mind looking at the test config below?

I will most certainly rate your posts - Thanks for your help,

Hutch

###########################

Router 1:

interface Ethernet0/0

ip address 171.16.6.5 255.255.255.0

no ip redirects

standby 1 ip 171.16.6.100

standby 1 timers 5 15

standby 1 priority 105

standby 1 preempt

standby 1 track Ethernet1/0

!

interface Ethernet1/0

ip address 10.0.0.5 255.255.255.0

no ip redirects

standby 2 ip 10.0.0.100

standby 2 timers 5 15

standby 2 priority 105

standby 2 preempt

standby 2 track Ethernet0/0

!

Router 2:

interface Ethernet0/0

ip address 171.16.6.6 255.255.255.0

no ip redirects

standby 1 ip 171.16.6.100

standby 1 timers 5 15

standby 1 preempt

standby 1 track Ethernet1/0

!

interface Ethernet1/0

ip address 10.0.0.6 255.255.255.0

no ip redirects

standby 2 ip 10.0.0.100

standby 2 timers 5 15

standby 2 preempt

standby 2 track Ethernet0/0

!

#############################

New Member

Re: HSRP (Simple) Standby Config Question

Just a few comments/questions.

Is there a reason you're using 5 15 for the timers? The default is 3 10 which allows for faster failover.

Your priorities are good. One common mistake people make are using 100 and 110, and then enabling tracking with the default decrement of 10.

One thing you might want to look into is preemptive delay. It'll dampen the effects of a flapping interface that's being tracked.

Also, keep in mind that you can now use SAA to track HSRP. So you can go beyond specific interface tracking and move toward endpoint reachability:

http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_feature_guide09186a00801d2d74.html

New Member

Re: HSRP (Simple) Standby Config Question

Well each ISP's interface will be talking BGP and advertising our block. I thought it would be good to delay it a bit to avoid flapping too much. Additionally, after reading this article:

http://www.cisco.com/warp/public/459/hsrp_bgp.html

I thought I might use "preempt delay minimum 60" on each interface as well.

That being said, once this is set up I certainly don't plan on unplugging ethernet cables and/or rearranging cables in a production network! Nor is my specific setup subject to "normal" hiccups.... So maybe I should just leave the defaults there? [If I do plan maintenance, I'll simply take a router offline before I mess with cables of course.]

Thoughts?

Thanks Martin,

Hutch

Purple

Re: HSRP (Simple) Standby Config Question

Hi Hutch,

While you may have a pretty solid setup, there are instances when line cards develop intermittent errors and start flapping.

Although this may never happen in your network, it may be a useful safety net to build in that delay.

Hope that helps - pls rate the post if it does.

Regards,

Paresh.

New Member

Re: HSRP (Simple) Standby Config Question

Good points.

So is there any down side to the longer delay, besides the delay itself? (sounds like a pretty dumb question I know) Additionally, does the timers setting along with the "preempt delay minimum 60" sound like a decent setup in my situation?

Thanks for your reply,

Hutch

603
Views
4
Helpful
6
Replies