Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

HSRP (standby taking time time to become active)

hi

i was configuring HSRP on my cisco 3550 switches

my topology is

1.JPG

i am doing this on live equipment.

hsrp is working but the problem  is i lose around 4 pings every time when the standby switch to active

my configuration is

on core 1

interface Vlan192

description local

ip address 192.168.0.251 255.255.255.0

no ip redirects

standby 192 ip 192.168.0.254

standby 192 timers msec 300 msec 950

standby 192 priority 110

standby 192 preempt

end

interface Vlan50

description dataserver

ip address 50.50.50.251 255.255.255.0

ip helper-address 81.81.81.81

ip helper-address 81.81.81.82

no ip redirects

standby 50 ip 50.50.50.254

standby 50 timers msec 300 msec 950

standby 50 priority 110

standby 50 preempt

end

on core 2

interface Vlan192

description local

ip address 192.168.0.252 255.255.255.0

standby 192 ip 192.168.0.254

standby 192 timers msec 300 msec 950

end

interface Vlan50

description dataserver

ip address 50.50.50.252 255.255.255.0

ip helper-address 81.81.81.81

ip helper-address 81.81.81.82

standby 50 ip 50.50.50.254

standby 50 timers msec 300 msec 950

end

please help me out to overcome this problem i will be thankful

1 REPLY
Silver

HSRP (standby taking time time to become active)

Basit Karim wrote:

hi

i was configuring HSRP on my cisco 3550 switches

my topology is

i am doing this on live equipment.

hsrp is working but the problem  is i lose around 4 pings every time when the standby switch to active

my configuration is

on core 1

interface Vlan192

description local

ip address 192.168.0.251 255.255.255.0

no ip redirects

standby 192 ip 192.168.0.254

standby 192 timers msec 300 msec 950

standby 192 priority 110

standby 192 preempt

end

interface Vlan50

description dataserver

ip address 50.50.50.251 255.255.255.0

ip helper-address 81.81.81.81

ip helper-address 81.81.81.82

no ip redirects

standby 50 ip 50.50.50.254

standby 50 timers msec 300 msec 950

standby 50 priority 110

standby 50 preempt

end

on core 2

interface Vlan192

description local

ip address 192.168.0.252 255.255.255.0

standby 192 ip 192.168.0.254

standby 192 timers msec 300 msec 950

end

interface Vlan50

description dataserver

ip address 50.50.50.252 255.255.255.0

ip helper-address 81.81.81.81

ip helper-address 81.81.81.82

standby 50 ip 50.50.50.254

standby 50 timers msec 300 msec 950

end

please help me out to overcome this problem i will be thankful

You're always going to lose *some* traffic while HSRP figures out the primary is dead and enables the secondary. 4 PING's isn't much, assuming an average network latency of 30 msec per PING that's only 120 msec - just over a tenth of a second.

You could try lowering your standby timers furter, but you've already got them lower than Cisco's recommended minimum (1 second/4 seconds), so all you'll do is increase your CPU load without any real benefit.

From memory, there are other protocols which provide a form of active/active redundant router scenario - maybe you should look into one of those. I'm sure someone will point out what they are (or smack me across the back of the head if I'm wrong!). :-)

Cheers

323
Views
0
Helpful
1
Replies
CreatePlease to create content