Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

HSRP stops responding when applying roue-map

Hi, I have two routers that have an HSRP process running. As soon as I apply a route map to the interfaces, the HSRP process stops working and they both become active. Here's an example of the configurations.

Router 1:

interface FastEthernet0/0.64

description Segment Corpo 1

encapsulation isl 64

ip address 10.166.64.2 255.255.254.0

ip policy route-map net-corpo

standby 1 priority 110

standby 1 preempt

standby 1 ip 10.166.64.1

!

access-list 110 permit ip 10.166.64.0 0.0.1.255 any

!

route-map net-corpo permit 10

match ip address 110

set ip next-hop 10.199.99.1

!

Router 2:

interface FastEthernet0.64

description Segment Corpo 1

encapsulation isl 64

ip address 10.166.64.3 255.255.254.0

no ip redirects

ip policy route-map net-corpo

standby 1 priority 100

standby 1 ip 10.166.64.1

!

access-list 110 permit ip 10.166.64.0 0.0.1.255 any

!

route-map net-corpo permit 10

match ip address 110

set ip next-hop 10.199.99.1

Thanks,

Stephane

1 REPLY
Cisco Employee

Re: HSRP stops responding when applying roue-map

Exclude the HSRP and both router IP address from access-list 110. That should make it work.

194
Views
0
Helpful
1
Replies
CreatePlease to create content