Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP with OSPF

I have OSPF running on the MAN/WAN. One of the OSPF links is a 100mbps connection from a 6509 to a 7206. The 6509 MSFC is the active router for the MAN. I have a point-to-point vlan for the connection from the 6509 to the 7206. The 7206 routes to three remote sites, and is running OSPF in the same area as the 6509.

I implemented HSRP between this 6509, and a 6509 in another location. HSRP works great, except for the fact that I lose my point-to-point connection between the 6509 and the 7206. This link does not have any HSRP configuration. I thought there should be no effect on this router link, but obviously, there is.

Does anyone have any suggestions as to how to troubleshoot this?

8 REPLIES
Bronze

Re: HSRP with OSPF

The routers should not use the standby address for their communications. Have you used router-id statements and specified the standby address?

Show us the standby and ospf configs.

New Member

Re: HSRP with OSPF

The router is directly connected to the 6509, using ospf routing.

There are 32 vlans, each configured the same way. When the hsrp config is applied, I cannot ping the 7206. When I remove the hsrp config from a vlan interface, I can ping the 7206 from within that vlan only. BTW, the link to the 7507 works fine, and the only static route is the one listed below.

Here are the relevant configs of the 6509, both pre-hsrp and post-hsrp, and the 7206:

===================================

6509 - Pre-HSRP Config

interface Vlan4

ip address 10.24.4.1 255.255.255.0

ip helper-address 10.24.4.74

no ip redirects

interface Vlan990

description to 7206 Router(10.24.254.77)

ip address 10.24.254.78 255.255.255.252

interface Vlan991

description to 7507 Router (10.24.254.249)

ip address 10.24.254.249 255.255.255.248

ip ospf authentication

ip ospf message-digest-key 50 md5 7 xxxxxxxxxx

router ospf 100

log-adjacency-changes

network 10.24.4.1 0.0.0.0 area 2.0.0.0

network 10.24.254.78 0.0.0.0 area 2.0.0.0

network 10.24.254.249 0.0.0.0 area 2.0.0.0

default-metric 100

ip route 0.0.0.0 0.0.0.0 10.24.254.248

======================================

6509 - Post-HSRP Config

(This is the only modification from the previous. Each vlan is configured this way.)

interface Vlan4

ip address 10.24.4.90 255.255.255.0

standby 2 ip 10.24.4.1

standby 2 timers 2 6

standby 2 priority 110

standby 2 preempt

=====================================

7206 Config

interface FastEthernet1/0

description To 6509 (10.24.254.78)

ip address 10.24.254.77 255.255.255.252

router ospf 100

network 10.24.254.77 0.0.0.0 area 2.0.0.0

default-metric 100

======================================

Gold

Re: HSRP with OSPF

Could you post a show ip route for the address you're trying to ping before and after the hsrp configuration is put in?

Russ.W

New Member

Re: HSRP with OSPF

As requested. I've also included more detail.

=======================

Without HSRP on vlan 2:

6509Router#

interface Vlan2

ip address 10.24.2.1 255.255.255.0

no ip redirects

6509Router#

7206Router#sh ip route 10.24.2.130

Routing entry for 10.24.2.0/24

Known via "ospf 100", distance 110, metric 2, type intra area

Redistributing via ospf 100

Last update from 10.24.254.78 on FastEthernet1/0, 00:00:38 ago

Routing Descriptor Blocks:

* 10.24.254.78, from 10.24.254.249, 00:00:38 ago, via FastEthernet1/0

Route metric is 2, traffic share count is 1

7206Router#

=======================

With HSRP on vlan 2:

After I apply the following config to the 6509...

6509Router#

interface Vlan2

ip address 10.24.2.90 255.255.255.0

standby 2 timers 2 6

standby 2 priority 110 preempt

standby 2 ip 10.24.2.1

6509Router#

...I get this output.

7206Router#sh ip route 10.24.2.130

% Subnet not in table

7206Router#

=======================

The 7206 config:

interface FastEthernet1/0

description To 6509Router

ip address 10.24.254.77 255.255.255.252

router ospf 100

network 10.24.254.77 0.0.0.0 area 2.0.0.0

(I do not have a gateway of last resort set)

=======================

The 6509 config:

interface Vlan990

description To 7206Router

ip address 10.24.254.78 255.255.255.252

interface Vlan991

description To 7506Router

ip address 10.24.254.249 255.255.255.248

ip ospf authentication

ip ospf message-digest-key 50 md5 7 xxxxxx

router ospf 100

network 10.24.254.78 0.0.0.0 area 2.0.0.0

network 10.24.254.249 0.0.0.0 area 2.0.0.0

ip route 0.0.0.0 0.0.0.0 10.24.254.248

(This last IP static route sets the gateway of last resort)

=======================

Note that I cannot ping the 7206 ONLY from within a vlan that has HSRP configured.

=======================

New Member

Re: HSRP with OSPF

When you are enabling HSRP,can you check if this 6509 box is active router.

"show standby vlan 2 "

Since you are running OSPF process in 6509 using the virual ip of HSRP,And if the active router is the remote location 6509, OSPF process would treat that link as down.

Inturn 7206 router would not learn the route of this subnet VLAN 2.

New Member

Re: HSRP with OSPF

what's your diagram, I get lost

New Member

Re: HSRP with OSPF

Problem Solved!

I managed to correct the problem. My OSPF network statements were pointing to the virtual router IP addresses, vice the physical IP addresses. I discovered this when, after I applied the HSRP config, the interface would not show up when I typed "show ip ospf int".

Thank you to all who provided input.

Gold

Re: HSRP with OSPF

Cool! And I was just typing a request for the configs of the routers, so I could look at your ospf network statements....

:-)

Russ.W

261
Views
0
Helpful
8
Replies
CreatePlease login to create content