Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP with secondary addresses?

llo

I have a problem configuring HSRP with secondary addresses on 2 Cisco 2811:s. On each router, fa0/0 is connected to the same switch. They see eachother with cdp.

On the LAN, there are clients with IP:s in both 172.17.2.0/24 and 172.17.3.0/24. The final goal is to use 172.17.x.2 as default gateway on all hosts. Router lugw01 is to be the active router on all interfaces while lugw02 is just a "hot spare" standing by.

The problem is that I cant get HSRP working with secondary:s. What am I doing wrong? According to CCO I think I have configured it the right way.

This is the interresting parts of the configurations:

hostname lugw01

interface FastEthernet0/0

description Internal LAN

ip address 172.17.3.3 255.255.255.0 secondary

ip address 172.17.2.3 255.255.255.0

duplex auto

speed auto

standby 2 ip 172.17.2.2

standby 2 priority 200

standby 2 preempt

standby 3 ip 172.17.3.2 secondary

standby 3 priority 200

standby 3 preempt

!

hostname lugw02

interface FastEthernet0/0

description Internal LAN

ip address 172.17.3.4 255.255.255.0 secondary

ip address 172.17.2.4 255.255.255.0

duplex auto

speed auto

standby 2 ip 172.17.2.2

standby 2 preempt

standby 3 ip 172.17.3.2 secondary

standby 3 preempt

!

As You can see below, standby group 3 is never going to Active state.

lugw01#sh stand

FastEthernet0/0 - Group 2

State is Active

4 state changes, last state change 00:03:07

Virtual IP address is 172.17.2.2

Active virtual MAC address is 0000.0c07.ac02

Local virtual MAC address is 0000.0c07.ac02 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 1.216 secs

Preemption enabled

Active router is local

Standby router is 172.17.2.4, priority 100 (expires in 9.212 sec)

Priority 200 (configured 200)

IP redundancy name is "hsrp-Fa0/0-2" (default)

FastEthernet0/0 - Group 3

State is Learn

Virtual IP address is unknown

Secondary virtual IP address 172.17.3.2

Active virtual MAC address is unknown

Local virtual MAC address is 0000.0c07.ac03 (v1 default)

Hello time 3 sec, hold time 10 sec

Preemption enabled

Active router is unknown

Standby router is unknown

Priority 200 (configured 200)

IP redundancy name is "hsrp-Fa0/0-3" (default)

lugw02#sh stand

FastEthernet0/0 - Group 2

State is Standby

4 state changes, last state change 00:03:20

Virtual IP address is 172.17.2.2

Active virtual MAC address is 0000.0c07.ac02

Local virtual MAC address is 0000.0c07.ac02 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 0.236 secs

Preemption enabled

Active router is 172.17.2.3, priority 200 (expires in 9.236 sec)

Standby router is local

Priority 100 (default 100)

IP redundancy name is "hsrp-Fa0/0-2" (default)

FastEthernet0/0 - Group 3

State is Learn

Virtual IP address is unknown

Secondary virtual IP address 172.17.3.2

Active virtual MAC address is unknown

Local virtual MAC address is 0000.0c07.ac03 (v1 default)

Hello time 3 sec, hold time 10 sec

Preemption enabled

Active router is unknown

Standby router is unknown

Priority 100 (default 100)

IP redundancy name is "hsrp-Fa0/0-3" (default)

4 REPLIES
New Member

Re: HSRP with secondary addresses?

Output from "deb standby" when I do "no shut" on int fa0/0:

*Sep 13 11:49:50.027: HSRP: Fa0/0 API 172.17.2.3 is not an HSRP address

*Sep 13 11:49:50.027: HSRP: Fa0/0 API 172.17.3.3 is not an HSRP address

*Sep 13 11:49:50.027: HSRP: Fa0/0 API MAC address update

*Sep 13 11:49:50.035: HSRP: Fa0/0 API Software interface coming up

*Sep 13 11:49:50.039: HSRP: Fa0/0 API Add active HSRP addresses to ARP table

*Sep 13 11:49:52.027: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up

*Sep 13 11:49:52.027: HSRP: API Hardware state change

*Sep 13 11:49:52.027: HSRP: Fa0/0 API Software interface coming up

*Sep 13 11:49:52.027: HSRP: Fa0/0 Grp 2 Hello in 172.17.2.4 Active pri 100 vIP 172.17.2.2

*Sep 13 11:49:52.027: HSRP: Fa0/0 Grp 2 Active router is 172.17.2.4

*Sep 13 11:49:53.027: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

*Sep 13 11:49:55.027: HSRP: Fa0/0 Grp 2 Hello in 172.17.2.4 Active pri 100 vIP 172.17.2.2

*Sep 13 11:49:57.927: HSRP: Fa0/0 Redirect adv out, Dormant, active 0 passive 0

*Sep 13 11:49:58.027: HSRP: Fa0/0 Grp 2 Hello in 172.17.2.4 Active pri 100 vIP 172.17.2.2

*Sep 13 11:49:59.743: HSRP: Fa0/0 Interface up

*Sep 13 11:49:59.743: HSRP: Fa0/0 Starting minimum interface delay (1 secs)

*Sep 13 11:50:00.743: HSRP: Fa0/0 Interface min delay expired

*Sep 13 11:50:00.743: HSRP: Fa0/0 Grp 2 Init: a/HSRP enabled

*Sep 13 11:50:00.743: HSRP: Fa0/0 Grp 2 Init -> Listen

*Sep 13 11:50:00.743: HSRP: Fa0/0 Grp 2 Redundancy "hsrp-Fa0/0-2" state Init -> Backup

*Sep 13 11:50:00.743: HSRP: Fa0/0 Redirect adv out, Passive, active 0 passive 1

*Sep 13 11:50:00.743: HSRP: Fa0/0 Grp 3 Init: a/HSRP enabled

*Sep 13 11:50:00.743: HSRP: Fa0/0 Grp 3 Init -> Learn

*Sep 13 11:50:00.743: HSRP: Fa0/0 Grp 3 Redundancy "hsrp-Fa0/0-3" state Init -> Learn

*Sep 13 11:50:01.027: HSRP: Fa0/0 Grp 2 Hello in 172.17.2.4 Active pri 100 vIP 172.17.2.2

*Sep 13 11:50:01.027: HSRP: Fa0/0 Grp 2 Listen: h/Hello rcvd from lower pri Active router (100/172.17.2.4)

*Sep 13 11:50:01.027: HSRP: Fa0/0 Grp 2 Active router is local, was 172.17.2.4

*Sep 13 11:50:01.027: HSRP: Fa0/0 Redirect adv out, Active, active 1 passive 3

*Sep 13 11:50:01.027: HSRP: Fa0/0 Grp 2 Coup out 172.17.2.3 Listen pri 200 vIP 172.17.2.2

*Sep 13 11:50:01.027: HSRP: Fa0/0 Grp 2 Listen -> Active

*Sep 13 11:50:01.027: %HSRP-6-STATECHANGE: FastEthernet0/0 Grp 2 state Listen -> Active

*Sep 13 11:50:01.027: HSRP: Fa0/0 Grp 2 Redundancy "hsrp-Fa0/0-2" state Backup -> Active

*Sep 13 11:50:01.027: HSRP: Fa0/0 Redirect adv out, Active, active 1 passive 2

Best regards

Jimmy Larsson

Silver

Re: HSRP with secondary addresses?

Can you reduce the priority on the primary router to about 105 instead of 200 and check if it works

New Member

Re: HSRP with secondary addresses?

Hi

I did, but it´s the same thing.

FastEthernet0/0 - Group 2

State is Active

9 state changes, last state change 00:00:37

Virtual IP address is 172.17.2.2

Active virtual MAC address is 0000.0c07.ac02

Local virtual MAC address is 0000.0c07.ac02 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 1.884 secs

Preemption enabled

Active router is local

Standby router is 172.17.2.4, priority 100 (expires in 9.420 sec)

Priority 105 (configured 105)

IP redundancy name is "hsrp-Fa0/0-2" (default)

FastEthernet0/0 - Group 3

State is Learn

Virtual IP address is unknown

Secondary virtual IP address 172.17.3.2

Active virtual MAC address is unknown

Local virtual MAC address is 0000.0c07.ac03 (v1 default)

Hello time 3 sec, hold time 10 sec

Preemption enabled

Active router is unknown

Standby router is unknown

Priority 105 (configured 105)

IP redundancy name is "hsrp-Fa0/0-3" (default)

interface FastEthernet0/0

description Internal LAN

ip address 172.17.3.3 255.255.255.0 secondary

ip address 172.17.2.3 255.255.255.0

duplex auto

speed auto

standby 2 ip 172.17.2.2

standby 2 priority 105

standby 2 preempt

standby 3 ip 172.17.3.2 secondary

standby 3 priority 105

standby 3 preempt

!

Any more suggestions?

Hall of Fame Super Silver

Re: HSRP with secondary addresses?

My suggestion is to change the configuration of group 3 and make it part of group 2.

standby 2 ip 172.17.3.2 secondary

As this part of the show command illustrates there is the ability to have a virtual address and a secondary virtual address in the same group.

FastEthernet0/0 - Group 3

State is Learn

Virtual IP address is unknown

Secondary virtual IP address 172.17.3.2

HTH

Rick

285
Views
0
Helpful
4
Replies
CreatePlease login to create content