Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

I can't get OSPF to go full. Any suggestions?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: I can't get OSPF to go full. Any suggestions?

Check hello & dead times. They should be identical.

13 REPLIES

Re: I can't get OSPF to go full. Any suggestions?

Check hello & dead times. They should be identical.

New Member

Re: I can't get OSPF to go full. Any suggestions?

I just checked and my hello is 10 and my dead is 40.

New Member

Re: I can't get OSPF to go full. Any suggestions?

I have distribution routers in Montreal and Toronto each supporting 34 access sites running OSPF over Frame Relay. Both Distribution routers are Cisco 3660's (12.2(1)). I am trying to bring up building number 35. This is a 2610 with 12.0(16). I can't get OSPF to go beyond INIT. I thought it may have been a circuit issue but layers 1 and 2 have both been accurately proved out. I am sending and receiving LMI, both pvcs are active, I am seeing the CIR; just no routing. Let me know if anyone has any suggestions. Thanks!

Bronze

Re: I can't get OSPF to go full. Any suggestions?

What type of OSPF network to you have your frame relay interfaces configured as?

Re: I can't get OSPF to go full. Any suggestions?

Hello,

When using over frame-relay, your hello, dead timers need to match to that of the neighbors...Are you using multipoint subinterface at one end , and a point to point interface on other end..(over framerelay) ???, then the timers wont match in this case...For this you need to change the network type on the interfaces, using ("ip ospf network ")

To check to see what the problem is, give a "debug ip ospf adjacancies" on the 2600 router. or get back to us with that output...

Hope that helps

Silver

Re: I can't get OSPF to go full. Any suggestions?

I would not recommend running the ospf debugs in a production enviroment. The potential is there to bring the box down.

Could you sh ow us the configs from both sides ?

try pinging 224.0.0.5 and source it from the outgoing interface see if you get a response . Also if you are using FR maps. make sure you have the broadcast key word at the end.

New Member

Re: I can't get OSPF to go full. Any suggestions?

Sorry for the delay. Got pulled into something else. Here is the config on the access site. The hello and dead timers were left at their defaults. These are point to point. I did get a response from my remote sub-interface when I pinged 224.0.0.5 sourcing the outgoing interface.

Current configuration:

!

! No configuration change since last restart

!

version 12.0

service timestamps debug datetime msec localtime

service timestamps log datetime localtime

no service password-encryption

!

hostname ARS7J4C8A

!

logging buffered 4096 notifications

logging console informational

aaa new-model

aaa authentication login default tacacs+ line

aaa authentication login admin line

aaa authentication enable default tacacs+ enable

aaa authentication ppp default local

aaa authorization network default local

aaa accounting network default start-stop tacacs+

aaa accounting connection default start-stop tacacs+

username DR02111Bbackup password

username 10901521 password

ip subnet-zero

no ip finger

no ip domain-lookup

isdn switch-type basic-ni

clock timezone MST -7

clock summer-time MDT recurring

!

!

!

interface Loopback0

ip address 10.90.254.152 255.255.255.255

no ip directed-broadcast

!

interface Ethernet0/0

description 235 Edson Street, Saskatoon, Saskatchewan

ip address 10.90.152.1 255.255.255.0

ip helper-address 10.101.2.106

ip helper-address 10.128.4.124

no ip directed-broadcast

!

interface Serial0/0

description 06/QHXX/000174/UCN/001 XUIOMFR2044

no ip address

no ip directed-broadcast

encapsulation frame-relay

no ip route-cache

no ip mroute-cache

logging event subif-link-status

logging event dlci-status-change

no fair-queue

service-module t1 timeslots 1

service-module t1 fdl att

!

interface Serial0/0.420 point-to-point

description "PVC to Murray Street"

bandwidth 64

ip address 10.90.251.153 255.255.255.252

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

frame-relay interface-dlci 420

!

interface Serial0/0.520 point-to-point

description "PVC to Summerlea Road"

bandwidth 64

ip address 10.90.250.153 255.255.255.252

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

frame-relay interface-dlci 520

!

interface Dialer1

ip address 10.90.253.153 255.255.255.252

no ip directed-broadcast

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer remote-name DR02111Bbackup

dialer idle-timeout 300

dialer string 16179884800

dialer hold-queue 100

dialer load-threshold 204 either

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap

ppp chap hostname 10901521

!

router ospf 300

log-adjacency-changes

passive-interface Ethernet0/0

passive-interface Dialer1

network 10.90.0.0 0.0.255.255 area 10.90.0.0

!

ip classless

no ip forward-protocol udp tftp

no ip forward-protocol udp domain

no ip forward-protocol udp time

no ip forward-protocol udp netbios-ns

no ip forward-protocol udp netbios-dgm

no ip forward-protocol udp tacacs

ip route 0.0.0.0 0.0.0.0 10.90.251.154 5

ip route 0.0.0.0 0.0.0.0 10.90.250.154 15

ip route 0.0.0.0 0.0.0.0 Dialer1 200

ip tacacs source-interface Loopback0

!

logging source-interface Loopback0

logging 10.128.4.130

access-list 99 permit 10.101.0.0 0.0.255.255

access-list 99 permit 10.102.0.0 0.0.255.255

access-list 99 permit 10.100.0.0 0.0.255.255

access-list 99 permit 10.128.0.0 0.0.255.255

access-list 188 permit icmp host 10.90.254.152 any echo

access-list 188 permit icmp host 10.90.254.152 any echo-reply

access-list 188 permit tcp 10.90.152.0 0.0.0.255 any eq telnet

access-list 188 permit tcp 10.90.152.0 0.0.0.255 any eq www

access-list 188 permit tcp 10.90.152.0 0.0.0.255 any eq ftp

access-list 188 permit tcp 10.90.152.0 0.0.0.255 any eq ftp-data

access-list 188 permit udp 10.90.152.0 0.0.0.255 any eq domain

access-list 188 permit tcp 10.90.152.0 0.0.0.255 any eq domain

access-list 188 permit tcp any 10.90.152.0 0.0.0.255 eq lpd

dialer-list 1 protocol ip list 188

Here are the subinterfaces on the head ends:

interface Serial2/0.475 point-to-point

description 235 Edson Street, Saskatoon, Saskatchewan

bandwidth 64

ip address 10.90.251.154 255.255.255.252

frame-relay interface-dlci 475

interface Serial2/0.475 point-to-point

description 235 Edson Street, Saskatoon, Saskatchewan

bandwidth 64

ip address 10.90.250.154 255.255.255.252

no ip mroute-cache

frame-relay interface-dlci 475

!

Silver

Re: I can't get OSPF to go full. Any suggestions?

what does sh ip o interface show ? are they in the same area ?

New Member

Re: I can't get OSPF to go full. Any suggestions?

Yes. The area is 10.90.0.0. They are in the same area.

Silver

Re: I can't get OSPF to go full. Any suggestions?

can you paste in the output of sh ip o interface

New Member

Re: I can't get OSPF to go full. Any suggestions?

Make sure the MTU settings is the same on both interfaces.

Re: I can't get OSPF to go full. Any suggestions?

I think that the best thing to do would be "debug ip ospf adjacancies" on the 2600 end to see what is going on. I wouldn't imagine it has to peer with too many other routers so you should be okay. But it is your network so you be the judge. If in doubt wait for after hours and/or use the "reload in 10" command in case you use connectivity.

Then post the results.

Hope it helps.

Steve

New Member

Re: I can't get OSPF to go full. Any suggestions?

This is actually working now. I changed the DLCI mappings on the subinterfaces. For subinterface s0/0.420, I bound it to frame-relay interface-dlci 520 and vice versa and it worked. Thanks for everyone's input on this.

123
Views
0
Helpful
13
Replies
CreatePlease to create content