Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

I gotta Problem.

Problem:

I just purchased a 4500 router (no problem there). However, somebody put 2600 IOS in the flash.

Another Problem:

The router has a password set so I can't even boot from ROM, which has the correct IOS (4500). In other words I can't go into enable mode.

One problem stops the other.

Any suggestions "ANYBODY"

Shug

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: I gotta Problem.

if it says that flash in read only mode, it looks like someone has not only installed the wrong flash image, but also installed some non supported flash simms

38 REPLIES
Silver

Re: I gotta Problem.

Not sure what you mean that you can not boot from ROM, because you can not enter enable mode in ROM Monitor mode. What I think you should do is to enter ROM Monitor mode, and use xmodem to copy the IOS image to the flash, then reboot.

New Member

Re: I gotta Problem.

I can't get xmodem from rommon

New Member

Re: I gotta Problem.

ok, let me see if I can futher explain. I"ve got a 4500 router thats been flashed with 2600 IOS. There is a password set that I don't know. After reading through the CISCO site, The recommedation is to boot from ROM. However to boot from ROM to reflash the router I need the password (of which I don't have).

Bronze

Re: I gotta Problem.

Ive never seen a 4500 but this works on the 2600/3600s. Press escape while the router is powering up, it should go into rommon mode.

New Member

Re: I gotta Problem.

I can get to rommon mode with no problem. Its what to do after. I can't load new main image or flash image because I don't have the password. And to recover the password, i need to boot from flash (of which I can't) due to the 2600 image being on a 4500 router.

Bronze

Re: I gotta Problem.

If you are booted to rommon the password is irrelvent. This is how you get around lost passwords. if its asking for a password you are not in rommon.

Bronze

Re: I gotta Problem.

in rommon see if the tftpdnld command exists. Dont use the ? just try it. If it does find the doc on cco for it by searching on that name. Another doc I found did not identify the router but was linked to by a 4500M page and said you have to get a flash pcmcia loaded on another router to use on this one. Is your flash pcmcia?

New Member

Re: I gotta Problem.

I don't have the option to change the baud rate to 115200, just 9600

Silver

Re: I gotta Problem.

Well, lets take it one by one. If you have the wrong IOS on the router, I expect the router to attempt to boot and then give an error message stating that the image file is not right. After this, it should restart, seems like it is attempting to boot, then go into rom monitor mode.

If it does not goes into rom monitor mode, after the first two lines of booting, (actually while it is trying to load the image file, either while decompressing, or just before decompressing) try hitting the ctrl and break key, that should take it also into rom monitor.

Please note that you need to be connected to the router via the console to do the above.

From the rom monitor, you will have a prompt such as

rommon 1 >

use the xmodem command to copy the right image to file.

Check the following link for how to copy image from ROM Monitor mode

http://www.cisco.com/en/US/products/hw/routers/ps259/products_tech_note09186a008015bfac.shtml

http://www.cisco.com/en/US/products/hw/modules/ps2797/products_module_installation_guide_chapter09186a00800ead70.html

Silver

Re: I gotta Problem.

Use confreg to change the baud rate. You will need to chnage your hyperterminal settings after you change the baud rate. If you do not change the baud rate and leave it at the default speed, your download will take ages.

New Member

Re: I gotta Problem.

rommon 2 > confreg

Configuration Summary

enabled are:

break/abort has effect

console baud: 9600

boot: the ROM Monitor

do you wish to change the configuration? y/n [n]: y

enable "diagnostic mode"? y/n [n]:

enable "use net in IP bcast address"? y/n [n]:

enable "load rom after netboot fails"? y/n [n]:

enable "use all zero broadcast"? y/n [n]:

disable "break/abort has effect"? y/n [n]:

enable "ignore system config info"? y/n [n]:

change console baud rate? y/n [n]: y

enter rate: 0 = 9600, 1 = 4800, 2 = 1200, 3 = 2400 [0]: 115

*** line too large ***

change the boot characteristics? y/n [n]:

New Member

Re: I gotta Problem.

System Bootstrap, Version 5.3(16) [richardd 16], RELEASE SOFTWARE (fc1)

Copyright (c) 1996 by cisco Systems, Inc.

C4500 processor with 32768 Kbytes of main memory

rommon 1 > xmodem -cy c4500-js-mz.12-7b

monitor: command "xmodem" not found

rommon 2 >

Silver

Re: I gotta Problem.

I guess that the console of that router can not do more 9600. Use that speed then and have patience. You might try flashing a small size image file, and then using either ftp or tftp download after you have gotten the router working back. The image transfer over tftp or ftp is much faster (in seconds) than the console (which might take hours with your 9600 speed).

Silver

Re: I gotta Problem.

I think you really have a old version of the boostrap, that is why the command is not there. Can you use the help command to list the available commands. Post this and lets see.

Silver

Re: I gotta Problem.

Now really sorry, I think I've been seriously wrong all along. The above procedures work well on other routers platform like 2600 and 3600, but not on the 4500. Check out the following links for info on what to do to your box

http://www.cisco.com/en/US/products/hw/routers/ps5199/products_tech_note09186a0080094012.shtml

http://www.cisco.com/warp/public/130/rommon_boot_image.html

New Member

Re: I gotta Problem.

Here in lies the problem, I've been here before. Now all would have to do is "en" and get the image. The problem is I don't have the password for this router. I can't do a password recovery due to the flash issue.

sa-amb(boot)>

New Member

Re: I gotta Problem.

You dont have any other choice other than the PCMCIA flash card. If you have similar router with PCMCIA flash card, load the proper image on that flash card, then move that PCMCIA card to your router. Then boot.

-Deepu

New Member

Re: I gotta Problem.

Hi there.

The prompt "sa-amb(boot)>" to me sounds like you're in what Cisco called RXBoot. This is a level 1/2 way between ROMMON and full featured IOS. See if you can get into ROMMON (cold boot router and press the Break key on your keyboard as soon as you see some message on the screen. I remebred that if you're using standard MS Hyper Terminal then Break won't work). ROMMON mode is the one where you can specify the values of config register. Specify a config register value of 0x2141 and then reboot your router. The value "4" specify "ignore config in NVRAM" and the last value "1" specify boot into RXBoot. You'll end up with the prompt "sa-amb(boot)>" like you did before and from here you should be able to get into priviledge mode without having to specify a password (default value). Post a reply once you have this working and I'll show you how to upload new IOS without XModem.

New Member

Re: I gotta Problem.

Nothing to be sorry about, I'm thankful for any and all help.

New Member

Re: I gotta Problem.

alias set and display aliases command

boot boot up an external process

break set/show/clear the breakpoint

confreg configuration register utility

cont continue executing a downloaded image

context display the context of a loaded image

cookie display contents of cookie PROM in hex

dev list the device table

dir list files in file system

dis disassemble instruction stream

dnld serial download a program module

frame print out a selected stack frame

help monitor builtin command help

history monitor command history

meminfo main memory information

repeat repeat a monitor command

reset system reset

set display the monitor variables

stack produce a stack trace

sync write monitor environment to NVRAM

sysret print out info from last system return

unalias unset an alias

unset unset a monitor variable

rommon 2 >

New Member

Re: I gotta Problem.

is it possible to setup a small tftp server and use tftpdnld from rommon ?

or isnt that commend supported in your bootstrap version ?

You could grab a spare laptop and setup the server on that.

Silver

Re: I gotta Problem.

Ok

1. tftp dpwnload will not work on a 4500 only on 2600's

2. If you were getting a [assword prompt earlier there must be a good image on it .

I saw eralier in the post you got the box to boot to router(boot)., this is good , get to this again dh a sh flash and post the sh flash .

New Member

Re: I gotta Problem.

Here in lies the problem. Someone load 2600 IOS onto this 4500 (I don't know why)

sa-amb(boot)>show flash

System flash directory:

File Length Name/status

1 4428372 c2600-i-mz.121-7

[4428436 bytes used, 3960172 available, 8388608 total]

8192K bytes of processor board System flash (Device not programmable)

sa-amb(boot)>

New Member

Re: I gotta Problem.

howeever, I can't get past the above due to this password issue:

sa-amb(boot)>show flash

System flash directory:

File Length Name/status

1 4428372 c2600-i-mz.121-7

[4428436 bytes used, 3960172 available, 8388608 total]

8192K bytes of processor board System flash (Device not programmable)

sa-amb(boot)>en

Password:

% Password: timeout expired!

Password:

% Password: timeout expired!

Password:

% Password: timeout expired!

% Bad passwords

sa-amb(boot)>en

Password:

Password:

Password:

% Bad passwords

sa-amb(boot)>

As you can see from a "sh ver"

sa-amb(boot)>show ver

Cisco Internetwork Operating System Software = 1200, 3 = 2400 [0]: 115C, 0 fra

IOS (tm) 4500 Bootstrap Software (C4500-BOOT-M), Version 10.3(7), RELEASE SOFTWA

RE (fc1)

any recommendations?

New Member

Re: I gotta Problem.

the system doesn't reconize the tftp portion of 'tftpdnld'. The system can't seem to find xmodem either.

Re: I gotta Problem.

Do the following:

1. break into rommon (press Break key during first 60 seconds

2. rommon1>confreg 0x2142

3. after setting above value to config register, it will prompt you to reset the router. Once its reset, the router will now boot into Rxboot mode (Router(boot)>) after ignoring your configuration files. Now it wont ask for any password.

4. configure an ip address for the ethernet interface and connect it to tftp server, and download new ios into flash using "copy tftp flash" command

Hope that helps!

New Member

Re: I gotta Problem.

See the show flash and show ver commands.

sa-amb(boot)>show flash

System flash directory:

File Length Name/status

1 4428372 c2600-i-mz.121-7

[4428436 bytes used, 3960172 available, 8388608 total]

8192K bytes of processor board System flash (Device not programmable)

sa-amb(boot)>en

Password:

% Password: timeout expired!

Password:

% Password: timeout expired!

Password:

% Password: timeout expired!

% Bad passwords

sa-amb(boot)>en

Password:

Password:

Password:

% Bad passwords

sa-amb(boot)>

As you can see from a "sh ver"

sa-amb(boot)>show ver

Cisco Internetwork Operating System Software = 1200, 3 = 2400 [0]: 115C, 0 fra

IOS (tm) 4500 Bootstrap Software (C4500-BOOT-M), Version 10.3(7), RELEASE SOFTWA

RE (fc1)

New Member

Re: I gotta Problem.

it continues to loop through the post below when I change to 0x2142 (I then did the break):

System Bootstrap, Version 5.3(16) [richardd 16], RELEASE SOFTWARE (fc1)

Copyright (c) 1996 by cisco Systems, Inc.

C4500 processor with 32768 Kbytes of main memory

loadprog: error - Invalid image for platform

e_machine = 43, cpu_type = 20

boot: cannot load "flash:"

System Bootstrap, Version 5.3(16) [richardd 16], RELEASE SOFTWARE (fc1)

Copyright (c) 1996 by cisco Systems, Inc.

C4500 processor with 32768 Kbytes of main memory

monitor: command "boot" aborted due to user interrupt

rommon 1 >

rommon 1 >

Re: I gotta Problem.

Change the config setting to 0x2141 (confreg 0x2141). This should take you to Rxboot mode.

HTH

221
Views
0
Helpful
38
Replies