Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Idle timer does not reset on interesting traffic

I would like to dial in with my PC ISDN adapter to my Cisco 2610 with a WIC-1B S/T. The config is as follows. If I dial in to the router all is working correct but the idle timer is not reseted if I start a ping or a telnet session over this established isdn link.

interface BRI0/0

description ISDN 031 748 02 20

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no peer default ip address

ppp authentication chap

interface Dialer2

ip unnumbered Loopback0

encapsulation ppp

dialer pool 1

dialer remote-name rfuchser

dialer string 0317480230

dialer-group 1

peer default ip address pool Dialin

ip local pool Dialin 192.168.140.10 192.168.140.15

access-list 101 deny eigrp any any log

access-list 101 permit ip any any log

dialer-list 1 protocol ip list 101

show dialer:

BRI0/0:1 - dialer type = ISDN

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is data link layer up

Interface bound to profile Di2

Time until disconnect 100 secs

Current call connected 00:00:20

Connected to 0317480230 (rfuchser)

Di2 - dialer type = DIALER PROFILE

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is data link layer up

Number of active calls = 1

Dial String Successes Failures Last DNIS Last status

0317480230 0 0 never - Default

7 REPLIES
Bronze

Re: Idle timer does not reset on interesting traffic

okay, first things first:

take off the line "ppp authentication chap" on the BRI interface and move it to your Dialer2 interface. After al, its the dailer interface that connects, The BRI is only the physical interface being used from a pool called "dialer pool 1"

Then add the following to your Dialer2 interfaceto enable time-outs:

dialer in-band

dialer idle-timeout 1800

no ip mroute-cache

hold-queue 20 in

The "no ip mroute-cache" is important , cos you don't want to cache routes.

You should also add" no cdp enable" on the dailer interface, unless you have already disabled CDP globally. The rest of your config looks fine.

Let us know if this sorted out your problem.

Cheers

New Member

Re: Idle timer does not reset on interesting traffic

o.k. may thanks

I configured as you suggested but now the ISDN is not working anymore. See below. Dialer in-band is not working with dialer profile at the same time. So far I have first removed the dialer pool 1 configuration from the di 2 interface. Why we have to configure the idle timer to 1800 it's 30 minutes. Should it not work with the default setting of 120s? O.k. cdp is relay not usable on links where no Cisco device is connected but should no affect the idle timer, is it? The hold queue adjustments are also a more cosmetic issue here. Before the changes I was able to open a telnet session to any host in my network for 120s without any packet loss.

interface BRI0/0

description ISDN 031 748 02 20

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no peer default ip address

interface Dialer2

ip unnumbered Loopback0

encapsulation ppp

no ip mroute-cache

dialer in-band

dialer idle-timeout 1800

peer default ip address pool Dialin

no cdp enable

ppp authentication chap

hold-queue 20 in

Mar 1 06:57:53.169: ISDN BR0/0:1: Incoming call rejected, unbindable

*Mar 1 06:57:53.177: ISDN BR0/0: TX -> RELEASE_COMP pd = 8 callref = 0x81

*Mar 1 06:57:53.181: Cause i = 0x8095 - Call rejected

Cisco Employee

Re: Idle timer does not reset on interesting traffic

120 secs of idle-timeout is default under the interface. With the exhisting config, if the link is getting disconnected because of idle-timeout expired, you will see that as disconnect reason when you turn on "debug dialer". You can confirm that.

Now direction of the interesting traffic which resets the idle-timeout is important.By default, the dialer idle-timeout is reset back to maximum by interesting traffic in the outbound direction. If only inbound traffic should reset the idle timeout, then use the additional keyword inbound. Use the either keyword for inbound and outbound traffic to reset the idle-timeout.

So you can enter following command under the interface dialer2

ppp authentication chap

dialer idle-timeout 300 either

That way the link will remain connected till 5 mins atleast and interesting traffic in both the directioin will reset the idle-timeout. I wrote a good document explaining that..visit following link

http://www.cisco.com/en/US/partner/tech/tk801/tk133/technologies_tech_note09186a0080094eb7.shtml

Bronze

Re: Idle timer does not reset on interesting traffic

The reason for the debug error:

ISDN BR0/0:1: Incoming call rejected, unbindable

is becuase you forgot to add: "dialer pool 1"

to the Dialer2 interface. This commands binds the BRI intrerface with the dialer interface upon a an incoming call. The number "1" is the common demoninator here.

I agree with tepalel's suggestions of adding "either" to the idle-timeout. That 300 second is much better than 1800 , the time I gave, was just an example.

Let us know.

New Member

Re: Idle timer does not reset on interesting traffic

I changed my configuration as requested. But the idle-timer is no reset back to maximum by interesting traffic. I think it doesn't matter what the timer max is set 120 (default) or any other settings (300, 1800...). important here is the in or either option. I tested also with the timer set to 120s it is the same problem. What I think here is the traffic is not linked to the dialer interface correctly. I mean the configuration of the dialer-group is important for triggering intressting traffic. This dialer-group configuration is missing if we are using dialer profiles (linked from bri 0/0 to dialer 2). Intressting to know here also is if I remove ppp authen chap on the bri 0/0 the dialer can not be allocated to bring up the dialer interface. I'm not sure is this a configuration problem or is this a bug in the software.

interface BRI0/0

description ISDN 031 748 02 20

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no peer default ip address

ppp authentication chap

interface Dialer2

ip unnumbered Loopback0

encapsulation ppp

dialer pool 1

dialer remote-name rfuchser

dialer idle-timeout 300 either

peer default ip address pool Dialin

ppp authentication chap

RT7#sh dialer

BRI0/0 - dialer type = ISDN

Dial String Successes Failures Last DNIS Last status

0 incoming call(s) have been screened.

0 incoming call(s) rejected for callback.

BRI0/0:1 - dialer type = ISDN

Idle timer (300 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is data link layer up

Interface bound to profile Di2

Time until disconnect 275 secs

Connected to 0317480230 (rfuchser)

Di2 - dialer type = DIALER PROFILE

Idle timer (300 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is data link layer up

Number of active calls = 1

Dial String Successes Failures Last DNIS Last status

New Member

Re: Idle timer does not reset on interesting traffic

Please make sure that you still have "dialer-group 1" configured on your dialer interface 2 (as well as the corresponding "dialer-list 1 protocol ip list 101").

You need to configure ppp authen chap on the BRI Interface, because the dialer binding is done by the "remote-name". The remote-name is negotiated by PPP CHAP.

There are two other methods of dialer binding (dialer called and dialer calling on the dialer interface), in these cases you don't need to use ppp authen chap on the BRI interface.

Regards,

Andreas

New Member

Re: Idle timer does not reset on interesting traffic

sorry I copied the wrong config, here is the running config. But the idle-timer is still not set back to max. I opened a telent session to a local router and started a debug to produce some traffic over the link which should be qualified as interesting traffic on ACL 101. It seems the incoming traffic is not qualified as interesting traffic on the dialer interface 2. But I'm not able to configure dialer-group on the physical bri interface in dialer profile configuration.

-------

config

-------

interface BRI0/0

description ISDN 031 748 02 20

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no peer default ip address

ppp authentication chap

interface Dialer2

ip unnumbered Loopback0

encapsulation ppp

dialer pool 1

dialer remote-name rfuchser

dialer idle-timeout 120 either

dialer-group 1

peer default ip address pool Dialin

ppp authentication chap

access-list 101 deny eigrp any any log

access-list 101 permit ip any any log

dialer-list 1 protocol ip list 101

---------

sh dialer

---------

BRI0/0:1 - dialer type = ISDN

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is data link layer up

Interface bound to profile Di2

Time until disconnect 42 secs

Connected to 0317480230 (rfuchser)

Di2 - dialer type = DIALER PROFILE

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is data link layer up

Number of active calls = 1

Dial String Successes Failures Last DNIS Last status

------

ACL

------

RT7#sh access-l

Extended IP access list 101

deny eigrp any any log (660 matches)

permit ip any any log (3 matches)

128
Views
0
Helpful
7
Replies