Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

IEEE 802.1Q VLAN Trunking on a Cisco 2610: no ip connectivity

A Catalyst 2950 Switch Port is configured for dot1q trunking and the 2610 (running IOS 12.2(8)T5) ethernet0/0 interface has two subinterfaces where dot1q encapsulation is configured.

VLAN 1 is configured as native VLAN, but you are not able to successfully ping each other. 'show cdp neigh detail' shows details about the switch/router, but there is no ip connectivity possible.

Is there any known IOS Bug or hardware restriction?

5 REPLIES
Cisco Employee

Re: IEEE 802.1Q VLAN Trunking on a Cisco 2610: no ip connectivit

I cant think of any known bugs. Can you paste the relevant configs from both the devices. Also visit the following page

http://www.cisco.com/warp/public/473/50.shtml

New Member

Re: IEEE 802.1Q VLAN Trunking on a Cisco 2610: no ip connectivit

Catalyst 2950:

!

interface FastEthernet0/10

spanning-tree portfast

!

interface FastEthernet0/11

switchport access vlan 2

spanning-tree portfast

!

interface FastEthernet0/12

switchport mode trunk

duplex full

speed 10

!

interface Vlan1

ip address 172.16.17.253 255.255.255.0

no ip route-cache

!

ip default-gateway 172.16.17.254

Cisco 2610:

interface Ethernet0/0

no ip address

full-duplex

!

interface Ethernet0/0.1

encapsulation dot1Q 1 native

ip address 172.16.17.254 255.255.255.0

!

interface Ethernet0/0.2

encapsulation dot1Q 2

ip address 172.31.31.94 255.255.255.224

VTP is configured for transparent mode on both devices.

In some docs I do find the requirement for a fastethernet I/F, but as I'm able to configure dot1q encapsulation this might not be valid for this software release. Should I try to run 12.2(11)T on 2610?

Cisco Employee

Re: IEEE 802.1Q VLAN Trunking on a Cisco 2610: no ip connectivit

Trunking is supported only on fast ethernet interfaces.

eso
New Member

Re: IEEE 802.1Q VLAN Trunking on a Cisco 2610: no ip connectivit

802.1Q encapsulation is now available on the built-in 10BaseT Ethernet interfaces of the Cisco 2610, 2611, and 2612 with Cisco IOS software 12.2(2)T

Re: IEEE 802.1Q VLAN Trunking on a Cisco 2610: no ip connectivit

Have you tried hard-coding the 2950 for dot1q ?

Example:

int fa0/12

switchport trunk encapsulation dot1q

switchport mode trunk

What does 'show int switchport' show on the 2950 for this port? Example output below.

Voice VLAN: none (Inactive)

Appliance trust: none

Name: Fa0/12

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

If it doesn't work after hard-coding it to dot1q, try removing the vlan 1 subinterface on the router and assigning the VLAN 1 IP address to the main ethernet interface (not subinterface) and see if VLAN 1 is working then between the router and switch. This should work if the link between 2950 and router is good since VLAN 1 isn't a tagged VLAN.

Erick

1095
Views
0
Helpful
5
Replies
CreatePlease to create content