Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

New Member

Improve Voice Quality

we are using cisco ATA 186 to make international call via IP i.e VOIP. We have a cisco 1600.

We have 256kpbs of bandwidth, same is used by quite a few users for other purpose like surfing etc...

When we make calls using this ata the call lag (latency) is very high some time it very bad we just can hear the other person.

I tried Priortiy Queuing and then i m using now Custom Queuing without much of change.

Can any help me in queuing or traffic shaping or any thing that can help me to improve with the latency. I dont mind if the other user get less bandwidth during the call period.

here is my config, the ip given to my ata 186 is denoted by C.C.C.226

Regds

RamP

!

ip subnet-zero

ip name-server A.A.A.A

isdn switch-type basic-ni

!

!

!

interface Ethernet0

ip address B.B.B.1 255.255.255.0 secondary

ip address c.c.c.225 255.255.255.224

no ip directed-broadcast

ip nat inside

!

interface Serial0

backup delay 30 60

backup interface BRI0

ip address D.D.D.D 255.255.255.252

no ip directed-broadcast

ip nat outside

custom-queue-list 1

!

interface BRI0

ip address negotiated

no ip directed-broadcast

ip nat outside

encapsulation ppp

dialer idle-timeout 300

dialer string 28529200

dialer hold-queue 10

dialer-group 1

isdn switch-type basic-net3

ppp authentication pap callin

ppp pap sent-username URURE@KSKSKS.COM password 7 141E1C0D05172E25757A075

!

ip nat inside source route-map rtm-nat-bri0 interface BRI0 overload

ip nat inside source route-map rtm-nat-ser0 interface Serial0 overload

ip nat inside source static C.C.C.226 D.D.D.D

ip nat inside source static F.F.F.3 C.C.C.227

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0

ip route 0.0.0.0 0.0.0.0 BRI0 100

ip route F.F.F.0 255.255.255.0 B.B.B.5

!

access-list 101 permit ip any any

access-list 101 deny icmp any any

access-list 102 permit tcp host C.C.C.226 any eq 16834

access-list 102 permit tcp host C.C.C.226 any eq 16835

queue-list 1 protocol ip 1 list 102

queue-list 1 default 2

queue-list 1 queue 1 byte-count 20480

queue-list 1 queue 2 byte-count 1

dialer-list 1 protocol ip list 101

route-map rtm-nat-ser0 permit 10

match interface Serial0

!

route-map rtm-nat-bri0 permit 10

match interface BRI0

!

!

2 REPLIES
New Member

Re: Improve Voice Quality

I would suggest

1.To use Low latency queing if your router IOS supports. Pls refer to

http://www.cisco.com/en/US/tech/tk543/tk757/technologies_tech_note09186a0080103eae.shtml

http://www.cisco.com/en/US/tech/tk543/tk757/technologies_tech_note09186a0080160fc1.shtml

2.To enable QOS features on in the ATA itself.

New Member

Re: Improve Voice Quality

I think the deafult codec for ATA is G711, if it is so try to make it G729 (You can have only one FXS port operating with this codec in ATA, this is product limitation). G729 minimizes the bandwidth needed.

Second, as said in the previuos posting use LLQ for voice or IP RTP Priority for simplicity. I recommand IP RTP priority here as you dont want to give any preferential treatment to other data traffic. If you face any difficulty during call setup give preferred treatment to VOIP signalling traffic with CBWFQ (in most of the cases it is not needed).

Since you are using NAT here, I assume you are connecting to local ISP. What ever I said above makes sense only if you have an SLA with your ISP for min end-to-end delay.

-Subba

85
Views
0
Helpful
2
Replies
CreatePlease to create content