Cisco Support Community
Community Member

inconsistent address & mask


I am attempting to add " ip route to a 2651. network is a dmz interface off of a pix 515. The router is saying that it is inconsistent address & mask. Currently, there would be a lot of work to change this to something more consistent like /24 dns, ip addresses, acl's etc... not a big deal but it would be nice to salvage work completed on this. Anyway, I was wondering if there's a routing workaround for this error without being overly complicated?




Re: inconsistent address & mask


this might be complaining due to the with that mask is not a network. Try this " ip route"

Hope that helps,


Community Member

Re: inconsistent address & mask

Hello !

what do you want to announce ?

network with subnet

or network with subnet ( <->

Community Member

Re: inconsistent address & mask





Re: inconsistent address & mask


With this mask this is a host addr not a network.


Community Member

Re: inconsistent address & mask


Maybe you can help me understand this. On the same router there are additional static's to get to various dmz int on the pix 515 fw and eigrp is running most of the network are /22 example: that are announced via eigrp.

router eigrp 100


ip route - to dmx on pix

ip route - to dmx2 on pix

why wouldn't the static's work using /22 and dynamic routing doesn't appear to have any problems?

thx again for you help,


Re: inconsistent address & mask

Routers would have the same problem. If you did a show ip route for you'd see that in your router the route would be Even in a router this static (17.0) would fail.

R1(config)#ip route null0

%Inconsistent address and mask

Ip routing protocols deal with networks (16.0) and not hosts. If you have further questions please let me know and I will try to clarify.



Community Member

Re: inconsistent address & mask

I will try to break it down very simple for you.  I probably dont know as much as these others guys as I am still studying for my CCNA test which I hope to take in the next couple of months. In fact all these other guys basically told you what was wrong as well.  I am going to give you a detailed explanation though and a way to combat this happening as well so forgive the wall of text!

However while studying I came across the same error but was able to figure out a fix.

The problem in simple layman terms is this:

When you enter a route the destination needs to be a subnet not a a valid IP address.

For example, if you had the IP subnet which is a Subnet Mask of 255.255.255. you have valid IP addresses from - is your subnet is your broadcast

So when your doing IP route command do this:


PxR1(config)#ip route ?

  A.B.C.D  Destination prefix    (look at this one its your clue see how it says Destination prefix?)

  profile  Enable IP routing table profile

  static   Allow static routes

  vrf      Configure static route for a VPN Routing/Forwarding instance r3-PxR1(config)#ip route ?
  A.B.C.D  Destination prefix
  profile  Enable IP routing table profile
  static   Allow static routes
  vrf      Configure static route for a VPN Routing/Forwarding instance


Its asking for the prefix which is the subnet so you would have to put in the subnet for  you didnt put in a subnet you put in a valid IP address that is assignable. is what block size?   you have to ask yourself what is the block size? If you know how to find your block sizes quickly you can figure this out easily.

252 in the third octet is the same block size as a 252 mask in the 4th octet right? Keep it simple in your head.So you have block size of 4. 

You know the IP Address you are trying to use is    what octet are we looking at?  we should be looking at the third octet correct? So we know from subnetting that there is no subnet that is  a multiple of anything other than 1, 2, 4, 8, 16, 32, 64, 128 right?   So you know something is pretty odd with your address right off the bat because none of those block sizes is divisble by 17 correct? So you should have warning signs go up just from looking at that address.

Also since we know the block size we can count up by fours   0, 4, 8, 12, 16 (and go ahead and count one more so you know your broadcast address as well) 20.

so your ip address your using is a valid ip address in the subnet of   Remember when when we did the actual command and used the question mark "?"  it told us it wanted the destination prefix so we need the subnet NOT a valid IP address which is what you used and why you got the error.

I really hope this explanation helps.

I will tell you what really changed my subnetting around and is the best subnetting technique out there and I have tried all the great instructors subnetting techniques.  Check out any of Todd Lammle study guide books on CCNA  7th edition or check out his web  page for the online video series he has (its really good). I studied alot of instructors stuff and they have really great stuff just like Todd Lammle but none of them can teach you to Master subnetting like he can its incredible =)

It really has changed how I can look at subnetting and addresses.  I can do them in my head now. Sure I make mistakes but I have only been using this technique for a couple of weeks!

P.S.  The other big thing is use the "?" help feature built into cisco equiptment its what made them famous, and it will help you out a ton



CreatePlease to create content