Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Initialization Failed for USER32.DLL

I have a problem installing CW 2000 4th

Edition with the patch for CD ONE.

Environment WIN NT4.0 SP 6a, IE 5.5 SP1

and a good ODBC component.

After starting the CW Server approx. at

the startingpoint for the RME-DB I receive

the following Message:

drwtsn32.exe – DLL Initialization Failed

Initialisation of the dynamic link library

C:\WINNT\system32\USER32.dll failed.

The process is terminatig abnormally

I tried to increase recources (desktop heap)according to the Microsoft Site

The registry value is:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\SubSystems\Windows

%SystemRoot%\system32\csrss.exe ObjectDirectory=\Windows

SharedSection=1024,3072,512 Windows=On SubSystemType=Windows

ServerDll=basesrv,1 ServerDll=winsrv:UserServerDllInitialization,3

ServerDll=winsrv:ConServerDllInitialization,2 ProfileControl=Off

MaxRequestThreads=16

Thanks in advance

2 REPLIES
Blue

Re: Initialization Failed for USER32.DLL

We've seen a few issues similar to this with the older version of CW2000, but not with the new versions. I'd suggest doing a clean reinstall on a Win2K machine.

New Member

Re: Initialization Failed for USER32.DLL

Thanks for the reply, what exactly are/were the issuese? Which version of cw2000 are you talking about? If there are known issuses could you please pass the Bug ID on to me?

Changing the OS is not a option because of the cost and the used OS -win nt 4.0- is supported. On my Laptop I have win2k running fine with cw2k. This means that the software itself is working.

I still need it to run on the supported Win NT 4.0 boxes!

Does anybody know what the problem is in order to correct it?

I tried the following (not a complete list):

Searched in Bug-Navigator: Nothing

Changed the desktop heap: Nothing

Changed the IE SP: Nothing

Changed the ODBC stuff (MDAC 2.5 to 2.7): Nothing

Changed the rights on e.g. CSCOpx: Nothing

Changed the install order: Nothing

Everytime I used a clean new (cw2k only) install!

This reminds me on the time when I tried to

use RME 2.0 and CWSI 2.2...

Using the same install WITHOUT the patch works better, but we are in the jear 2002, aren't we? And even here once in a while I get the USER32.DLL message!

I have the feeling that after filling the rme db and running for a couple of days the error stops! I assume, from the two mentioned reasons for USER32.DLL -according to MS- the second one

applies: resource problems. If it were a security problem it would apply allways. Is there a way to check/verify this? Can I change/delay the starting

behavior of cw2k?

Thanks in advance

187
Views
0
Helpful
2
Replies
CreatePlease login to create content