Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

InputErrors on Etherchannel despite low Utilization ???

Hi -

we are observing 0.01% and 0.12% InputErrors on an Etherchannel between a 6500 and a 4500 consisting of 4 (resp. 3) GigaBit Links. We discovered that the Packets were simply droped due to "Rx-No-Pkt-Buff" - We have a PRTG Graph showing a rather low utilization of 3% or less (5 min average) over the whole day or week. Customer experiences disconnect session in his SAP and Mainframe Aplications ...

Anybody any Idea how these errors could come into existance? The counters were cleared a few days ago to confirm this observation ...

The EtherChannel Load-Balancing is src-dst-ip (the default) - an the errors are distributed 15 - 30 % among the 4 ports.

Nothing Suspicious in the Logs - a few OutDiscards on some Ports/Channels to a range of servers.

Regards

Robert

10 REPLIES
Silver

Re: InputErrors on Etherchannel despite low Utilization ???

Hi Robert ,

Can you paste sh int gig output of both routers.

Thanks,

satish

New Member

Re: InputErrors on Etherchannel despite low Utilization ???

Below the show int:

(only 2/1 and 2/2 2/3-4 almost the same)

--------------------------------------------

GigabitEthernet2/1 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet Port, address is 000f.f742.e9f0 (bia 000f.f742.e9f0)

Description: Trunk zu hbmens03

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000-TX

input flow-control is on, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:05, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 6324000 bits/sec, 1168 packets/sec

5 minute output rate 541000 bits/sec, 159 packets/sec

8686920824 packets input, 10581825403873 bytes, 0 no buffer

Received 125157985 broadcasts (111201279 multicast)

5 runts, 0 giants, 0 throttles

9321859 input errors, 1 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

2346102954 packets output, 1775034484330 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

GigabitEthernet2/2 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet Port, address is 000f.f742.e9f1 (bia 000f.f742.e9f1)

Description: Trunk

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000-TX

input flow-control is on, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:05, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 1620000 bits/sec, 403 packets/sec

5 minute output rate 3448000 bits/sec, 821 packets/sec

12372257480 packets input, 17700592747377 bytes, 0 no buffer

Received 65152265 broadcasts (35997526 multicast)

1 runts, 0 giants, 0 throttles

14274963 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

3467908099 packets output, 1722413143410 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

New Member

Re: InputErrors on Etherchannel despite low Utilization ???

switch# sh int po1 count deta

Port InBytes InUcastPkts InMcastPkts InBcastPkts

Po1 11299925717041 8147189079 39181675 11400608

Port OutBytes OutUcastPkts OutMcastPkts OutBcastPkts

Po1 1420324404663 3283253668 1112846 440881

Port InPkts 64 OutPkts 64 InPkts 65-127 OutPkts 65-127

Po1 208434 43628 487833822 2308774325

Port InPkts 128-255 OutPkts 128-255 InPkts 256-511 OutPkts 256-511

Po1 112313899 75128140 164251318 19567566

Port InPkts 512-1023 OutPkts 512-1023

Po1 155207086 106542771

Port InPkts 1024-1522 OutPkts 1024-1522 InPkts 1523-1600 OutPkts 1523-1600

Po1 7277956803 774750965 0 0

Port Tx-Bytes-Queue-1 Tx-Bytes-Queue-2 Tx-Bytes-Queue-3 Tx-Bytes-Queue-4

Po1 1420309318663 0 98390 126238732

Port Tx-Drops-Queue-1 Tx-Drops-Queue-2 Tx-Drops-Queue-3 Tx-Drops-Queue-4

Po1 0 0 0 0

Port Dbl-Drops-Queue-1 Dbl-Drops-Queue-2 Dbl-Drops-Queue-3 Dbl-Drops-Queue-4

Po1 0 0 0 0

Port Rx-No-Pkt-Buff RxPauseFrames TxPauseFrames PauseFramesDrop

Po1 10715805 0 0 0

Port UnsupOpcodePause

Po1 0

Silver

Re: InputErrors on Etherchannel despite low Utilization ???

Hi ,

Did you check the port speeds on both ends.

Enable udld on 4500 and check whether it is enabled on 6500.

Thanks,

satish

New Member

Re: InputErrors on Etherchannel despite low Utilization ???

Dont think this is a speed error. All Ports are on 1000 full (auto). No udld -> RJ45/Cat5 ...

New Member

Re: InputErrors on Etherchannel despite low Utilization ???

I added a PRTG Graph of the Channel Utilization ..

Purple

Re: InputErrors on Etherchannel despite low Utilization ???

If you are seeing this across all 4 I would cast an eye on the patch cords if they are directly connected , should be cat 6 at a minimum.

New Member

Re: InputErrors on Etherchannel despite low Utilization ???

patch cords? The error is def. "Rx-No-Pkt-Buff" - patch cords might produce fcs, max aligment errors - I think we can exclude the patchcords ...

Thanks anyway

New Member

Re: InputErrors on Etherchannel despite low Utilization ???

I do have the same problem. Low utilization on the link but seeing increasing total output drops. Have digging for a long time but did not find anything yet.

New Member

Re: InputErrors on Etherchannel despite low Utilization ???

- we settled for design and internal switch problems/issues: head-of-line blocking and the 1Gbx4 per module oversupcription on the 4000 modules ...

- the customer himself discovered a bug wich increased these error counters without actually dropping the frames. (sorry don't remember the Bud # and IOS release ..)

753
Views
0
Helpful
10
Replies
CreatePlease to create content