Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

inter - area OSPF LSA 3 filtering

hello,

i try to implement this filtering:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080087be9.html

but it don't seems to work. and i don't found other explenation on the cisco site

got one router in area 0 (f0/0 ) and area 3 (f0/1.1 dot1q)

with this config:

router ospf 109

router-id 172.17.7.5

log-adjacency-changes

area 0 authentication

area 3 filter-list prefix AREA_0-vers-AREA_3 in

redistribute connected metric 50 subnets

redistribute static metric 50 subnets

network 172.27.64.14 0.0.0.0 area 0

network 172.27.65.253 0.0.0.0 area 3

distribute-list OSPF-CONNECTED out connected

distribute-list OSPF-STATIC out static

ip prefix-list AREA_0-vers-AREA_3 seq 5 permit 128.1.0.0/16

ip prefix-list AREA_0-vers-AREA_3 seq 10 permit 172.29.0.0/16

the second router has only this config:

interface Ethernet0/0

ip address 172.27.65.250 255.255.255.0

no ip directed-broadcast

!

interface Ethernet0/1

no ip address

no ip directed-broadcast

shutdown

!

router ospf 109

network 172.27.65.250 0.0.0.0 area 3

but i received all the routing table from the area 0

did i make something wrong ?

fabrice

4 REPLIES

Re: inter - area OSPF LSA 3 filtering

Although I am not familiar with the feature, I still hope the next will be of help:

As I read the posting, you want to filter outgoing routes from area 0 into area 3.

To achieve this, on the router attached to area 0 the filter should be set to outgoing: area 3 filter-list prefix AREA_0-vers-AREA_3 OUT.

You have interpreted the direction in/out as coming out of area 0 and in to area 3. I think this is not true, its out or in the interface that belongs to area 3.

Goodluck

Community Member

Re: inter - area OSPF LSA 3 filtering

i have already try both in fact, but it is the same. All IA and E2 ospf routes of area 0 are known by others routers in area 3.

:-(

Thanks anyway.

Fabrice

Community Member

Re: inter - area OSPF LSA 3 filtering

If you want to filter outgoing routes from area 0 into area 3

area 3 filter-list prefix AREA_0-vers-AREA_3 in

(change to out)

(if the 128.1.0.0/16 and 172.29.0.0/16 comes from AREA 0)

ip prefix-list AREA_0-vers-AREA_3 seq 5 permit 128.1.0.0/16

ip prefix-list AREA_0-vers-AREA_3 seq 10 permit 172.29.0.0/16

(change to deny)

Community Member

Re: inter - area OSPF LSA 3 filtering

well,

after many,many tests I give up.

the only think i can filter are IA ospf routes from the area 0.

when i put "permit" or "deny" in the prefix list, i got the same result ???

all E2 ospf routes learned by area 0 are learned by area 3 routers.

So i declared a second OSPF 110 process. redistribute ospf 109 in ospf 110 with redistribute list.

works in 10 minutes !!!

se u

153
Views
0
Helpful
4
Replies
CreatePlease to create content