Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Inter-Vlan issues

Hi,

I configured a 3550 switch for an Inter-Vlan routing. Tested the switch by pinging the laptops which are connected to different subnets. While going for lunch I took my laptop with me and connected again. Now i cannot ping other laptop.

The most wearied thing, I reloaded the switch and gave ping –t from my windows CLI. While reloading, both laptops pinged for a while and once again it says "Requested timed out".

I went through the configurations and it seems to be fine. Now, if some one knows why this is happening, please let me know. I welcome all your suggestions.

Thanks

Rajesh Krishnamurthy

5 REPLIES
New Member

Re: Inter-Vlan issues

Hi there,

Once again i reloaded my switch. The same thing happens. The ping goes for a while and says "Requested time out".

I never applied any ACL's or configured any other things. Just using Ip Routing for the intervlan routing.

Thanks

Rajesh

Re: Inter-Vlan issues

Rajesh,

Please paste the switch config and details on which ports the hosts are connected.

Also paste " show ip route ".

regards,

-amit singh

New Member

Re: Inter-Vlan issues

Hi Amith,

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

interface FastEthernet0/13

switchport access vlan 102

switchport mode access

no ip address

interface FastEthernet0/19

switchport access vlan 103

switchport mode access

no ip address

interface FastEthernet0/23

switchport access vlan 102

switchport mode access

no ip address

spanning-tree portfast

interface Vlan1

ip address 192.168.0.2 255.255.255.0

!

interface Vlan99

ip address 192.168.99.1 255.255.255.0

interface Vlan102

ip address 192.168.102.1 255.255.255.0

!

interface Vlan103

ip address 192.168.103.1 255.255.255.0

ip routing

My laptop ip is 192.168.103.10 and default gateway is 192.168.103.1. Other laptops ip is 192.168.102.10 and default gateway is 192.168.102.1.

For show ip route i am getting the output as

Gateway of last resort is not set

C 192.168.99.0/24 is directly connected, Vlan99

C 192.168.0.0/24 is directly connected, Vlan1

C 192.168.102.0/24 is directly connected, Vlan102

C 192.168.103.0/24 is directly connected, Vlan103

Every things seems to be clear and correct. D't know where i am going wrong.

Thanks

Rajesh

Re: Inter-Vlan issues

Rajesh,

This config seems to be OK. Ip routing is also enabled as you see the connected interface under the show ip route.

Check if you have any errors on the interfaces where you have your laptop connected. Also check for some internal firewalls.

Try disabling ip routing and enabling it again do a wr mem and reload the switch. Check the behaviour.

HTH, Please rate if it does.

-amit singh

New Member

Re: Inter-Vlan issues

Hi Amith,

This time when i did the above mentioned things i got "Reply from 192.168.103.1: Destination host unreachable" a few times and once again i am getting the message as "Requested time out".

Firewalls are off in both the PC's. I did show ip interface fastethernet 0/13, 0/19. It shows UP, UP.

I also don't know other things needed to be checked in the show interface command.

I know this is a basic inter-vlan routing configs and i d't know where i am messing up.

Thanks for all your help Mr Sing.

Rajesh

273
Views
0
Helpful
5
Replies
CreatePlease to create content