Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Inter VLAN ROuting

Hi Friends,

I need guidance regarding VLANs on L2 Switches(2950 Model).If I create VLANs on these How do they talk to each other. I have a 2600 Model Router. Suppose I create 3 VLANs on a Switch how are these 3 going to talk to each other. Simply Creating VLAns on 3 ports will suffice or anything to be Done at the Router End to enable Communicating of VLANs. I am a beginner to VLANs. Any one Pl. helpme on this.

Rgds

Srini

  • Other Network Infrastructure Subjects
4 REPLIES

Re: Inter VLAN ROuting

New Member

Re: Inter VLAN ROuting

The URL is not Openeing pl. give me Non-CCo Login

Rgds

Kalyan

Re: Inter VLAN ROuting

Hi,

it should open without CCO login.

It's public.

Regards,

Milan

Gold

Re: Inter VLAN ROuting

Using a 2600 series router and only one LAN interface, you need a "Plus" version of IOS in order to create subinterfaces on it. (Which may require more memory and flash in your router.) Then, configure the switch port the router plugs into to be an 802.1Q trunk port.

Here's an example of a configuration I have working on a 2620 router:

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 10.1.0.1 255.255.0.0

!

interface FastEthernet0/0.5

encapsulation dot1Q 5

ip address 10.5.0.1 255.255.0.0

!

interface FastEthernet0/0.16

encapsulation dot1Q 16

ip address 172.16.0.1 255.255.0.0

!

interface FastEthernet0/0.17

encapsulation dot1Q 17

ip address 172.17.0.1 255.255.0.0

!

The subinterface number (0/0.xxx) is arbitrary; I chose to match the "xxx" with the VLAN number on the encapsulation dot1Q xxx".

Whatever is the native VLAN defined on your switch port, that subinterface should also have it indicated with the "native" command line option. (See my 0/0.1 subint. for example.)

It's a one-armed router; but it works better than nothing, especially if you have other protocols to route besides TCP/IP. However, if all you have to route is IP, then inter-VLAN routing performance would be greatly improved if you had a 3550 series switch, even one with the SMI software. That's because you can activate Layer 3 switching of IP traffic on those, and define VLAN interfaces like this:

interface vlan1

ip address 10.1.0.1 255.255.0.0

!

interface vlan5

ip address 10.5.0.1 255.255.0.0

!

interface vlan16

ip address 172.16.0.1 255.255.0.0

!

interface vlan17

ip address 172.17.0.1 255.255.0.0

!

Hope this helps.

110
Views
0
Helpful
4
Replies