Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Interface utilization...Please help!

This is the issue: two 3640 routers bridged over a DS3 (45MB), hssi and atm interfaces, utilization on the interfaces never goes over 40-42 % and after performing large data transfer still never goes above 40-42% utilization. Does anybody have any ideas or similar issues, here is the configs:

Building configuration...

Current configuration : 4535 bytes

!

! Last configuration change at 13:41:14 EDT Wed Aug 6 2003

! NVRAM config last updated at 15:29:12 EDT Tue Aug 5 2003

!

version 12.2

no parser cache

no service single-slot-reload-enable

service timestamps debug datetime localtime show-timezone

service timestamps log datetime localtime show-timezone

service password-encryption

no service dhcp

!

hostname d-ds3

!

logging buffered 4096 debugging

logging rate-limit console 10 except errors

no logging console

no logging monitor

enable secret xxxxx

!

clock timezone EST -5

clock summer-time EDT recurring

ip subnet-zero

ip cef

!

!

no ip domain-lookup

!

no ip dhcp-client network-discovery

!

class-map match-any Exchange

match access-group 110

!

!

policy-map QoS-Policy

class Exchange

priority 33500

class class-default

fair-queue

!

bridge irb

!

!

!

interface FastEthernet0/0

no ip address

no ip redirects

speed 100

full-duplex

bridge-group 1

!

interface FastEthernet0/1

ip address 172.21.1.4 255.255.255.0

no ip redirects

speed 100

full-duplex

!

interface Hssi2/0

no ip address

no ip redirects

encapsulation ppp

crc 32

bridge-group 1

!

interface BVI1

ip address 172.18.2.23 255.255.0.0

no ip redirects

!

router eigrp 11453 network 172.18.0.0

network 172.21.0.0

distribute-list 20 out

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.21.1.1

no ip http server

!

no logging trap

access-list 20 deny any

access-list 110 permit ip 172.18.0.0 0.0.255.255 host 172.18.1.86

access-list 110 deny ip any any

snmp-server community xxxxxx

snmp-server chassis-id d-DS3

snmp-server enable traps snmp linkdown linkup coldstart warmstart

snmp-server enable traps config

snmp-server enable traps entity

snmp-server enable traps envmon

snmp-server enable traps syslog

snmp-server host 172.22.x.x

snmp-server host 172.22.x.x

bridge 1 protocol ieee

bridge 1 route ip

bridge 1 aging-time 14400

banner motd ^C

*****************************************************************************

* *

* WAN router *

* *

* This is a private system operated for and * *

* Authorization * *

* Use by unauthorized persons is prohibited. *

* *

*****************************************************************************

^C

!

line con 0

line aux 0

password xxxxx

modem InOut

transport input all

line vty 0 4

exec-timeout 120 0

password xxxxx

login

!

!

end

Any help is appreciated

12 REPLIES
Silver

Re: Interface utilization...Please help!

I am not sure what you are asking , if you want a more accurate picture of the load on an interface you can configure load-interval 30 on the interface it will calculate the load over a 30 sec time period as opposed to 5 minute which is default .

New Member

Re: Interface utilization...Please help!

What I mean is that I'm not getting a full 45 MB bandwidth on the link, only 40% of that, even when large amounts of data are being transferred, packets instead are being dropped, thank you.

Silver

Re: Interface utilization...Please help!

Are you sure this a full DS3 or is it a fractional ? Is the other end the same size pipe? Perhaps your serivce provider is policing you at 20Mb

New Member

Re: Interface utilization...Please help!

Yes, it is full DS3, provider just tested it a week ago and was able to push 44.7 MB, One side is a ATM int and the other a hssi int, thank you.

Silver

Re: Interface utilization...Please help!

what does the ATM config look like ?

Silver

Re: Interface utilization...Please help!

Also I see you have LLQ configured but it is not applied anywhere was it applied ?

New Member

Re: Interface utilization...Please help!

Sorry, no ATM, two hssi's (I'm working in two different issues)and the QOS policy was removed from all interfaces. Thanks again

Silver

Re: Interface utilization...Please help!

how do you know you are getting drops ?

Bronze

Re: Interface utilization...Please help!

When we were getting a DS3 for the Internet Cisco told us the 3640 could not forward data at that rate (even though it had the interface) and sold us a 7204. That was not the HSSI you are using but it may be the same issue.

On the other hand, what are you using to transfer the file and how far is the link. You need two fast servers using a large tcp window and a good sliding window protocol (FTP) to take advantage of the speed. Typical NOS file copies are inefficient and combined with distance based latency can kill your performance.

Bronze

Re: Interface utilization...Please help!

I've pushed ~40Mbits/sec through a 2621 with full-sized packets, so I'd be surprised if a 3640 couldn't handle a full DS3. Things may chance if you introduce access-lists/NAT/routing protocols/etc into the picture, however, but CPU usage should be maxed in any case if the router is the bottleneck.

New Member

Re: Interface utilization...Please help!

The two routers are about 50 miles away, there are several exchange servers running replication software across the DS3 link and it runs pretty slow, we tested the link by copying/pasting files between two different PC's but still was slow and utiliz never went pass 40 %, thanks to everyone for your ideas.

Bronze

Re: Interface utilization...Please help!

Try testing it with an application such as TTCP (Google for a Windows version if necessary) that is meant specifically to test link bandwidth. Windows file copies are about the worst possible way to test network bandwidth.

142
Views
0
Helpful
12
Replies
CreatePlease to create content