Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Intergrated Routing and Bridging (IRB) over Frame Relay Subinterface

Hello all together,

we have a problem with an IRB Configuration via an Frame Relay Network.

I shortly explain what we have done:

We have 2 Routers connected via Frame Relay pt-2-pt Subinterfaces. At both Routers we have the IRB Feature activated. At one Router we have configured an BVI interface and linked at to the FR Subinterface. The other Router should only bridge the incomming packets from the serial interface (s1/2.40) to the outgoing LAN Interface (e0/0.40). In the LAN environment is the remote IP Address from the BVI 1 Interface.

But this is not working. We have the same scenario with an serial leased Line (ppp encapsulation) and that works fine.

Here are extracts from the configs:

Router 1:

!

bridge irb

!

interface Serial0/0

bandwidth 384

no ip address

encapsulation frame-relay

no ip mroute-cache

no fair-queue

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Serial0/0.104 point-to-point

frame-relay interface-dlci 104

bridge-group 1

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 192.168.90.22 255.255.255.252

!

ip classless

ip route 192.168.90.240 255.255.255.240 192.168.90.21

!

bridge 1 protocol ieee

bridge 1 bitswap-layer3-addresses

bridge 1 route ip

!

end

Router 2:

!

bridge irb

!

interface Ethernet0/0.40

no ip proxy-arp

bridge-group 40

bridge-group 40 spanning-disabled

!

interface Serial0/0

bandwidth 384

no ip address

encapsulation frame-relay

no ip mroute-cache

no fair-queue

bridge-group 40

bridge-group 40 spanning-disabled

!

!

interface Serial0/0.40 point-to-point

frame-relay interface-dlci 40

bridge-group 40

bridge-group 40 spanning-disabled

!

bridge 40 protocol ieee

!

end

The DLCI is up and cdp information are already exchanged. What could be the reason that it will not work with Frame Relay encapsulation. Could it be a an problem with the address resolution or an IOS Bug?

As Appendix i ´ll provide you the output from debug arp, debug ip packets, debug frame-relay packets from Router 1:

ping 192.168.90.250

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.90.250, timeout is 2 seconds:

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, sending

6d01h: ICMP type=8, code=0

6d01h: IP ARP: creating incomplete entry for IP address: 192.168.90.21 interface BVI1

6d01h: IP ARP: sent req src 192.168.90.22 0000.0c53.13a9,

dst 192.168.90.21 0000.0000.0000 BVI1

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, encapsulation failed

6d01h: ICMP type=8, code=0

6d01h: Serial0/0: broadcast search

6d01h: Serial0/0:encaps failed on broadcast for link 38(BRIDGE)

6d01h: Serial0/0.104: broadcast search

6d01h: Serial0/0.104(o): dlci 104(0x1881), pkt type 0x6558, datagramsize 64

6d01h: bridged dest ffff.ffff.ffff, src 0000.0c53.13a9, type 806

6d01h: broadcast dequeue

6d01h: Serial0/0.104(o):Pkt sent on dlci 104(0x1881), pkt type 0x6558(BRIDGE), datagramsize 64

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, sending

6d01h: ICMP type=8, code=0

6d01h: IP ARP throttled out the ARP Request for 192.168.90.21

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, encapsulation failed

6d01h: ICMP type=8, code=0

6d01h: Serial0/0.104: Broadcast on DLCI 104 link 65(CDP)

6d01h: Serial0/0.104(o): dlci 104(0x1881), pkt type 0x2000(CDP), datagramsize 335

6d01h: broadcast dequeue

6d01h: Serial0/0.104(o):Pkt sent on dlci 104(0x1881), pkt type 0x2000(CDP), datagramsize 335

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, sending

6d01h: ICMP type=8, code=0

6d01h: IP ARP: sent req src 192.168.90.22 0000.0c53.13a9,

dst 192.168.90.21 0000.0000.0000 BVI1

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, encapsulation failed

6d01h: ICMP type=8, code=0

6d01h: Serial0/0: broadcast search

6d01h: Serial0/0:encaps failed on broadcast for link 38(BRIDGE)

6d01h: Serial0/0.104: broadcast search

6d01h: Serial0/0.104(o): dlci 104(0x1881), pkt type 0x6558, datagramsize 64

6d01h: bridged dest ffff.ffff.ffff, src 0000.0c53.13a9, type 806

6d01h: broadcast dequeue

6d01h: Serial0/0.104(o):Pkt sent on dlci 104(0x1881), pkt type 0x6558(BRIDGE), datagramsize 64.

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, sending

6d01h: ICMP type=8, code=0

6d01h: IP ARP: sent req src 192.168.90.22 0000.0c53.13a9,

dst 192.168.90.21 0000.0000.0000 BVI1

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, encapsulation failed

6d01h: ICMP type=8, code=0

6d01h: Serial0/0: broadcast search

6d01h: Serial0/0:encaps failed on broadcast for link 38(BRIDGE)

6d01h: Serial0/0.104: broadcast search

6d01h: Serial0/0.104(o): dlci 104(0x1881), pkt type 0x6558, datagramsize 64

6d01h: bridged dest ffff.ffff.ffff, src 0000.0c53.13a9, type 806

6d01h: broadcast dequeue

6d01h: Serial0/0.104(o):Pkt sent on dlci 104(0x1881), pkt type 0x6558(BRIDGE), datagramsize 64.

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, sending

6d01h: ICMP type=8, code=0

6d01h: IP ARP: sent req src 192.168.90.22 0000.0c53.13a9,

dst 192.168.90.21 0000.0000.0000 BVI1

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, encapsulation failed

6d01h: ICMP type=8, code=0

6d01h: Serial0/0: broadcast search

6d01h: Serial0/0:encaps failed on broadcast for link 38(BRIDGE)

6d01h: Serial0/0.104: broadcast search

6d01h: Serial0/0.104(o): dlci 104(0x1881), pkt type 0x6558, datagramsize 64

6d01h: bridged dest ffff.ffff.ffff, src 0000.0c53.13a9, type 806

6d01h: broadcast dequeue

6d01h: Serial0/0.104(o):Pkt sent on dlci 104(0x1881), pkt type 0x6558(BRIDGE), datagramsize 64

Success rate is 0 percent (0/5)

Thanx for any response.

2 REPLIES

Re: Intergrated Routing and Bridging (IRB) over Frame Relay Subi

Hi,

1) Remove the bridge-group commands from the s0/0 interfaces, and only put them on the sub-interfaces.

2) Take the global bridge command out to bitswap the addresses (its not needed).

3) On router 2, remove the IRB since you're just bridging between the 2 interfaces and not routing the bridged traffic on this router ( If I misunderstood, then a BVI40 interface will need to be added on Router 2. )

3) The static IP route overlaps with the BVI /30 but that won't prevent things from working in a classless environment on this router, but if device on remote LAN has a /28 IP subnet address and no route back to this /30 network then they'll need to add one.

Is there a device on routers 2 LAN with IP of 192.168.90.21 / 30 and 192.168.90.x / 28 network??? If so, check to make sure both IPs are up. One might not be up since those ranges overlap. Cisco routers don't allow overlapped networks (except on serial interfaces) so...

HTH, Erick

Re: Intergrated Routing and Bridging (IRB) over Frame Relay Subi

Disregard my comment about the IP subnet overlapping. Sorry.... posted to quick and too early in the morning.

715
Views
0
Helpful
2
Replies