Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Intergrated Routing and Bridging (IRB) over Frame Relay Subinterface

Hello all together,

we have a problem with an IRB Configuration via an Frame Relay Network.

I shortly explain what we have done:

We have 2 Routers connected via Frame Relay pt-2-pt Subinterfaces. At both Routers we have the IRB Feature activated. At one Router we have configured an BVI interface and linked at to the FR Subinterface. The other Router should only bridge the incomming packets from the serial interface (s1/2.40) to the outgoing LAN Interface (e0/0.40). In the LAN environment is the remote IP Address from the BVI 1 Interface.

But this is not working. We have the same scenario with an serial leased Line (ppp encapsulation) and that works fine.

Here are extracts from the configs:

Router 1:

!

bridge irb

!

interface Serial0/0

bandwidth 384

no ip address

encapsulation frame-relay

no ip mroute-cache

no fair-queue

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Serial0/0.104 point-to-point

frame-relay interface-dlci 104

bridge-group 1

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 192.168.90.22 255.255.255.252

!

ip classless

ip route 192.168.90.240 255.255.255.240 192.168.90.21

!

bridge 1 protocol ieee

bridge 1 bitswap-layer3-addresses

bridge 1 route ip

!

end

Router 2:

!

bridge irb

!

interface Ethernet0/0.40

no ip proxy-arp

bridge-group 40

bridge-group 40 spanning-disabled

!

interface Serial0/0

bandwidth 384

no ip address

encapsulation frame-relay

no ip mroute-cache

no fair-queue

bridge-group 40

bridge-group 40 spanning-disabled

!

!

interface Serial0/0.40 point-to-point

frame-relay interface-dlci 40

bridge-group 40

bridge-group 40 spanning-disabled

!

bridge 40 protocol ieee

!

end

The DLCI is up and cdp information are already exchanged. What could be the reason that it will not work with Frame Relay encapsulation. Could it be a an problem with the address resolution or an IOS Bug?

As Appendix i ´ll provide you the output from debug arp, debug ip packets, debug frame-relay packets from Router 1:

ping 192.168.90.250

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.90.250, timeout is 2 seconds:

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, sending

6d01h: ICMP type=8, code=0

6d01h: IP ARP: creating incomplete entry for IP address: 192.168.90.21 interface BVI1

6d01h: IP ARP: sent req src 192.168.90.22 0000.0c53.13a9,

dst 192.168.90.21 0000.0000.0000 BVI1

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, encapsulation failed

6d01h: ICMP type=8, code=0

6d01h: Serial0/0: broadcast search

6d01h: Serial0/0:encaps failed on broadcast for link 38(BRIDGE)

6d01h: Serial0/0.104: broadcast search

6d01h: Serial0/0.104(o): dlci 104(0x1881), pkt type 0x6558, datagramsize 64

6d01h: bridged dest ffff.ffff.ffff, src 0000.0c53.13a9, type 806

6d01h: broadcast dequeue

6d01h: Serial0/0.104(o):Pkt sent on dlci 104(0x1881), pkt type 0x6558(BRIDGE), datagramsize 64

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, sending

6d01h: ICMP type=8, code=0

6d01h: IP ARP throttled out the ARP Request for 192.168.90.21

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, encapsulation failed

6d01h: ICMP type=8, code=0

6d01h: Serial0/0.104: Broadcast on DLCI 104 link 65(CDP)

6d01h: Serial0/0.104(o): dlci 104(0x1881), pkt type 0x2000(CDP), datagramsize 335

6d01h: broadcast dequeue

6d01h: Serial0/0.104(o):Pkt sent on dlci 104(0x1881), pkt type 0x2000(CDP), datagramsize 335

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, sending

6d01h: ICMP type=8, code=0

6d01h: IP ARP: sent req src 192.168.90.22 0000.0c53.13a9,

dst 192.168.90.21 0000.0000.0000 BVI1

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, encapsulation failed

6d01h: ICMP type=8, code=0

6d01h: Serial0/0: broadcast search

6d01h: Serial0/0:encaps failed on broadcast for link 38(BRIDGE)

6d01h: Serial0/0.104: broadcast search

6d01h: Serial0/0.104(o): dlci 104(0x1881), pkt type 0x6558, datagramsize 64

6d01h: bridged dest ffff.ffff.ffff, src 0000.0c53.13a9, type 806

6d01h: broadcast dequeue

6d01h: Serial0/0.104(o):Pkt sent on dlci 104(0x1881), pkt type 0x6558(BRIDGE), datagramsize 64.

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, sending

6d01h: ICMP type=8, code=0

6d01h: IP ARP: sent req src 192.168.90.22 0000.0c53.13a9,

dst 192.168.90.21 0000.0000.0000 BVI1

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, encapsulation failed

6d01h: ICMP type=8, code=0

6d01h: Serial0/0: broadcast search

6d01h: Serial0/0:encaps failed on broadcast for link 38(BRIDGE)

6d01h: Serial0/0.104: broadcast search

6d01h: Serial0/0.104(o): dlci 104(0x1881), pkt type 0x6558, datagramsize 64

6d01h: bridged dest ffff.ffff.ffff, src 0000.0c53.13a9, type 806

6d01h: broadcast dequeue

6d01h: Serial0/0.104(o):Pkt sent on dlci 104(0x1881), pkt type 0x6558(BRIDGE), datagramsize 64.

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, sending

6d01h: ICMP type=8, code=0

6d01h: IP ARP: sent req src 192.168.90.22 0000.0c53.13a9,

dst 192.168.90.21 0000.0000.0000 BVI1

6d01h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, encapsulation failed

6d01h: ICMP type=8, code=0

6d01h: Serial0/0: broadcast search

6d01h: Serial0/0:encaps failed on broadcast for link 38(BRIDGE)

6d01h: Serial0/0.104: broadcast search

6d01h: Serial0/0.104(o): dlci 104(0x1881), pkt type 0x6558, datagramsize 64

6d01h: bridged dest ffff.ffff.ffff, src 0000.0c53.13a9, type 806

6d01h: broadcast dequeue

6d01h: Serial0/0.104(o):Pkt sent on dlci 104(0x1881), pkt type 0x6558(BRIDGE), datagramsize 64

Success rate is 0 percent (0/5)

Thanx for any response.

7 REPLIES

Re: Intergrated Routing and Bridging (IRB) over Frame Relay Subi

"encapsulation failed" message is in your output - this means that the router knows on which interface it has to send the packet, but doesn't know how to do it. The reason for this is it can't find the remote routers MAC (show arp should have 192.168.90.21 as incomplete). Can you change both bridge groups to the same number, example 1?

Hope it helps.

Steve

New Member

Re: Intergrated Routing and Bridging (IRB) over Frame Relay Subi

Hi,

There is encapsulation failure in the outgoing interface, so the problem should not be the remote router. But do your router config match the config of the frame-relay switch? e.g. maybe you need the command "encapsulation frame-relay ietf".

Best Regards

Teru Lei

New Member

Re: Intergrated Routing and Bridging (IRB) over Frame Relay Subi

I ´ve solved the encapsulation failed problem with an static arp entry in the Router. I think that both Router have a Problem to exchange arp or broadcast informations via frame relay. Although we configured the static arp it isn´t still not working.

This time we get an encaps failed on broadcast for link 38(BRIDGE). Has anybody an idea. ?

Here is the output of the debug commands again.

sending 5, 100-byte ICMP Echos to 192.168.90.250, timeout is 2 seconds:

6d00h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, sending

6d00h: ICMP type=8, code=0

6d00h: Serial0/0: broadcast search

6d00h: Serial0/0:encaps failed on broadcast for link 38(BRIDGE)

6d00h: Serial0/0.104: broadcast search

6d00h: Serial0/0.104(o): dlci 104(0x1881), pkt type 0x6558, datagramsize 118

6d00h: bridged dest 00c1.2603.157f, src 0000.0c53.13a9, type 800

6d00h: broadcast dequeue

6d00h: Serial0/0.104(o):Pkt sent on dlci 104(0x1881), pkt type

0x6558(BRIDGE), datagramsize 118.rÿ

6d00h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, sending

6d00h: ICMP type=8, code=0

6d00h: Serial0/0: broadcast search

6d00h: Serial0/0:encaps failed on broadcast for link 38(BRIDGE)

6d00h: Serial0/0.104: broadcast search

6d00h: Serial0/0.104(o): dlci 104(0x1881), pkt type 0x6558, datagramsize 118

6d00h: bridged dest 00c1.2603.157f, src 0000.0c53.13a9, type 800

6d00h: broadcast dequeue

6d00h: Serial0/0.104(o):Pkt sent on dlci 104(0x1881), pkt type

0x6558(BRIDGE), datagramsize 118.

6d00h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, sending

6d00h: ICMP type=8, code=0

6d00h: Serial0/0: broadcast search

6d00h: Serial0/0:encaps failed on broadcast for link 38(BRIDGE)

6d00h: Serial0/0.104: broadcast search

6d00h: Serial0/0.104(o): dlci 104(0x1881), pkt type 0x6558, datagramsize 118

6d00h: bridged dest 00c1.2603.157f, src 0000.0c53.13a9, type 800

6d00h: broadcast dequeue

6d00h: Serial0/0.104(o):Pkt sent on dlci 104(0x1881), pkt type

0x6558(BRIDGE), datagramsize 118.

6d00h: Serial0/0(i): dlci 103(0x1871), NLPID 0x3CC(IP), datagramsize 72

6d00h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, sending

6d00h: ICMP type=8, code=0

6d00h: Serial0/0: broadcast search

6d00h: Serial0/0:encaps failed on broadcast for link 38(BRIDGE)

6d00h: Serial0/0.104: broadcast search

6d00h: Serial0/0.104(o): dlci 104(0x1881), pkt type 0x6558, datagramsize 118

6d00h: bridged dest 00c1.2603.157f, src 0000.0c53.13a9, type 800

6d00h: broadcast dequeue

6d00h: Serial0/0.104(o):Pkt sent on dlci 104(0x1881), pkt type

0x6558(BRIDGE), datagramsize 118.

6d00h: IP: s=192.168.90.22 (local), d=192.168.90.250 (BVI1), len 100, sending

6d00h: ICMP type=8, code=0

6d00h: Serial0/0: broadcast search

6d00h: Serial0/0:encaps failed on broadcast for link 38(BRIDGE)

6d00h: Serial0/0.104: broadcast search

6d00h: Serial0/0.104(o): dlci 104(0x1881), pkt type 0x6558, datagramsize 118

6d00h: bridged dest 00c1.2603.157f, src 0000.0c53.13a9, type 800

6d00h: broadcast dequeue

6d00h: Serial0/0.104(o):Pkt sent on dlci 104(0x1881), pkt type

0x6558(BRIDGE), datagramsize 118.

Success rate is 0 percent (0/5)

Re: Intergrated Routing and Bridging (IRB) over Frame Relay Subi

Add the keyword "broadcast" at the end of your frame-relay interface-dlci 104 - so it will look like "frame-relay interface-dlci 104 broadcast". Add at both ends of the network.

Steve

Re: Intergrated Routing and Bridging (IRB) over Frame Relay Subi

The reason why it is sending broadcasts out the s0/0 interface because this also has a bridge-group defined which isn't needed it sounds like unless you have more then one frame connecion and rest of the DLCIs are on the s0/0 interface.

Anyway, if it's just the one DLCI on subinterface then remove the bridge-group commands on the s0/0 interface on both routers.

I had responded to this earlier, but now my post is gone. Hmm....

On router 2, IRB is not needed if you're not routing the bridging traffic on a BVI on that router. So remove bridge command from s0/0 and just put bridge command on subinterface and LAN interface.

Your BVi interface on Router 1 is a /30 subnet, so since router 2 doesn't have a BVI it looks like then the next-hop is a machine on the LAN at that location.

After the above changes, can you ping your next hop?

New Member

Re: Intergrated Routing and Bridging (IRB) over Frame Relay Subi

Hi all togehther,

we have done the changes that steve hast posted and removed the bridge Group from the serial Interfaces. But it still notworking.

The the next-hop is in deed a machine on the LAN at that location and we can´t ping it.

What makes this interesting is, if we use a serial leased Line with ppp encapsuluation it works fine and we can ping the machine on the LAN . With show bridge command at the Router 2 we see that packets will forward to e0.40 and s1.40 with the corresponding MAC Addresses. Fine:-)

But if change the serial encapsulation to FR or also X.25 we see also packets from the serial Interfaces corresponding MAC address not anymore from the ethernet Subinterface.

It seems to be maybe a broadcast /arp problem because FR and X.25 are both Non Broadcast Media.

Re: Intergrated Routing and Bridging (IRB) over Frame Relay Subi

If it were a point-to-multipoint subinterface I would suggest :

frame-relay map bridge 104 broadcast [ietf]

Steve

768
Views
0
Helpful
7
Replies