Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Internal IP reconfiguration.

I have a small network with an app server that we connect to using internal IP (192.168.20.xx) using DSL. After switching to a Frame Relay type of service with the new (TCP/IP) configuration (IP, DNS, Subnet Mask), my internet of course is faster but I am now unable to connect to my application server. However, if I make no changes on each computer with it's IP configuration and leave it on "Obtain an IP address automatically"--I am able to connect with my application server but not able to surf the internet. Is there a way of keeping my internal IP's and be able to connect to the internet?

5 REPLIES
New Member

Re: Internal IP reconfiguration.

Well I don't fully understand the situation here, but my assumption is that your workstations and app server are on your LAN and you LAN is connected to the internet via a router.

You must ensure that you app server and workstations are both in the same subnet, e.g. both have 192.168.20.xx addresses with 255.255.255.0 masks. Your internet connection router should also have an address in this subnet. Because this router is your link to the outside world this is your gateway, so it's address should be used as the default gateway for your PC and app server.

New Member

Re: Internal IP reconfiguration.

To add to what David said, which is all correct, many DSL modems will give an IP address in the 192.168.0.0 network (255.255.255.0), and set the IP address of its internal interface to 192.168.0.1. This would leave you unable to contact your application server at 192.168.20.xx. Unless your DSL modem allows you to configure which IP addresses are handed out via its DHCP server, you're left with the option of changing the IP address of your server to match the subnet handed out by the modem, and let your PCs get their IP addresses automatically.

New Member

Re: Internal IP reconfiguration.

Robert,

Thank you for your reply, I do have a new 1721 Cisco router and here are some info. What should I do with this router and my server app.

Thank you again.

[OK]

gw/OrthopedicMC#

gw/OrthopedicMC#sh ver

Cisco IOS Software, C1700 Software (C1700-Y-M), Version 12.3(2)XE, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

Synched to technology version 12.3(3.5)T

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2003 by Cisco Systems, Inc.

Compiled Wed 19-Nov-03 01:11 by ealyon

ROM: System Bootstrap, Version 12.2(7r)XM2, RELEASE SOFTWARE (fc1)

ROM:

gw/OrthopedicMC uptime is 22 minutes

System returned to ROM by power-on

System image file is "flash:c1700-y-mz.123-2.XE.bin"

Cisco 1721 (MPC860P) processor (revision 0x300) with 55208K/10328K bytes of memory.

Processor board ID FOC07481B9Z (3727625487), with hardware revision 0000

MPC860P processor: part number 5, mask 2

1 FastEthernet interface

1 Serial interface

WIC T1-DSU

32K bytes of NVRAM.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

gw/OrthopedicMC#sh run

Building configuration...

Current configuration : 1014 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname gw/OrthopedicMC

!

boot-start-marker

boot-end-marker

!

enable password xxxxxxxxxxxxx

!

no aaa new-model

ip subnet-zero

!

!

!

!

ip name-server xxx.xxx.29.12

ip name-server xxx.xxx.30.12

ip cef

no scripting tcl init

no scripting tcl encdir

!

!

!

!

interface FastEthernet0

description TO LOCAL LAN

ip address 63.201.112.225 255.255.255.224

speed auto

!

interface Serial0

description PB CKT 23.HCGM.008335..SUV

no ip address

encapsulation frame-relay IETF

service-module t1 timeslots 1-24

frame-relay lmi-type cisco

!

interface Serial0.1 point-to-point

ip address xxx.xxx.119.178 255.255.255.252

frame-relay interface-dlci 16

!

ip classless

ip route 0.0.0.0 0.0.0.0 68.xxx.xxx.177

no ip http server

!

!

!

control-plane

!

!

line con 0

password cnsc1

login

line aux 0

transport input all

flowcontrol hardware

line vty 0 4

password cnsc1

login

!

no scheduler allocate

!

end

gw/OrthopedicMC#ping xxx.xxx.219.25

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to xxx.xxx.219.25, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 20/21/24 ms

gw/OrthopedicMC#

New Member

Re: Internal IP reconfiguration.

To follow on....based on your configuration:

Your router's ethernet IP / Subnet mask are in network 63.201.112.224/255.255.255.224, which means that ligitimate IP addresses for your LAN are 63.201.112.225 - 63.201.112.254.

You router has the address 63.201.112.225, so you need to be assiging addresses to your workstations and application server other addresses in this range, with the subnet mask of 255.255.255.224. The default gateway for your workstations/app server should be that of the router 63.201.112.225.

Somewhere on your LAN you have a DHCP server, you can see from your config that it's not running on the router. Either you statically assign the above addresses to you devices or you could reconfigure the DHCP server to give out your free IP addresses.

Hope this anwers you question

New Member

Re: Internal IP reconfiguration.

David,

Thank you for your response. I will try this and hopefully it solves my problem.

Rosauro

184
Views
0
Helpful
5
Replies
CreatePlease to create content