Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

intervlan routing catalyst 4503

Dear all, I've been trying to get intervlan routing on my l3 switch working over the last week. somehow it still doesn't work.

I would like to make it possible that people can access the callmanager in vlan 100 (172.16.0.50 255.255.252.0) from an other vlan (e.g. vlan 20 192.168.0.1 255.255.255.0.

my management vlan is vlan 10 (172.16.100.0 255.255.255.0)

so far I've configured the vlans and gave them ip addresses in the ranges above.

I tried to give specific port an ip address, but I get the message that it overlaps with my vlan(s).

I've enabled ip routing.

could someone help and give a simple example of how it should work?

thanks in advance,

Gerard

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: intervlan routing catalyst 4503

Hi,

The config looks ok, just to clarify, you say you can ping hosts on each vlan from the switch. But cant get the hosts to ping each other, is this correct ?

If so, check you have added the correct default gateway address in the tcp/ip configuration on both your P.C.s. They should be the addresses you have defined in the vlan interfaces.

Cheers

Shaun

7 REPLIES
Silver

Re: intervlan routing catalyst 4503

There are two things to establish basic connectivity between VLANs

* The VLAN has an interfaces assigned to it

* The VLAN has a SVI ( switched virtual interface) with IP address

Show your routing table, show ip route. You should see that for both VLANs 20 and 100 there is a route in the table which states that the networks are directly connected.

Ping a host in the remote VLAN 100 from a host in VLAN 20. What happens? Use ICMP echo to verify connectivity.

Pay attention to VLAN assignments and potentially conflicting security configuration.

If that doesn't help post your configuration for further assistance.

Example configuration

interface vlan 10

ip address 172.16.100.0 255.255.255.0

interface vlan 20

ip address 192.168.0.1 255.255.255.0

interface Fa1/0/1

switchport mode access

switchport access vlan 20

interface Fa1/0/2

switchport mode access

switchport access vlan 20

...

HTH

Leon

* Please rate posts

New Member

Re: intervlan routing catalyst 4503

Hi Leon,

thanks.

from my switch (currently testing on a 3560) I can ping both networks.

result of sh ip route:

Gateway of last resort is 172.16.100.0 to network 0.0.0.0

172.16.0.0/24 is subnetted, 1 subnets

C 172.16.100.0 is directly connected, Vlan10

C 192.168.0.0/24 is directly connected, Vlan100

S* 0.0.0.0/0 [1/0] via 172.16.100.0

and my runing conf:

vlan internal allocation policy ascending

!

vlan 10

!

vlan 100

name Voice-Vlan

!

interface FastEthernet0/1

switchport access vlan 10

!

interface FastEthernet0/2

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/3

switchport access vlan 100

switchport mode access

!

interface Vlan1

no ip address

shutdown

!

interface Vlan10

ip address 172.16.100.1 255.255.255.0

!

interface Vlan100

ip address 192.168.0.1 255.255.255.0

!

router rip

network 192.168.0.0

!

no ip classless

ip route 0.0.0.0 0.0.0.0 172.16.100.0

ip http server

New Member

Re: intervlan routing catalyst 4503

i think you are putting network address at management vlan, you need to put like this"172.16.100.1 255.255.255.0."

-Check routing table, All the vlans are directly connected or not

-Check routing protocol properly broadcast network .

I think this may be help out

New Member

Re: intervlan routing catalyst 4503

hi vinodbharwani,

in my previous post you can see my ip route table.

as for the management vlan, currently not in use. I'm working on a stand alone switch just figure out how this routing works.

so from my switch I can ping ip addresses in both vlans. now I would like to ping from one vlan to the other. does anyone know how to do this?

New Member

Re: intervlan routing catalyst 4503

Can you ping from one vlan interface to another?

If so, then you should be able to have a pc on each segment ping each other.

New Member

Re: intervlan routing catalyst 4503

Hi,

The config looks ok, just to clarify, you say you can ping hosts on each vlan from the switch. But cant get the hosts to ping each other, is this correct ?

If so, check you have added the correct default gateway address in the tcp/ip configuration on both your P.C.s. They should be the addresses you have defined in the vlan interfaces.

Cheers

Shaun

New Member

Re: intervlan routing catalyst 4503

ah I had the gateway on my nics wrong. it was using a real gateway instead of my test case. how stupid..

thanks guys! it works

648
Views
4
Helpful
7
Replies
CreatePlease to create content