Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

InterVlan routing on cisco 2811

I am trying to do intervlan routing on a cisco 2811 fitted with a HWIC 4ESW card. I have created 3 vlans each with a different subnet ip address. Can anyone give me advice on how i would go about doing intervlan routing? Thanks in advance.

20 REPLIES

Re: InterVlan routing on cisco 2811

Hi,

As the vlans that you have created are directly connected, you just need to enable ip routing for perfomring inter-vlan routing. Enter the command 'ip routing' at the config prompt. That should work.

Refer the following link-->

http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_feature_guide09186a00802c6bb6.html

Hope this helps!

Regards,

AbhisheK

Please rate all helpful posts!!!

New Member

Re: InterVlan routing on cisco 2811

Thanks for responding. When i do "show ip route" it indeed shows that the 3 vlans are directly connected. As you have suggested i have done "ip routing" Now i have tried to ping the different interfaces and i get "destination unreachabe. Any ideas?

Re: InterVlan routing on cisco 2811

Hi,

You are welcome.

Can you please post the configuration?

Also have you given the command 'no shut' on all your vlans??

Regards,

AbhisheK

Re: InterVlan routing on cisco 2811

Hi,

As the vlans that you have created are directly connected, you just need to enable ip routing for perfomring inter-vlan routing. Enter the command 'ip routing' at the config prompt. That should work.

Refer the following link-->

http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_feature_guide09186a00802c6bb6.html

Hope this helps!

Regards,

AbhisheK

Please rate all helpful posts!!!

Re: InterVlan routing on cisco 2811

Hello,

make sure your configuration looks like this (IP addresses are arbitrary, you are probably using different ones):

ip routing

!

interface FastEthernet0/1/2

switchport access vlan 2

spanning-tree portfast

!

interface FastEthernet0/1/3

switchport access vlan 3

spanning-tree portfast

!

interface FastEthernet0/1/4

switchport access vlan 4

spanning-tree portfast

!

interface Vlan2

ip address 192.168.2.1 255.255.255.0

!

interface Vlan3

ip address 192.168.3.1 255.255.255.0

!

interface Vlan4

ip address 192.168.4.1 255.255.255.0

Make sure your Vlans exist in the Vlan database, you can verify this with the 'show vlan' exec command.

Where are you actually pinging from ?

Obviously, if you ping from a workstation, make sure the default gateway and subnet mask match the ones of the Vlan interface on the router...

Regards,

GNT

New Member

Re: InterVlan routing on cisco 2811

Thanks for responding. When i do "show ip route" it indeed shows that the 3 vlans are directly connected. As you have suggested i have done "ip routing" Now i have tried to ping the different interfaces and i get "destination unreachabe. Any ideas?

Bronze

Re: InterVlan routing on cisco 2811

Hii,

not to be more confused , it could be a small problem, so pls post ur config for your router & switch..

New Member

Re: InterVlan routing on cisco 2811

to GlobalNetTech

Thanks for your reply. I have followed your config example, with the exeption of the ip addresses for the diferent subnets.I have a laptop connected to the router and have tried to ping from one of the vlan interfaces ( i have changed the laptop ip to match the vlan)I can ping the interface on the vlan ok but if i try to ping a different interface on a different vlan i am still getting destination unreachable . i have also connected to FastEthernet0/0 with the same result?

New Member

Re: InterVlan routing on cisco 2811

Make sure interface is up for fe 0/0 fe 0/1 fe 0/2. good luck

Re: InterVlan routing on cisco 2811

Hello,

as previously suggested, if possible, can you post the configuration of the router, as well as the output of 'show ip route' ?

Regards,

GNT

Purple

Re: InterVlan routing on cisco 2811

Do a "show vlan" and make sure all your layer 2 vlans are defined. They should show active and it will tell you what ports are assigned to that vlan. Also when you are pinging , do a show ip int brief and make sure all the interfaces are up , you will need at least one active device on that vlan to bring it to a up/up state. i think you are a little confused on what a layer 2 vlan definition and layer 3 SVI is .

New Member

Re: InterVlan routing on cisco 2811

Hi everyone

I really do appreciate you all trying to help.Thanks.

i enclose a copy of my running config as well as the out from "show ip route" I have sent this as an attachment, hope this works, thanks again

Re: InterVlan routing on cisco 2811

Hello,

the output in the text file is somewhat scrambled, but it looks like only your Vlan2 and Vlan4 interfaces are up, while Vlan3 is not, probably because there is no active port on Vlan3.

When you connect a device to either the switchport configured to Vlan2 or Vlan4, can you then ping the respective other interface ?

Regards,

GNT

New Member

Re: InterVlan routing on cisco 2811

i have a laptop connected to vlan 2 and one to vlan 4. When i try to ping to the other vlan interface from each laptop i get "Destination host unreachable"

Re: InterVlan routing on cisco 2811

Hello,

what does a 'show vlan' say ? Is Vlan 4 actually existing in your VLAN database ?

Also, can you post your configuration here again, as a reply to a post rather than as an attachment ?

Regards,

GNT

New Member

Re: InterVlan routing on cisco 2811

copy of my config and show vlan

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$$ES_LAN$$FW_INSIDE$

ip address 82.110.135.1 255.255.255.128

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip route-cache flow

duplex auto

speed auto

no mop enabled

!

interface FastEthernet0/1

description $ES_WAN$$FW_OUTSIDE$

ip address 217.205.255.10 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip route-cache flow

duplex auto

speed auto

no mop enabled

!

interface FastEthernet0/0/0

!

interface FastEthernet0/0/1

switchport access vlan 4

spanning-tree portfast

!

interface FastEthernet0/0/2

switchport access vlan 2

spanning-tree portfast

!

interface FastEthernet0/0/3

switchport access vlan 3

spanning-tree portfast

!

interface Vlan1

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

!

interface Vlan2

ip address 10.0.0.50 255.0.0.0

!

interface Vlan3

ip address 172.20.

!

interface Vlan4

ip address 172.23.3.100 255.255.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0/1

!

ip http server

ip http authentication local

ip http timeout-policy idle 5 life 86400 requests 10000

ip nat inside source list 1 interface FastEthernet0/1 overload

!

logging trap debugging

access-list 1 remark INSIDE_IF=FastEthernet0/0

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 82.110.135.0 0.0.0.127

no cdp run

!

control-plane

!

banner login ^CAuthorized access only!

Disconnect IMMEDIATELY if you are not an authorized user!^C

!

line con 0

login local

transport output telnet

line aux 0

login local

transport output telnet

line vty 0 4

privilege level 15

login local

transport input telnet

line vty 5 15

privilege level 15

login local

transport input telnet

!

scheduler allocate 20000 1000

!

end

netgate03#netgate03#sh vlan-switch

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/0/0

2 VLAN0002 active Fa0/0/2

3 VLAN0003 active Fa0/0/3

4 VLAN0004 active Fa0/0/1

5 VLAN0005 active

1002 fddi-default active

1003 token-ring-default active

1004 fddinet-default active

1005 trnet-default active

Re: InterVlan routing on cisco 2811

Hello,

the config looks ok...

What does a 'route print' on your laptops show ? Can you post the output from both laptops, as well as the output of 'ipconfig' from both laptops ?

Regards,

GNT

New Member

Re: InterVlan routing on cisco 2811

Vlan 4

>route print

===========================================================================

Interface List

0x1 ........................... MS TCP Loopback interface

0x2 ...00 0e 35 80 09 fa ...... Intel(R) PRO/Wireless 2200BG Network Connection

- Packet Scheduler Miniport

0x3 ...00 0d 60 7a e4 5d ...... Intel(R) PRO/1000 MT Mobile Connection - Packet

Scheduler Miniport

===========================================================================

===========================================================================

Active Routes:

Network Destination Netmask Gateway Interface Metric

127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1

172.23.0.0 255.255.0.0 172.23.3.101 172.23.3.101 20

172.23.3.101 255.255.255.255 127.0.0.1 127.0.0.1 20

172.23.255.255 255.255.255.255 172.23.3.101 172.23.3.101 20

224.0.0.0 240.0.0.0 172.23.3.101 172.23.3.101 20

255.255.255.255 255.255.255.255 172.23.3.101 172.23.3.101 1

255.255.255.255 255.255.255.255 172.23.3.101 2 1

===========================================================================

Persistent Routes:

None

C:\Documents and Settings\eddieb>ipconfig

Windows IP Configuration

Ethernet adapter Wireless Network Connection:

Media State . . . . . . . . . . . : Media disconnected

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :

IP Address. . . . . . . . . . . . : 172.23.3.101

Subnet Mask . . . . . . . . . . . : 255.255.0.0

Default Gateway . . . . . . . . . :

Vlan 2

>route print

===========================================================================

Interface List

0x1 ........................... MS TCP Loopback interface

0x2 ...00 09 6b d0 1d 0d ...... Intel(R) PRO/100 VE Network Connection - Packet

Scheduler Miniport

0x3 ...00 0d 54 99 2b 4a ...... 3Com 3CRPAG175 Wireless LAN PC Card - Packet Sch

eduler Miniport

===========================================================================

===========================================================================

Active Routes:

Network Destination Netmask Gateway Interface Metric

10.0.0.0 255.0.0.0 10.0.0.51 10.0.0.51 20

10.0.0.51 255.255.255.255 127.0.0.1 127.0.0.1 20

10.255.255.255 255.255.255.255 10.0.0.51 10.0.0.51 20

127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1

224.0.0.0 240.0.0.0 10.0.0.51 10.0.0.51 20

255.255.255.255 255.255.255.255 10.0.0.51 10.0.0.51 1

255.255.255.255 255.255.255.255 10.0.0.51 3 1

===========================================================================

Persistent Routes:

None

C:\Documents and Settings\administrator.FLLP>ipconfig

Windows IP Configuration

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :

IP Address. . . . . . . . . . . . : 10.0.0.51

Subnet Mask . . . . . . . . . . . : 255.0.0.0

Default Gateway . . . . . . . . . :

Ethernet adapter Wireless Network Connection 4:

Media State . . . . . . . . . . . : Media disconnected

Silver

Re: InterVlan routing on cisco 2811

You need default a gateway configured on each laptop.

Purple

Re: InterVlan routing on cisco 2811

mmoris hit it on the head , you cannot get off your attached subnet with a default gateway on each user nic card . The gateway will be the defined router address for each subnet.

462
Views
25
Helpful
20
Replies
CreatePlease login to create content