Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Intervlan routing problem dot1q

Hi,

Hopefully someone out there will be able to help me with this. I have a pairs of 7204VXR and a pair of Cat 3550 SMI. I have connected port FE0/1 on each switch to one of the GE ports on each router. Each router has a seperate connection to the internet hooked into another GE interface.

I have configured the switch port as follows:

!

interface FastEthernet0/1

description 7204VXR scocore1

switchport trunk encapsulation dot1q

switchport trunk native vlan 101

switchport mode trunk

no ip address

!

This is the same for both switches. (note the switches have an etherchannel setup between them handling all VLANS. The switches have 5 VLANS configured with the routing handled by the 7204's using HSRP to failover. The config for the routers as follows:

Router 1

!

interface GigabitEthernet0/1

description CoreTrunk

no ip address

duplex auto

speed auto

media-type rj45

no negotiation auto

!

interface GigabitEthernet0/1.1

description CORE Lan

encapsulation dot1Q 101 native

ip address 62.128.192.2 255.255.255.128

standby 1 ip 62.128.192.1

standby 1 priority 10

standby 1 preempt delay minimum 120

standby 1 name COREhsrp

!

interface GigabitEthernet0/1.2

description S1 Lan

encapsulation dot1Q 102

ip address 62.128.192.130 255.255.255.240

standby 2 ip 62.128.192.129

standby 2 priority 10

standby 2 preempt delay minimum 120

standby 2 name S1hsrp

!

interface GigabitEthernet0/1.3

description MS COLO Lan

encapsulation dot1Q 103

ip address 62.128.195.2 255.255.255.192

standby 3 ip 62.128.195.1

standby 3 priority 10

standby 3 preempt delay minimum 120

standby 3 name mscolohsrp

!

interface GigabitEthernet0/1.4

description MISC COLO Lan

encapsulation dot1Q 104

ip address 62.128.195.66 255.255.255.192

standby 4 ip 62.128.195.65

standby 4 priority 10

standby 4 preempt delay minimum 120

standby 4 name misccolohsrp

!

interface GigabitEthernet0/1.5

description UNIX COLO Lan

encapsulation dot1Q 105

ip address 62.128.195.130 255.255.255.128

standby 5 ip 62.128.195.129

standby 5 priority 10

standby 5 preempt delay minimum 120

standby 5 name unixcolohsrp

!

interface GigabitEthernet0/3

ip address 195.97.229.206 255.255.255.252

duplex auto

speed auto

media-type rj45

no negotiation auto

!

Router 2 is identical except the IP's for hsrp.

If I plug a laptop into any VLAN and assign it a valid IP and gateway for that VLAN I can ping all the GE0/1.x interfaces on both routers and the virtual HSRP gateways. I can also ping the interface for GE0/3. What I cannot do is ping between two machines on different VLANS or ping from one VLAN to 195.97.229.205, which is a router at the oposite end of the /30. I can ping this from the router console.

I am at a loss as to why this is happening. Any help greatly appreciated.

Thanks,

Richard

  • Other Network Infrastructure Subjects
2 REPLIES

Re: Intervlan routing problem dot1q

Hi,

just some ideas:

1) aren't there any ACLs involved?

2) doublecheck if the default gateway is correct ot both PCs when pinging between VLANs

3) where exactly does the tracert stop?

4) running Ethereal on the target PC, are the Ping packets coming?

Regards,

Milan

Re: Intervlan routing problem dot1q

What are you using to route between the subnets? Do you have static routing or a dynamic routing protocol running? If your not picky, I would enable EIGRP on them, nice and simple, very easy to use.

Can you do a "sh standby" and does it show the Active/Standby router properly for each group?

Can you hardwire the speed/duplex on the ports?

As a hint to make things easier on you. We tend to use the VLAN # as the subinterface number (and the HSRP group) if possible for each VLAN. Makes things easier to remember, ie:

instead of G0/1.1, make it

!

interface GigabitEthernet0/1.101

description CORE Lan

encapsulation dot1Q 101 native

ip address 62.128.192.2 255.255.255.128

standby 101 ip 62.128.192.1

standby 101 priority 10

standby 101 preempt delay minimum 120

standby 101 name COREhsrp

just a suggestion, definitely not required...

119
Views
0
Helpful
2
Replies
This widget could not be displayed.