Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

InterVLAN Routing problems

Hello,

I have a 6509 switch with a SupII module and MSFC. Last night I attempted to establish VLANs and routing on this switch. I logged on to the switch and created the VLANs I needed. I assigned ports to each VLAN. Then I logged on tot he MSFC and created a VLAN interface for each VLAN along with an IP address. I turned on routing and nothing worked. From what I saw, the Sup Module on ports 1/1-2 was trunking all VLANs and the MSFC on port 15/1 was turnking all VLANs. I couldn't even ping the IP address of any of the VLANs I created, so I'm missing something. I've checked sample configs and can't find what I did wrong. Any insight would be appreciated. Let me know if you need more info/details.

Thanks,

-Tim

10 REPLIES
Bronze

Re: InterVLAN Routing problems

Please make sure that the vlan interfaces on the msfcs are up. Please paste the output of sh ip interface brief or sh interface vlan # from the msfc and sh trunk from the switch

New Member

Re: InterVLAN Routing problems

They are shutdown now because I had to revert everything back on the switch to VLAN 1 so the office could function today. I also had to remove the trunking on the Sup Module, but I've incluced the show trunk in case you see anything.

interface Vlan1

description MANAGEMENT

ip address 10.8.23.254 255.255.255.128

shutdown

!

interface Vlan20

description WORKSTATIONS and SERVERS

ip address 10.8.20.1 255.255.255.0

shutdown

!

interface Vlan22

description FIREWALL

ip address 10.8.22.2 255.255.255.128

shutdown

!

interface Vlan23

description WAN

ip address 10.8.23.2 255.255.255.128

shutdown

----------------------------

Console> (enable) sh trunk

* - indicates vtp domain mismatch

Port Mode Encapsulation Status Native vlan

-------- ----------- ------------- ------------ -----------

15/1 nonegotiate isl trunking 1

Port Vlans allowed on trunk

-------- ---------------------------------------------------------------------

15/1 1-1005,1025-4094

Port Vlans allowed and active in management domain

-------- ---------------------------------------------------------------------

15/1

Port Vlans in spanning tree forwarding state and not pruned

-------- ---------------------------------------------------------------------

15/1

Silver

Re: InterVLAN Routing problems

what routing protocol are you running on the Msfc ? do you have neighbors ?

New Member

Re: InterVLAN Routing problems

No nieghbors. EIGRP, although I could just as well use static routing since it's a small network.

Silver

Re: InterVLAN Routing problems

what does your eigrp config look like?

New Member

Re: InterVLAN Routing problems

Could you also paste the routing part of the config please ?

New Member

Re: InterVLAN Routing problems

There is no routing config right now. I removed that when I reverted back. Basically it was :

router eigrp

no auto-summary

network 10.8.0.0 0.0.255.255

Bronze

Re: InterVLAN Routing problems

If you are talking about intervlan routing, then you don;t need any routing protocol since these vlans interface will be directly connected interfaces and routing should work. Your config seems right but here are few things that you have to make sure when you do this test next time.

First of all , all the interfaces on the msfc should be up/up which you can verify by looking at the sh interface or sh ip interface brief.

2. Second make sure you have atleast one port in that vlan is connected and working , if you are doing trunking to other switch and these vlans are forwarding then it is ok.

3. DO show ip route on the msfc and see if the routes are showing up as directly connected interfaces.

4. Capture all this that will help in determining the problem, sh interface, sh ip interface brief sh ip route, sh ver, sh arp, sh trunk, sh mod , sh test 15 from the sup

make sure you are not on the boot prompt of the msfc.. like this (router(boot)#)

New Member

Re: InterVLAN Routing problems

Okay, so it's a little easier when you are setting up a trunk link between two switches because you set the port on each end to the desired trunking mode. But what are the specific steps if you are trunking between a 6509 switch and the MSFC?

I have a sup module. ports 1/1-3 (VLAN 1)

16 port gig module: ports 4/1-16 (VLAN 20)

48-port 10/10 module: ports 8/1-48 (VLAN 20, with a few ports on VLAN 23 and 21)

1 port MSFC: port 15/1(VLAN 1)

How would I configure each module so that the switch is trunking between itself and the MSFC? I think that's the step I'm missing to get this working right.

Thanks,

-Tim

Bronze

Re: InterVLAN Routing problems

By default there is the ISL trunking b/w MSFC and the sup,, As soon you define vlan interfaces on the msfc and they came up, sh trunk automatically starts showing those vlans to be forwarding. The only think you have to make sure that either there is trunk b/w two switches on which all the vlans are forwarding or atleast one active (up n working port means shows connected in show port) in each vlan to bring the vlan interface up on the msfc..

By the way what software version you are using on the sup and the msfc. Why don;t u create some dummy vlan on the sup/msfc - it should cause any problems n make sure you have something connected on that vlan and do no shut and see if that works. .

121
Views
0
Helpful
10
Replies
CreatePlease to create content