cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
254
Views
0
Helpful
4
Replies

intervlan routing

p-allen
Level 1
Level 1

we would like to implement vlan's on one of our wan's. We have a 2610 and 3550-48's. My question is: Is it better to set up the routing on the router or the switches? Do I still need ip routing on the switches if I set it up on the router?

4 Replies 4

Roberto Salazar
Level 8
Level 8

Vlan is a LAN concept, so not sure what you meant by implementing VLAN on WAN.

You can enable routing on the 3550 for inter-vlan traffic and any other traffic can be handle by the 2610. You will need default route for all unknown on 3550 to point to 2610 and on 2610 a static route to all the vlans in 3550.

For example, you have vlan 1, 2 and 3 on 3550. The 2610 is connected to 3550 via vlan 1 and the WAN or Internet.

3550:

interface vlan 1

ip address 1.1.1.1/24

interface vlan 2

ip address 2.2.2.2/24

interface vlan 3

ip address 3.3.3.3/24

ip route 0.0.0.0 0.0.0.0 1.1.1.2

2610:

interface fa0

ip address 1.1.1.2/24

ip route 2.2.2.0 mask 1.1.1.1

ip route 3.3.3.0 mask 1.1.1.1

above is just a simple example where the 3550 is doing the inter-vlan routing and the 2610 doing the routing for the rest of the traffic. Hope it helps.

you can used routing dynamic as eigrp

configure 2610 as internet router:

router eigrp 100

network 1.1.1.0

interface eth0/0

description ***to internet***

ip address 193.1.1.2 255.255.255.0

ip nat out

interface eth0/1

description0 ***To Lan***

ip address 1.1.1.1 255.255.255.0

ip nat in

ip nat inside source list 1 interface eth0/0 overload

access-list 1 permit 1.1.1.0

access-list 1 permit 2.2.2.0

access-list 1 permit 3.3.3.0

ip route 0.0.0.0 0.0.0.0 193.1.1.2

configure 3550 as Lan router:

router eigrp 100

network 1.1.1.0

network 2.2.2.0

network 3.3.3.0

interface vlan 1

ip address 1.1.1.1/24

interface vlan 2

ip address 2.2.2.2/24

interface vlan 3

ip address 3.3.3.3/24

please hope this help and rate this poste

escume add default route on 3550,

interface vlan

ip address 1.1.1.2/24

ip route 0.0.0.0 0.0.0.0 1.1.1.1

vladrac-ccna
Level 5
Level 5

Hello,

If you could better explain what is the topology and configuration of your network , it would help us understanding this scenario.

But, I believe using a l3 switch could be a better option expecially if you configure SDM (Switching Database Manager) for routing.

http://www.cisco.com/en/US/products/hw/switches/ps646/products_tech_note09186a0080094bc6.shtml

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: