Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

interVLAN routing

I'm trying to set up InterVLAN routing using a Cisco 1720 router and two Cisco 2950 switches using IEEE 802.1q encapsulation. The switches seems to take the configuration but the router keeps giving me the message "Configuring IP routing on a LAN subinterface is only allowed if that

subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q, or ISL vLAN." This occurs as I'm trnsfering the configuration text file into the router. When I look at the configuration (show run) the ip address of the subinterfaces are not present

Switch configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname SwitchD

!

interface VLAN1

ip address 192.5.5.253 255.255.255.0

no ip directed-broadcast

no ip route-cache

!

ip default-gateway 192.5.5.1

!

!

ip subnet-zero

!

!

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

switchport access vlan 2

spanning-tree portfast

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

switchport access vlan 3

spanning-tree portfast

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

switchport mode trunk

switchport trunk allowed vlan all

!

interface FastEthernet0/24

!

!

line con 0

transport input none

stopbits 1

line vty 5 15

!

end

Router configuration:

!

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname LabF

!

ip routing

router rip

network 200.10.25.0

!

!

!

!

!

interface FastEthernet0

no ip address

no shutdown

speed auto

!

interface FastEthernet0.1

encapsulation dot1Q 1

ip address 200.10.25.69 255.255.255.192

!

interface FastEthernet0.2

encapsulation dot1Q 2

ip address 200.10.25.132 255.255.255.192

!

interface Serial0

no ip address

shutdown

!

interface Serial1

no ip address

shutdown

!

ip classless

no ip http server

!

!

line con 0

line aux 0

line vty 0 4

!

no scheduler allocate

end

15 REPLIES
New Member

Re: interVLAN routing

Looking at your switch config you are using Vlan's 2 & 3 but on the router you are using Vlan's 1 & 2.

Do you get the error when pasting the router config of Fast0.1 ?

I would try creating Fast 0.2 & 0.3 on the router.

Regards

John

Bronze

Re: interVLAN routing

Are you also getting errors on the encapsulation statements? The 1720 doesnt support trunks. You need a 1721.

New Member

Re: interVLAN routing

And what IOS feature set are you running ? Dont you need at least IP Plus to be able to use trunking ?

New Member

Re: interVLAN routing

Try using a different vlan number apart from the native vlan 1.

New Member

Re: interVLAN routing

What IOS version are you running.

I have seen cases where you can wirte the confige to the router even when support for the command wasnt in the IOS.

/Regards Jonas

Bronze

Re: interVLAN routing

I repeat, the 1720 does not support vlans. The hardware in the ethernet interface cannot do it. I have one, I tried it, I found out I made a bad buy. You need a 1721 to do VLAN trunking. Here's the link.

http://www.cisco.com/en/US/customer/products/hw/routers/ps221/products_data_sheet09186a00800920ec.html

New Member

Re: interVLAN routing

Thanks for all your help. Just in case you are not aware this is for my semester 4 final for the Cisco networking academy class. I tried it with a 2501, and the same thing happened I guess i can assume the 2501 does not support trunks either.

Configuration text follows:

Router>

Router>en

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#

Router(config)#!

Router(config)#version 12.0

Router(config)#service timestamps debug uptime

Router(config)#service timestamps log uptime

Router(config)#no service password-encryption

Router(config)#!

Router(config)#hostname LabE

LabE(config)#!

LabE(config)#!

LabE(config)#!

LabE(config)#!

LabE(config)#!

LabE(config)#!

LabE(config)#ip subnet-zero

LabE(config)#no ip domain-lookup

LabE(config)#

LabE(config)#!

LabE(config)#!

LabE(config)#!

LabE(config)#process-max-time 200

LabE(config)#!

LabE(config)#interface Ethernet0

LabE(config-if)# no shutdown

LabE(config-if)# no ip address

LabE(config-if)#!

LabE(config-if)#interface Ethernet0.2

LabE(config-subif)#

LabE(config-subif)# ip address 200.10.25.69 255.255.255.192

Configuring IP routing on a LAN subinterface is only allowed if that

subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q, or IS

L vLAN.

LabE(config-subif)#!

LabE(config-subif)#interface Ethernet0.3

LabE(config-subif)#

LabE(config-subif)# ip address 200.10.25.132 255.255.255.192

Configuring IP routing on a LAN subinterface is only allowed if that

subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q, or IS

L vLAN.

LabE(config-subif)#!

LabE(config-subif)#interface Serial0

LabE(config-if)# no ip address

LabE(config-if)# no ip directed-broadcast

LabE(config-if)# no ip mroute-cache

LabE(config-if)# shutdown

LabE(config-if)# no fair-queue

LabE(config-if)#!

LabE(config-if)#interface Serial1

LabE(config-if)# no ip address

LabE(config-if)# no ip directed-broadcas

00:03:37: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up

00:03:38: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed sta

te to upt

LabE(config-if)# no ip mroute-cache

LabE(config-if)# shutdown

LabE(config-if)#!

LabE(config-if)#router rip

LabE(config-router)# network 200.10.25.0

LabE(config-router)#!

LabE(config-router)#no ip classless

LabE(config)#ip http server

LabE(config)#!

LabE(config)#banner motd ^CInterVLAN Routing by Zabel^C

LabE(config)#!

LabE(config)#line con 0

LabE(config-line)# password class

LabE(config-line)# login

LabE(config-line)# transport input none

LabE(config-line)#line aux 0

LabE(config-line)#line vty 0 4

LabE(config-line)# password class

LabE(config-line)# login

LabE(config-line)#!

LabE(config-line)#end

LabE#

LabE#LabE#

00:03:41: %SYS-5-CONFIG_I: Configured from console by console

I have a 2514, I guess I'll have to use each ethernet port to accomplish my task although I did want to show the kids "router on a stick". Any other ideas?

New Member

Re: interVLAN routing

Looking at the way you're trying to configure the sub-interface it seems you're trying to add the ip address right after creating the sub-interface.

LabE(config-subif)#interface Ethernet0.3

LabE(config-subif)#

LabE(config-subif)# ip address 200.10.25.132 255.255.255.192

Configuring IP routing on a LAN subinterface is only allowed if that

subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q, or IS

L vLAN.

I think you need to configure the encapsulation FIRST and then add the IP address.

c2600(config)#int fastEthernet 0/0.1

!-- Enter the trunking encapsulation as either isl

c2600(config-subif)#encapsulation isl 1

!-- or as dot1q:

!-- In case of dot1q, you need to make sure that

!-- the native VLAN matches across the link.

!-- On 3512XL, by default, the native VLAN is 1.

!-- On the router, configure VLAN1 as the native VLAN.

c2600(config-subif)#encapsulation dot1Q 1 ?

native Make this is native vlan

c2600(config-subif)#encapsulation dot1Q 1 native

!-- On the switch, if you have a native VLAN other than VLAN1,

!-- on the router, configure the same VLAN to be the native VLAN,

!-- by using the above command.

!-- Configure L3 information on the sub-interface 0/0.1.

c2600(config-subif)#ip address 10.10.10.1 255.255.255.0

c2600(config-subif)#exit

Hope this helps.

Bronze

Re: interVLAN routing

I'm not sure if this helps, it depends on what you had to do for your lab. You could use one vlan and put both IP addresses on the one router interface using the secondary command. Both IP networks would share the same segment but they would have to bounce off of the router to talk to each other.

New Member

Re: interVLAN routing

I'll try both suggestions and let you know, I cannot use ISL as my 2950 switches do not support that protocol

New Member

Re: interVLAN routing

I tried the encapsulation prior to to the ip address and got the following:

Router>en

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#

Router(config)#!

Router(config)#version 12.0

Router(config)#service timestamps debug uptime

Router(config)#service timestamps log uptime

Router(config)#no service password-encryption

Router(config)#!

Router(config)#hostname LabE

LabE(config)#!

LabE(config)#!

LabE(config)#!

LabE(config)#!

LabE(config)#!

LabE(config)#!

LabE(config)#ip subnet-zero

LabE(config)#no ip domain-lookup

LabE(config)#

LabE(config)#!

LabE(config)#!

LabE(config)#!

LabE(config)#process-max-time 200

LabE(config)#!

LabE(config)#interface Ethernet0

LabE(config-if)# no shutdown

LabE(config-if)# no ip address

LabE(config-if)#!

LabE(config-if)#interface Ethernet0.2

LabE(config-subif)# encapsuation dot1q 2

^

% Invalid input detected at '^' marker.

LabE(config-subif)# ip address 200.10.25.69 255.255.255.192

Configuring IP routing on a LAN subinterface is only allowed if that

subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q, or IS

L vLAN.

LabE(config-subif)#!

LabE(config-subif)#interface Ethernet0.3

LabE(config-subif)# encapsuation dot1q 3

^

% Invalid input detected at '^' marker.

LabE(config-subif)# ip address 200.10.25.132 255.255.255.192

Configuring IP routing on a LAN subinterface is only allowed if that

subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q, or IS

L vLAN.

LabE(config-subif)#!

LabE(config-subif)#interface Serial0

LabE(config-if)# no ip address

LabE(config-if)# no ip directed-broadcast

LabE(config-if)# no ip mroute-cache

LabE(config-if)# shutdown

LabE(config-if)# no fair-queue

LabE(config-if)#!

LabE(config-if)#interface Serial1

LabE(config-if)# no ip address

00:05:44: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up

00:05:45: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed sta

te to up

LabE(config-if)# no ip directed-broadcast

LabE(config-if)# no ip mroute-cache

LabE(config-if)# shutdown

LabE(config-if)#!

LabE(config-if)#router rip

LabE(config-router)# network 200.10.25.0

LabE(config-router)#!

LabE(config-router)#no ip classless

LabE(config)#ip http server

LabE(config)#!

LabE(config)#banner motd ^CInterVLAN Routing by Zabel^C

LabE(config)#!

LabE(config)#line con 0

LabE(config-line)# password class

LabE(config-line)# login

LabE(config-line)# transport input none

LabE(config-line)#line aux 0

LabE(config-line)#line vty 0 4

LabE(config-line)# password class

LabE(config-line)# login

LabE(config-line)#!

LabE(config-line)#end

LabE#

LabE#LabE#

00:05:48: %SYS-5-CONFIG_I: Configured from console by console

I guess that doesn't work

New Member

Re: interVLAN routing

OK one more time, I have two 2950 switches connected together (trunked) via port 23, I've got a 1720 router connected on one switches port 1, I've got 4 hosts connected, one on each port 5 and one on each port 10. Port 5 is on vlan 2 and port 10 is on vlan 3, the hosts are on seperate subnets. I can ping the router from the switches, but I cannot communicate betwwen hosts on seperate subnets. The hosts use the default gateway of thier respective subnet. The hosts can ping their counterpart, but cannot ping the router. Configurations follow, Any futher thoughts.

SwitchD:

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname switchD

!

!

ip subnet-zero

vtp domain Conard

vtp mode transparent

!

vlan 2

!

vlan 3

!

spanning-tree extend system-id

!

!

interface FastEthernet0/1

no ip address

!

interface FastEthernet0/2

no ip address

!

interface FastEthernet0/3

no ip address

!

interface FastEthernet0/4

no ip address

!

interface FastEthernet0/5

switchport access vlan 2

no ip address

!

interface FastEthernet0/6

no ip address

!

interface FastEthernet0/7

no ip address

!

interface FastEthernet0/8

no ip address

!

interface FastEthernet0/9

no ip address

!

interface FastEthernet0/10

switchport access vlan 3

no ip address

!

interface FastEthernet0/11

no ip address

!

interface FastEthernet0/12

no ip address

!

interface FastEthernet0/13

no ip address

!

interface FastEthernet0/14

no ip address

!

interface FastEthernet0/15

no ip address

!

interface FastEthernet0/16

no ip address

!

interface FastEthernet0/17

no ip address

!

interface FastEthernet0/18

no ip address

!

interface FastEthernet0/19

no ip address

!

interface FastEthernet0/20

no ip address

!

interface FastEthernet0/21

no ip address

!

interface FastEthernet0/22

no ip address

!

interface FastEthernet0/23

switchport mode trunk

no ip address

!

interface FastEthernet0/24

no ip address

!

interface Vlan1

ip address 200.10.25.126 255.255.255.192

no ip route-cache

!

ip default-gateway 200.10.25.65

ip http server

!

!

line con 0

line vty 5 15

!

end

SwitchE:

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname switchE

!

!

ip subnet-zero

vtp domain Conard

vtp mode transparent

!

vlan 2

!

vlan 3

!

spanning-tree extend system-id

!

!

interface FastEthernet0/1

switchport mode trunk

no ip address

!

interface FastEthernet0/2

no ip address

!

interface FastEthernet0/3

no ip address

!

interface FastEthernet0/4

no ip address

!

interface FastEthernet0/5

switchport access vlan 2

no ip address

!

interface FastEthernet0/6

no ip address

!

interface FastEthernet0/7

no ip address

!

interface FastEthernet0/8

no ip address

!

interface FastEthernet0/9

no ip address

!

interface FastEthernet0/10

switchport access vlan 3

no ip address

!

interface FastEthernet0/11

no ip address

!

interface FastEthernet0/12

no ip address

!

interface FastEthernet0/13

no ip address

!

interface FastEthernet0/14

no ip address

!

interface FastEthernet0/15

no ip address

!

interface FastEthernet0/16

no ip address

!

interface FastEthernet0/17

no ip address

!

interface FastEthernet0/18

no ip address

!

interface FastEthernet0/19

no ip address

!

interface FastEthernet0/20

no ip address

!

interface FastEthernet0/21

no ip address

!

interface FastEthernet0/22

no ip address

!

interface FastEthernet0/23

switchport mode trunk

no ip address

!

interface FastEthernet0/24

no ip address

!

interface Vlan1

ip address 200.10.25.190 255.255.255.192

no ip route-cache

!

ip default-gateway 200.10.25.129

ip http server

!

!

line con 0

line vty 5 15

!

end

Router:

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname InterVlan

!

!

memory-size iomem 25

ip subnet-zero

!

!

!

!

interface FastEthernet0

ip address 200.10.25.129 255.255.255.192 secondary

ip address 200.10.25.65 255.255.255.192

speed auto

!

interface Serial0

no ip address

shutdown

!

interface Serial1

no ip address

shutdown

!

router rip

network 200.10.25.0

!

ip classless

no ip http server

!

!

line con 0

line aux 0

line vty 0 4

login

!

end

Thanks for any and all help. After tommorrow (Friday) I'll be on school vacation for week.

Re: interVLAN routing

What you need is "router on the stick".

See http://www.cisco.com/warp/public/473/50.pdf

for details or search "InterVLAN routing" on CCO.

Regards,

Milan

New Member

Re: interVLAN routing

I've tried that document, the 1720 doesn't support trunking

Re: interVLAN routing

Well, you've got three possibilities then:

a) use another router which does support 802.1q trunking

b) use some router with two Ethernet ports, connect each of them to a different VLAN a route between them;

c) put WIC-1ENET card to your 1720 nad configure it as in b)

See http://www.cisco.com/en/US/customer/products/hw/routers/ps221/products_data_sheet09186a0080088714.html for details.

I've never used this card and I'm not sure if it works this way. But according to the datasheet it should.

Regards,

Milan

296
Views
0
Helpful
15
Replies
CreatePlease to create content