Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

InterVlan Trunking between Catalyst 500 Express and Router 1841

Hello,

I am currently attempting to configure 2 VLANs on a Router 1841 and allow them to communication with my Catalyst 500 Express switch. The Router Setup is simple

its 3 Sub-ints on the FE0/0 interface.

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

description *** ADMINISTERING VLAN ***

encapsulation dot1Q 1 native

ip address 10.19.1.1 255.255.255.0

!

interface FastEthernet0/0.2

description *** DATA VLAN ***

encapsulation dot1Q 2

ip address 10.19.2.1 255.255.255.0

!

interface FastEthernet0/0.3

description *** VOICE VLAN ***

encapsulation dot1Q 3

ip address 10.19.3.1 255.255.255.0

ip helper-address 10.19.2.2

FE 0/0 Port on the Router is connected to port 24 on my Catalyst. I set the Smartport on port 24 of the Catalyst to be Router for trunking purposes

I get a notification error on the Catalyst saying "Undersized frames detected from the connected device" (which is my ROUTER).

does anyone have a suggestion? Or Is it supported this scenario?

Thanks,

Eduardo

4 REPLIES
Blue

Re: InterVlan Trunking between Catalyst 500 Express and Router 1

can you post the config of your switch? what is the IOS version?

this could be a 'false' error as some cats/IOS have reported errors on dot1q frames of 61-64 bytes including the q-tag.

(affected ios are 12.1(19)ea1d, 12.1(20)ea1a, 12.1(22)ea1+ and 12.1(20)se1)

verify your MTU settings on the router and switch. also, try to set the router and switch to 100/full statically, not using auto.

New Member

Re: InterVlan Trunking between Catalyst 500 Express and Router 1

This is the config of the switch and the version 12.2(25)FY

I check the mtu setting and in the interface fasthernet 0/0 router is in 1500 and in the interface fastethernet 24 in the switch is in 1546, I tried to modify but is not allowed.

New Member

Re: InterVlan Trunking between Catalyst 500 Express and Router 1

I had the same issue when I was working on CE500s and a WLC.

In the CE500 Device Manager, go to Configure->VLANs

Create your VLAN 2 and 3.

Then go back to smartports, click customize, and verify that VLAN-1 is default (native).

Sending information through a port on the CE500 that it is not expecting will set alerts in the log.

Hope this helps.

RB

New Member

Re: InterVlan Trunking between Catalyst 500 Express and Router 1

Hi RB,

I check in the smartports, customize and the default native vlan in the router port is the vlan 1.

Thanks

181
Views
0
Helpful
4
Replies
CreatePlease to create content