Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Inverse arp and NBMA networks

Hello,

My question is about the nature of inverse arp:

I've seen that if I configure a meshed Frame relay Networks with subinterfaces (point-to-point but also multipoint), if the inverse ARP is not activated, to permit the routing update of a routing protocol, I've had to set up the keyword "broadcast" at the end of the "frame relay map" commands.

If instead the inverse arp is active the command "frame relay map" is useless, I've only specified the "frame realy DLCI" on the sub interfaces, and the routing protocol work well, without that I add the keyword "broadcast" from no part. My question is:

IF the inverse arp is active, broadcast is permitted

by default?

and again, the inverse arp notifications is a broadcast itself?

thank's very much in advance.

Graziano

8 REPLIES
New Member

Re: Inverse arp and NBMA networks

These are really separate issues.

inverse arp is the mechanism that allows a router to discover the IP address on the other side of a point-to-mulitpoint frame PVC and associate that IP address with that PVC. Frame-relay map is the mechanism to configure this manually. They are mutually exclusive.

broadcast only applies to point-to-mulipoint configurations. point-to-point sub-interfaces don't need to broadcast as such since there is only one other host to send data to.

broadcast needs to be enabled on point-to-multipoint configurations if broadcast or multicast packets need to go over the frame. If you're using RIP or OSPF, for instance, and choose not to use the neighbor statements, broadcast will need to be enabled.

Mick.

New Member

Re: Inverse arp and NBMA networks

Hi Mick,

thank you very much for the answer, I've understood but...

Look this example, a router with a subinterface multipoint with the inverse arp is enabled:

-----------------------------------------------

interface FastEthernet0/0

ip address 10.11.11.250 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

no ip address

encapsulation frame-relay

frame-relay lmi-type ansi

!

interface Serial0/0.1 multipoint

ip address 172.16.0.2 255.255.255.0

frame-relay interface-dlci 704

frame-relay interface-dlci 709

router eigrp 1234

passive-interface FastEthernet0/0

network 10.0.0.0

network 172.16.0.0

no auto-summary

no eigrp log-neighbor-changes

-------------------------------------------------

Can you explane me why this configuration work well without the keyword "broadcast" at the frame relay-dlci command level?

thank's,

Graz

New Member

Re: Inverse arp and NBMA networks

You shouldn't be using Frame-relay interface-dlci on a multipoint interface. Its redundant. Use either inverse arp or frame map. interface-dlci is used to map a PVC to a point-to-point sub-interface.

Mick.

New Member

Re: Inverse arp and NBMA networks

Hi Mick,

really, I've tryed in lab that, if I work with inverse arp, if I've a multipoint subinterface with

3 dlci I must specifie this, because the FR switch

doesn't know the subinterface itself.

If I don't write the FR dlci command the network doesn't work... then I don't think that it is redundant... what do you think about?

PS: sorry for my very bad english...

rgds,

Graz

New Member

Re: Inverse arp and NBMA networks

You are correct.

If you're using multiple point-to-multipoint subinterfaces, and you wish to use inverse-arp, you need to associate the DLCI with the appropriate subinterface. My mistake.

Guess I'm outa practice on reading questions lately. :-/

Mick.

New Member

Re: Inverse arp and NBMA networks

Well,

thank you very much Mick!

rgds,

Graz.

New Member

Re: Inverse arp and NBMA networks

Hi.

You asked: "IF the inverse arp is active, broadcast is permitted by default? "

Answer: YES. You can check with the "show frame-relay map" command.

Regarding the Inverse ARP notifications being a broadcast itself... I'm not sure, but I do think so (at the IP layer of course).

Rgds.

NM

New Member

Re: Inverse arp and NBMA networks

Hi Nuno,

Thank's very much for the answer, perfect!

Bye,

Graz.

246
Views
0
Helpful
8
Replies