Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

IOS DHCP Failure

I have a client using IOS DHCP at a remote site. Initially, his clients get an address but the renew process fails. He can do a manual release all and then renew all which works. Does anyone have any thoughts on why the automatic renewal 1/2 way through the lease fails? I'm drawing a blank.

5 REPLIES
Purple

Re: IOS DHCP Failure

Make sure there is no manually assigned broadcast address (subnet.255) assigned to the interface his subnet is on . We had this assigned on some interfaces in our environment and it caused the exact problem you are seeing . It needs to see a regular broadcast 255.255.255.255 which the router then forwards to the assigned helper addresses.

New Member

Re: IOS DHCP Failure

Glen, I know the original problem was stated as an (IOS DHCP) event. I'm assuming that he is possibly using an external router with a dynamic dhcp pool. My question to you is if this were an RSM blade on a cisco switch and I was planning to use the ip helper-address command, would I need to configure a 255.255.255.255 on that port-channel interface (vlan) or can I get away with the (subnet.255) assignment? I'm just wondering that's all. I would appreciate any input if you have encountered this or if you in fact know what the config might look like,

Thanks in advance,

~Alonzo

Purple

Re: IOS DHCP Failure

You should not have to configure a broadcast address at all , it should be determined by the ip address and the subnet mask . We ran into trouble when we did have a subnet.255 address defined at the vlan interface level . Once we eliminated this everything worked the way it should .

New Member

Re: IOS DHCP Failure

Thanks. The router doesn't have a manually assigned Broadcast. The router is a 2612 and has a scope for TR and Ethernet. We found that the problem is only on the TR side. I see you work for IBM; can you think of why that is? The config below has the MTU set at 2052 to fix a different problem.

ip dhcp excluded-address 10.1.51.1 10.1.51.100

ip dhcp excluded-address 10.1.50.1 10.1.50.150

!

ip dhcp pool ethernet

network 10.1.51.0 255.255.255.0

domain-name cisco.com

default-router 10.1.51.1

dns-server 10.1.11.7 10.1.10.5 10.1.10.15

lease 7

!

ip dhcp pool tokenring

network 10.1.50.0 255.255.255.0

default-router 10.1.50.1

domain-name cisco.com

dns-server 10.1.11.7 10.1.10.5 10.1.10.15

lease 7

!

interface Ethernet0/0

ip address 10.1.51.1 255.255.255.0

half-duplex

!

interface TokenRing0/0

mtu 2052

ip address 10.1.50.1 255.255.255.0

ring-speed 16

!

router rip

network 10.1.0.0

!

ip classless

New Member

Re: IOS DHCP Failure

Hello,

Your configuration looks fine (assuming the token ring end stations also have a mtu set to 2052). If the manual release/renew works, then we know there isn't a problem with how the router receives the frames. At this point, the only real way to figure out what is happening is to get a sniffer trace of the problem, or get the following debugs:

debug ip dhcp server packet

debug ip dhcp server event

debug ip dhcp server linkage

These debugs will tell us what the router is doing with the request when it comes in, and may help us understand why the process is failing.

210
Views
0
Helpful
5
Replies