Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

IOS DHCP server

I need to setup a IOS dhcp server for nortel voip phones. I have info on what the phone does during dhcp handshake:

1. Requests options (via option 55) 43, 128,144,157,191

2. It gets an address and a option with the vlan it should be on (voice vlan)

3. It drops the address and re-requests its dhcp info form the voice vlan

I am using Version 12.2(18)SXE2 on 6509 720 supervisor. I am setting up a voice vlan for phones. Does anyone know how to configure DHCP raw options to allow nortel phone to attach to voice vlan and obtain voip ip address?

Option 191 should be used to tell what vlan to attach to for voice.

Does anyone have info on how to configure the raw options in a IOS DHCP server? I am using 12.2(18) on 6509 720 supervisor. I can't find any good documentation on all the parameters.

Thanks

3 REPLIES
Community Member

Re: IOS DHCP server

ip dhcp excluded-address 10.x.x.1 10.x.x.10

!

ip dhcp pool Voice

network 10.x.y.0 255.255.255.0

option 150 ip 10.x.y.1

default-router 10.x.y.1

where 10.x.y.1 is the service engine( Call Manager Express) interface Service-Engine0/1

hope this helps

Community Member

Re: IOS DHCP server

Thanks for the response, my main issue is getting the nortel voip phones to attach to the voice vlan and the pc that is using the switch in the voip phone to be in the data vlan. I have an article that tells me which options to setup for an ISC dhcp server, so I need to setup the same options in the IOS server, but I don't understand the syntax for the IOS server raw option parameter.

Community Member

Re: IOS DHCP server

For anyone interested, through trial and error I made a Nortel phone get reconnected to voice vlan and pc attached to internal switch on phone attach to data network

1. Setup Nortel VoIP phone for "full DHCP"

2.Create DHCP pools in IOS with options

ip dhcp pool TestDataVoIP (DATA VLAN temporarily vlan 1)

network 172.17.0.0 255.255.0.0

default-router 172.17.0.2

option 191 ascii "VLAN-A:10."

option 128 ascii "Nortel-i2004-A."

ip dhcp pool Test_VoIP (VOICE VLAN 10)

network 172.18.0.0 255.255.0.0

default-router 172.18.0.1

option 128 ascii "Nortel-i2004-A,172.18.0.10:4100,1,5;172.18.0.10:4100,1,7."

3. configure switchport for voice vlan

interface FastEthernet1/0/1

switchport mode access

switchport voice vlan 10

duplex full

speed 100

spanning-tree portfast

Attach Nortel phone to port and powerup

Debug messages on IOS DHCP server:

06:36:14: DHCPD: DHCPDISCOVER received from client 000a.e40c.118a on interface Vlan1.

06:36:21: DHCPD: Sending DHCPOFFER to client 000a.e40c.118a (172.17.0.9).

06:36:21: DHCPD: creating ARP entry (172.17.0.9, 000a.e40c.118a).

06:36:21: DHCPD: unicasting BOOTREPLY to client 000a.e40c.118a (172.17.0.9).

06:36:21: DHCPD: DHCPDISCOVER received from client 000a.e40c.118a on interface Vlan1.

06:36:21: DHCPD: Sending DHCPOFFER to client 000a.e40c.118a (172.17.0.9).

06:36:21: DHCPD: creating ARP entry (172.17.0.9, 000a.e40c.118a).

06:36:21: DHCPD: unicasting BOOTREPLY to client 000a.e40c.118a (172.17.0.9).

06:36:22: DHCPD: DHCPREQUEST received from client 000a.e40c.118a.

06:36:22: DHCPD: Sending DHCPACK to client 000a.e40c.118a (172.17.0.9).

06:36:22: DHCPD: creating ARP entry (172.17.0.9, 000a.e40c.118a).

06:36:22: DHCPD: unicasting BOOTREPLY to client 000a.e40c.118a (172.17.0.9).

06:36:22: DHCPD: DHCPRELEASE message received from client 000a.e40c.118a (172.17.0.9).

06:36:32: DHCPD: DHCPDISCOVER received from client 000a.e40c.118a on interface Vlan10.

06:36:39: DHCPD: Sending DHCPOFFER to client 000a.e40c.118a (172.18.0.6).

06:36:39: DHCPD: creating ARP entry (172.18.0.6, 000a.e40c.118a).

06:36:39: DHCPD: unicasting BOOTREPLY to client 000a.e40c.118a (172.18.0.6).

06:36:39: DHCPD: DHCPDISCOVER received from client 000a.e40c.118a on interface Vlan10.

06:36:39: DHCPD: Sending DHCPOFFER to client 000a.e40c.118a (172.18.0.6).

06:36:39: DHCPD: creating ARP entry (172.18.0.6, 000a.e40c.118a).

06:36:39: DHCPD: unicasting BOOTREPLY to client 000a.e40c.118a (172.18.0.6).

06:36:48: DHCPD: DHCPDISCOVER received from client 000a.e40c.118a on interface Vlan10.

06:36:48: DHCPD: Sending DHCPOFFER to client 000a.e40c.118a (172.18.0.6).

06:36:48: DHCPD: broadcasting BOOTREPLY to client 000a.e40c.118a.

06:36:49: DHCPD: DHCPREQUEST received from client 000a.e40c.118a.

06:36:49: DHCPD: Sending DHCPACK to client 000a.e40c.118a (172.18.0.6).

06:36:49: DHCPD: broadcasting BOOTREPLY to client 000a.e40c.118a.

331
Views
0
Helpful
3
Replies
CreatePlease to create content