Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

IP-Address Assignment for Dialin-Users via IOS DHCP-pool

Following configuration:

is it possible to point on the TACACS-Server to the local configured DHCP-Pool-Name like its possible for a "ip local pool poolname"

!

aaa authentication ppp default group tacacs+

aaa authorization network default group tacacs+

!

ip dhcp excluded-address 192.168.44.1

ip dhcp bootp ignore

!

ip dhcp pool ras_pfw

network 192.168.44.0 255.255.255.248

netbios-name-server 172.16.1.29

netbios-node-type h-node

domain-name pfw.aero

dns-server 172.16.1.53 172.16.1.54

lease 0 0 1

!

interface Loopback0

ip address 192.168.44.1 255.255.255.248

!

interface BRI0

ip unnumbered Loopback0

encapsulation ppp

dialer pool-member 1

peer default ip address dhcp-pool ras_pfw

isdn switch-type basic-net3

ppp callback accept

ppp authentication pap chap ms-chap ms-chap-v2 eap

!

interface Dialer0

ip unnumbered Loopback0

no ip proxy-arp

encapsulation ppp

dialer pool 1

dialer idle-timeout 3600

dialer-group 1

peer default ip address dhcp-pool ras_pfw

no cdp enable

ppp callback accept

ppp authentication pap chap ms-chap ms-chap-v2 eap

1 REPLY
Silver

Re: IP-Address Assignment for Dialin-Users via IOS DHCP-pool

You can use either TACAS+ server or RADIUS server for this , can mention the IP pool in the authenication server and mention a group name for a IP pool. The users login into this group will be assigned IP address from that pool.

you may have to use the command aaa authentication login "list_name" group radius group tacas+

107
Views
0
Helpful
1
Replies
CreatePlease to create content