Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IP address of 2950 with VLANs

Hi!

I have a 2950 with trunking on an interface. The trunk is connected to a router. I may access the switch via the router. The trunk is 802.1q and it has 3 VLANS. None of those VLANS is the default. I have tried to configure the ip address on the vlans that are applied to the interfaces but as soon as I create the vlan, it keeps on shut, even when it

ports associated. Here is the configuration of the swith. Can someone suggest me how can I configure the administrative IP address? The vlans on the trunk are 999,1000 and 1001.

Thanks,

Mario

Building configuration...

Current configuration:

!

! Last configuration change at 14:45:18 UTC Tue Nov 18 2003

! NVRAM config last updated at 23:08:17 UTC Mon Nov 17 2003

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log datetime msec

no service password-encryption

!

hostname VOIP

!

no logging console

enable password cisco

!

!

!

!

!

!

ip subnet-zero

!

!

!

interface FastEthernet0/1

description ITG VoIP 10.3.0.0

duplex full

speed 10

switchport access vlan 1001

spanning-tree portfast

!

interface FastEthernet0/2

description ITG VoIP 10.3.192.0

duplex full

speed 10

switchport access vlan 1001

spanning-tree portfast

!

interface FastEthernet0/3

description N/A

duplex full

speed 10

switchport access vlan 998

spanning-tree portfast

!

interface FastEthernet0/4

description N/A

duplex full

speed 10

switchport access vlan 998

spanning-tree portfast

!

interface FastEthernet0/5

description DPC'S 10.110.64.X

duplex half

speed 10

switchport access vlan 1000

!

interface FastEthernet0/6

description N/A

duplex half

speed 10

switchport access vlan 998

!

interface FastEthernet0/7

description RASCISCO 10.201.0.100

switchport access vlan 999

spanning-tree portfast

!

interface FastEthernet0/8

description 7507 TRUNKING

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/9

description ESTACION GESTION IMPSAT 10.201.0.1

switchport access vlan 999

spanning-tree portfast

!

interface FastEthernet0/10

description DPC'S 10.201.0.X

switchport access vlan 999

!

interface FastEthernet0/11

switchport access vlan 998

!

interface FastEthernet0/12

switchport access vlan 998

!

interface FastEthernet0/13

switchport access vlan 998

!

interface FastEthernet0/14

switchport access vlan 998

!

interface FastEthernet0/15

switchport access vlan 998

!

interface FastEthernet0/16

switchport access vlan 998

!

interface FastEthernet0/17

switchport access vlan 998

!

interface FastEthernet0/18

switchport access vlan 998

!

interface FastEthernet0/19

switchport access vlan 998

!

interface FastEthernet0/20

switchport access vlan 998

!

interface FastEthernet0/21

switchport access vlan 998

!

interface FastEthernet0/22

!

interface FastEthernet0/23

description ----MONITOR DPCS 10.201.0.0----

port monitor FastEthernet0/5

switchport access vlan 1000

!

interface FastEthernet0/24

description --MONITOR DPC 10.110.64 ---

shutdown

!

interface VLAN1

description VLAN1

no ip address

no ip directed-broadcast

no ip route-cache

!

interface VLAN100

no ip directed-broadcast

no ip route-cache

shutdown

!

interface VLAN1000

no ip directed-broadcast

no ip route-cache

shutdown

!

ip default-gateway 10.3.0.10

snmp-server community PUBLIK1 RO

snmp-server community COMUNIKA RW

snmp-server location VOIP.DIRECCION_GENERAL.BACKBONE

snmp-server contact 0

!

line con 0

transport input none

stopbits 1

line vty 0 4

password cisco

login

line vty 5 15

login

!

ntp clock-period 17180054

ntp server 10.5.128.9

end

VOIP#

3 REPLIES
Cisco Employee

Re: IP address of 2950 with VLANs

You can have only one VLAN interface up/up in a XL/2950 switch. This interface is just used for management purpose as XL/2950 are layer 2 switches only

http://www.cisco.com/warp/public/473/8.html#topic4

Re: IP address of 2950 with VLANs

You need to shutdown VLAN1. This isn't as drastic as it seems.... The 2950 doesn't route and so the only VLAN interface that needs to be up is the management one.

Andy

New Member

Re: IP address of 2950 with VLANs

2950 is Just an L2 switch.

So it can have only One L3 interface active any timeand ip address assigned to it(which is used for managing/administeing the switch.)

By default VLAN 1 is the management VLAN.

If you are allowing only 999,1000,1001 VLANs via the trunk port, you can administer the switch via any one of active L3 VLAN interfaces of among theas three VLANs only.

If you are allowing all VLANs via the trunk , you can use any one of the active L3 VLAN interface for administering the switch.

192
Views
0
Helpful
3
Replies