Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IP addressing and analogue dial-in to 3640 PRI

I have a 3640 with an E1 PRI module and 12 port digimodem. The PRI is used primarily for DDR with remote BRI routers, it has also been configured for use with a digimodem module for analogue dial-in. My problem is that I’ve never configured analogue dial-in, it was there before I started, and now need to make some changes to it.

At the moment an analogue dial-in user will receive a dynamically assigned IP address from our DHCP servers. Ideally I’d like to retain this while allowing specific usernames to use an allocated, fixed, IP address. If this isn’t possible I’d like to allocate all dial-in usernames a static IP address, and remove DHCP.

Please give me some pointers on how I could achieve this, thanks in advance.

Here’s a sample of my config:

IOS 12.2(7)

username dialuser1 password 7 xxxxxxxxxxxxx

username dialuser2 password 7 xxxxxxxxxxxxx

username isdn1 password 7 xxxxxxxxxxxxx

username isdn2 password 7 xxxxxxxxxxxxx

!

!

ip domain-name domain.co.uk

ip name-server 10.0.1.156

ip name-server 10.0.1.151

ip name-server 10.0.1.154

!

ip address-pool dhcp-proxy-client

ip dhcp-server 10.0.1.151

ip dhcp-server 10.0.1.154

!

!

isdn switch-type primary-net5

chat-script cisco-default ABORT ERROR "" "AT" OK "ATDT\T" TIMEOUT 60 CONNECT

chat-script rtp ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 45 CONNECT \c

chat-script offhook "" "ATH1" OK

call rsvp-sync

!

controller E1 1/0

pri-group timeslots 1-31

!

!

!

interface Ethernet0/0

ip address 192.168.1.14 255.255.255.0 secondary

ip address 10.0.1.1 255.255.0.0

full-duplex

service-policy output voip

!

...serial interfaces...

!

interface Group-Async1

ip unnumbered Ethernet0/0

encapsulation ppp

dialer in-band

dialer-group 1

async mode interactive

no peer default ip address

ppp callback accept

ppp authentication chap pap

group-range 65 76

!

interface Dialer1

description ISDN connection to isdn1

bandwidth 128

ip address 192.168.255.5 255.255.255.252

encapsulation ppp

dialer pool 1

dialer remote-name isdn1

dialer idle-timeout 360

dialer string xxxxxxxxxxxxx

dialer-group 1

no peer default ip address

pulse-time 0

ppp authentication chap

ppp multilink

!

interface Dialer2

description ISDN connection to isdn2

bandwidth 64

ip address 192.168.255.9 255.255.255.252

encapsulation ppp

dialer pool 1

dialer remote-name isdn2

dialer idle-timeout 360

dialer string xxxxxxxxxxxxx

dialer-group 1

no peer default ip address

pulse-time 0

ppp authentication chap

!

.... more dialer interfaces for ISDN DDR ....

!

ip route 10.1.0.0 255.255.0.0 Dialer1

ip route 192.168.13.0 255.255.255.0 Dialer2

... more routes ...

!

dialer-list 1 protocol ip permit

!

line 65 76

session-timeout 120

script modem-off-hook offhook

script callback rtp

login local

modem InOut

modem autoconfigure type mica

transport input all

autoselect during-login

autoselect ppp

callback forced-wait 5

1 REPLY
Bronze

Re: IP addressing and analogue dial-in to 3640 PRI

You can do the following under int group-async1 :

dialer map ip 1.1.1.1 name peter

dialer map ip 1.1.1.2 name bob

dialer map ip 1.1.1.3 name mike

So user peter will always get 1.1.1.1 as his ip address , user bob will always get

1.1.1.2 as his ip and so on and so forth.

While doing this you could still have your external DHCP server to assign IP addresses to the rest of the users who are not peter, bob and mike. For that

all you need to have is "peer default ip address dhcp" under int group-async1

since you already have DHCP server address defined in your global config.

~Zulfi

172
Views
0
Helpful
1
Replies
CreatePlease login to create content