Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IP helper address and tunnel interface

I have some problems when a router forward DHCP requests through tunnel interface.

In the listed configuration below, all DHCP requests time out. When I configured a default route, I see DHCP requests in serial interface (not in tunnel interface).

Does anyone know if ip helper address command have priority over route-maps? Is there some workarounds to avoid this behavior?

TIA

Jefferson Soletti

Current configuration:

!

! Last configuration change at 14:36:06 BRA Tue Mar 2 2004 by oper

!

version 11.3

ip subnet-zero

no ip domain-lookup

!

interface Tunnel101

ip unnumbered Ethernet0

bandwidth 256

tunnel source Serial0

tunnel destination 10.4.3.29

!

interface Ethernet0

ip address 172.19.0.1 255.255.255.224

ip helper-address 172.20.1.100

no ip directed-broadcast

ip policy route-map test1

!

interface Serial0

ip address 10.101.32.2 255.255.240.0

no ip directed-broadcast

bandwidth 256

!

router eigrp 1

network 10.0.0.0

!

ip classless

no ip forward-protocol udp netbios-ns

no ip forward-protocol udp netbios-dgm

ip route 172.19.0.0 255.255.255.224 Tunnel101

!

access-list 101 permit ip any 172.19.0.0 0.0.0.31

access-list 102 permit ip any any

route-map test1 permit 10

match ip address 101

set interface Ethernet0

!

route-map test1 permit 11

match ip address 102

set interface Tunnel101

!

4 REPLIES
Gold

Re: IP helper address and tunnel interface

What's happening is the broadcast packet is being picked up and being processed by the helper code, which sets the next hop to 172.20.1.100. The resulting packet is then switched; since there is PBR on the interface, the policy is examined first, and the policy tells the packet to be switched out Tunnel 101. Or at least that's what I would expect.

At this point, though, I'm not certain what the problem is. Are you saying the packets will not be switched out the tunnel interface at all? They are being switched out the serial interface, but isn't that where the tunnel interface would live?

Why are you running policy based routing here anyway? The only policies you have set up are for specific destinations to be routed a specific way, and that can be handled using standard static routes, so I'm not certain what your final goal is....

Russ.W

New Member

Re: IP helper address and tunnel interface

Yes. Only DHCP packets are switched out the serial interface without GRE encapsulation. Normal IP traffic are switched out tunnel 101.

I can see these DHCP packets (with dest. 172.20.1.100) "traveling" in network 10.0.0.0

These packets should be encapsulated as others IP packets (like ICMP) and should be routed through network 10.0.0.0.

I'm running policy based just for migration scenario. I configured the route-map to ip any any to be sure that this is not the problem. And, also, I need to be sure that this model (helper address, tunnel and route-maps) works.

I think that describe my problem better.

TIA

Jefferson Soletti

New Member

Re: IP helper address and tunnel interface

Do you have a route for your tunnel destination IP? Is your tunnel up?

New Member

Re: IP helper address and tunnel interface

Yes and yes.

Like I said in reply before, normal IP traffic are working fine. Just DHCP relay doesn't work.

TIA,

Jefferson Soletti

415
Views
0
Helpful
4
Replies
CreatePlease to create content