Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IP Nat/ Flash problem

I have a Cisco 2611 router that is running static and dynamic NAT together. (static-webservers, mail, etc--dynamic-workstations). This router has run flawlessly for over 1.5yrs so Im pleased. In the past two days I have lost my dynamic translations. I have captured two debug segments to see if the translations were looping or just crapping out. They don't even show up. I tried a cold start. No luck. I created another address pool and named it. Deleted the old pool and reassigned the 3 IPs I use for that pool. It worked for about 9 hours and died. I tried another cold start this morning, but no luck. ALSO I noticed that some changes were not showing up in the startup-config after I ran the command "copy run star" and then "sh star". And on the last cold start after the image decompression, I got this nice little message-- "Warning: flash:star does not exist. Command retained." followed by "Warning: flash:startup-config does not exist. Command retained."

I could not find any reference to these two errors on the TAC website or in my books so I thought I would ask the experts. My feeble little brain guesses I have to reload the IOS image over the existing one in flash from my tftp server and then reload the config that I have saved. Any advice with the flash? I don't have alot of experience fooling with flash. PLEASE help! and thank you in advance!

Bobby

2 REPLIES
New Member

Re: IP Nat/ Flash problem

Bobby:

I think you've got two problems that are getting comingled and confused: NAT failures, and startup weirdness. Let's pull them apart and deal with them one at a time.

In a 2600, flash is only the place where the IOS sits waiting for the router to boot up. Once the router copies the IOS from flash to DRAM, the flash goes back to waiting for the next event. 2600s do have NVRAM, so your startup-config should be being saved in NVRAM, not in flash. Without seeing the actual verbage of what was typed, it's hard to know exactly how things got to this condition. Regardless, the errors themselves mean that the router is looking to the flash device for two files--one named "star" and the other named "startup-config" and it's not finding them. Again, it shouldn't because the 2600 has NVRAM and stores the config there. I'd guess there are probably commands somewhere in the config that call to these files, or they've somehow become referenced in bootup commands. Most likely, if you erase the config, erase the flash, reload an image, reload the config, everything will be fine.

Now for the NAT failure. The first thing you should know about NAT is that it is *VERY* memory intensive. Without other SHOW commands from the router, it's hard to say for certain, but from what you're describing, (and I've heard the same story for quite a while,) it sounds like the router is simply being depleted of DRAM resources, so processes are being dropped. NAT tends to be one of the first to go. As well, given that you've run the router for 1.5 years, I'd guess that the volume of traffic being pumped through the router has gone up over that 1.5 years as well. Remember that the router doesn't have a hard drive to swap to like Windows does, so all it can do when it gets crunched for resources is drop the packets and kill off processes. It's possible to see this in SHOW BUFFERS and SHOW PROCESS CPU, if you know what you're looking for.

Another possibility would be a bad version of IOS, but normally, if that were the case, you would have had NAT issues all along. Either way, it wouldn't hurt to have someone look over a SHOW TECH and give an opinion.

New Member

Re: IP Nat/ Flash problem

I'd suggest also making sure that the config register is OK (0x2102). Also boot sequence is not changed because of a boot command in the config.

So, try show ver to check on the register, and show boot for the boot sequence. Also check the configuration for any boot command. Good luck.

133
Views
0
Helpful
2
Replies