Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

ip over Annex G

Please tell me how to solve the problem:

It is necessary to connect IP-LANs

central and regional offices over x25 network.

In region, router connected to x25 network trought x25 protocol.

In Center, in additional, need connect to Internet.

router 2650 connected to ISP trougth Frame Relay with two DLCI:

dlci-110 for x25, dlci-316 for PPP to Internet.

Used protocol fully equivalent given here example:

http://www.cisco.com/warp/public/133/x25_over_frame_wo_tcp.html

In this cheme Router-1 equivalent regional router 1750.

Router-3 equivalent central router 2650.

Router-2 and Router-4 is ignored.

In given example, command "x25 map ip ..." make

interconnecting networks routers 1 and 4

But need interconnect networks routers 1 and 3

The problem is that, in Router-3 Annex G is used

and there is no opportunity to use command

(Config-if)# x25 map ip 10.0.0.2 1234

How interconnect IP-LANs routers 1 and 3 ?

my current config:

2 additional Serial with crossover cable.

-----------------------------------

version 12.1

x25 profile SI dte

x25 htc 64

x25 win 7

x25 wout 7

x25 routing

interface FastEthernet0/0

ip address 192.168.100.3 255.255.255.0

interface Serial0/0

bandwidth 64

no ip address

encapsulation frame-relay IETF

no ip mroute-cache

frame-relay interface-dlci 16

x25-profile SI

frame-relay lmi-type ansi

!

interface Serial0/0.2 point-to-point

bandwidth 64

ip address 111.111.111.61 255.255.255.248

frame-relay interface-dlci 319

!

interface Serial0/1

no ip address

encapsulation x25 dce ietf

clockrate 2000000

!

interface Serial0/2

ip address 192.168.3.100 255.255.255.0

encapsulation x25 ietf

x25 address 12345

x25 map ip 192.168.3.101 11111 broadcast compress

x25 map ip 192.168.3.102 22222 broadcast compress

x25 map ip 192.168.3.103 33333 broadcast compress

x25 map ip 192.168.3.104 44444 broadcast compress

ip classless

ip route 192.168.101.0 255.255.255.0 192.168.3.101

ip route 192.168.102.0 255.255.255.0 192.168.3.102

ip route 192.168.103.0 255.255.255.0 192.168.3.103

ip route 192.168.104.0 255.255.255.0 192.168.3.104

x25 route .* interface Serial0/0 dlci 16

x25 route 12345 interface Serial0/1

-----

please, E-mail me about this config.

cep@conti.penza.ru

Russia, Penza city.

3 REPLIES
Bronze

Re: ip over Annex G

I wonder if this is an IOS feature yours doesn't support. You should check it on feature navigator at www.cisco.com/go/fn

Bronze

Re: ip over Annex G

we do not support IP encapsulation in the x25 profiles for annexg - it is a method for remote switching of X25 packets. Please see link below:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120t/120t3/x25anxg.htm#xtocid156614

Community Member

Re: ip over Annex G

It's clear that is IOS do not support IP encapsulation in the x25 profiles for annexg.

That's why we use following configuration:

At this moment we installed an additional two-port

unit WIC-2T into 2650, bind its ports by pair of DTE-DCE cables to

each other and transmit X.25 traffic from Frame-Relay to one of those

additional ports, get the traffic from another additional port and do

"x25 map ip..." on it.

It's amazing that's Cisco IOS can't realize more correct solution?

would the command "translate" help me in this problem ?

91
Views
0
Helpful
3
Replies
CreatePlease to create content