Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

IP Phone and Data Port on the same Ethernet

Hi,

Would need some advise on how can I configure Voice vlan and data vlan on

Cisco C3524XL Switch With the IOS Version(C3500XL-C3H2S-M), Version 12.0(5)WC13, RELEASE SOFTWARE (fc1)

I would like to configure it to work on IP Phone n data on the same ethernet port.

same of the configuation

interface FastEthernet0/23

switchport access vlan 200

switchport voice vlan 190

spanning-tree portfast

!

Regards

Mc

9 REPLIES

Re: IP Phone and Data Port on the same Ethernet

Hi Friend,

The config is perfect if it is a cisco ip phones or infact any ip phone which understand voice vlan because if you configure this command it will automatically form an internal trunk and allow both the vlans to pass but incase the ip phone does not understand voice vlan then you need to manually confugure trunk port also on the switchport.

HTH

Ankur

New Member

Re: IP Phone and Data Port on the same Ethernet

Hi,

can U advise how to trunk ? I have turnk the uplink port. Hmmmm blur...

Append with the vlan db .

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/17, Fa0/18, Fa0/19, Fa0/20,

Fa0/21, Fa0/24, Gi0/1

190 HQ190-IPPhone active Fa0/22

200 HQ200 active Fa0/23

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,100,190,200,300,1002-1005

switchport mode trunk

!

Re: IP Phone and Data Port on the same Ethernet

Hi,

Your config is right.You have to simple use the command:

conf t

int gig 0/x

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan <--- Define the voice vlan here in the port.

If you want to allow specific vlans between the switches you should use the command as you has used using " switch port allowed " , make sure that voice vlan and date vlan both are passed on the

trunk.If you want you can pass only the voice vlan and data vlan on teh switchport connecting the IP phones.

In my experience you should always use trunk configuration on the ports connecting the IP phones with 3500XL's the other config doesnot work most of the times.

regards,

-amit singh

New Member

Re: IP Phone and Data Port on the same Ethernet

Thank s fro yout help,

Would appreicate you can show me your sample configuration. as I tried you advise. I doubt it works

The sample show below is fs0/24 which is connected to user ip phone and data port .

Whereas the Gi0/2 is the uplink to our aceess switches,,

interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,200,1002-1005

switchport mode trunk

switchport voice vlan 190

!

!

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,100,190,200,300,1002-1005

switchport mode trunk

switchport voice vlan 190

New Member

Re: IP Phone and Data Port on the same Ethernet

We use this config a lot with our phones.

int fa0/1

description CISCO PHONE

switchport access vlan 2

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

switchport mode trunk

switchport voice vlan 3

no ip address

spanning-tree portfast

no snmp trap link-status

We do not use VLAN 1 (native vlan) for any regular traffic. Our data vlan is 2 and voice vlan is 3. In order for a computer to get it's IP (assuming their DHCP works correctly for that VLAN) is to make sure the native vlan vlan-number is in each port config. This way everything defaults out the "data" vlan while voice only comes out the "voice" vlan.

New Member

Re: IP Phone and Data Port on the same Ethernet

Hmmm

can U sh vlsn , ,mine did not display the port fa0/21 which I copy n paste the command line given

interface FastEthernet0/21

switchport access vlan 200

switchport trunk encapsulation dot1q

switchport trunk native vlan 200

switchport mode trunk

switchport voice vlan 190

no snmp trap link-status

spanning-tree portfast

190 HQ190-IPPhone active Fa0/22

200 HQ200 active Fa0/1, Fa0/2, Fa0/3, Fa0/4,

Fa0/5, Fa0/6, Fa0/7, Fa0/8,

Fa0/9, Fa0/10, Fa0/11, Fa0/12,

Fa0/13, Fa0/14, Fa0/15, Fa0/16,

Fa0/23

New Member

Re: IP Phone and Data Port on the same Ethernet

thanks guys, It works..

Regards

Mc

Re: IP Phone and Data Port on the same Ethernet

MC,

Update us with your final port config and also any special thing you did.

regards

-amit singh

New Member

Re: IP Phone and Data Port on the same Ethernet

This is the cmd line that works....

interface FastEthernet0/21

switchport access vlan 2

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

switchport mode trunk

switchport voice vlan 190

no snmp trap link-status

spanning-tree portfast

Hmmm. It work on one of ip phone but no the other..

any thought

really Puzzle

Thanks guys...

325
Views
0
Helpful
9
Replies