Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

IP Route btw 2 ethernet interfaces

I have a Cisco 806 router with two ethernet intefaces. E0 = 10.1.1.7/28 & E1 = 10.119.128.25/24. While logged into the router I can ping devices on both segments, but not from a device on one segment to another. example: PC 10.1.1.5 can not ping PC 10.119.128.10. my config is below. What am I doing wrong?Building configuration...

Current configuration : 1418 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Router

!

enable secret 5 $1$94nN$ZtnzBBIAZpNNDl6P7n/dv.

!

username Router password 7 130B16020A

ip subnet-zero

!

ip inspect name myfw cuseeme timeout 3600

ip inspect name myfw ftp timeout 3600

ip inspect name myfw http timeout 3600

ip inspect name myfw rcmd timeout 3600

ip inspect name myfw realaudio timeout 3600

ip inspect name myfw smtp timeout 3600

ip inspect name myfw tftp timeout 30

ip inspect name myfw udp timeout 15

ip inspect name myfw tcp timeout 3600

ip inspect name myfw h323 timeout 3600

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!

!

!

!

interface Ethernet0

ip address 10.1.1.7 255.255.255.240

no cdp enable

!

interface Ethernet1

ip address 10.119.128.25 255.255.255.0

no cdp enable

!

interface Dialer1

ip address negotiated

ip access-group 111 in

ip mtu 1492

ip nat outside

ip inspect myfw out

encapsulation ppp

ip tcp adjust-mss 1452

shutdown

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname admin

ppp chap password 7 025756085F

ppp pap sent-username admin password 7 11584B5643

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.1.1

no ip http server

!

!

line con 0

exec-timeout 120 0

stopbits 1

line vty 0 4

exec-timeout 0 0

password 7 000A121605

login

length 0

!

scheduler max-task-time 5000

end

Router#

4/10/02

2 REPLIES
New Member

Re: IP Route btw 2 ethernet interfaces

Your config is probably fine. The devices on the network probably need their default gateways set to the router's ethernet address.

Mick.

New Member

Re: IP Route btw 2 ethernet interfaces

Your configuration looks fine, so test the default gateways of the PC by doing a extended ping from the router. For example, ping 10.1.1.5 but source the ping from 10.119.128.25

et-comm4#ping

Protocol [ip]:

Target IP address: 10.1.1.5

Repeat count [5]:

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]: y

Source address or interface: 10.119.128.25

Type of service [0]:

Set DF bit in IP header? [no]:

Validate reply data? [no]:

Data pattern [0xABCD]:

Loose, Strict, Record, Timestamp, Verbose[none]:

Sweep range of sizes [n]:

If you get a response, then you know the 10.1.1.5 has a route (or default gateway) back to the this router.

227
Views
0
Helpful
2
Replies