Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IP Unnumbered, RIP v2

I have a network running RIP v2. When the network was originally built, it used IP unnumbered on serial links. The router at each end of the serial link has the serial interface (that uses IP unnumbered) and an ethernet interface that's in class C network in the 10.X.X.X network space. For example, Router A's ethernet interface might be 10.1.0.1/24 and Router B's ethernet interface might be 10.2.0.1/24. The ip unnumbered works perfectly.

Now I need to subnet the address space the the ethernet interface on Router A connects to. For example, I need to take the 10.1.0.0/24 space and subnet it into 10.1.0.0/25 and 10.1.0.128/25. I still want to run ip unnumbered across the serial links (there's a reason for this, honest. It's an unusual network.) Only problem is, now the subnet masks don't match on the ethernet interfaces at both ends of the link.

Can anyone tell me if this setup will still result in the ip unnumbered working across the serial links between Router A and Router B?

5 REPLIES

Re: IP Unnumbered, RIP v2

Take a look at this link: http://www.cisco.com/en/US/tech/tk648/tk365/technologies_tech_note09186a0080094e8d.shtml

Shouldn't be an issue.

Hope it helps.

Steve

New Member

Re: IP Unnumbered, RIP v2

yeah, I read this thing and it gave me heartburn. I think that my case is same major net, different subnets but even that is problematic. I figure the major net is the 10.0.0.0 network in my example. The subnets are the 10.1.0.0/24 and 10.2.0.0/24 subnets. In the example that Cisco gives for this, they show the same subnet mask on both networks. I have an old Cisco Press book (circa 1998) that makes a blanket statement that the subnet mask must be the same on both sides for ip unnumbered to work properly. It says this before it even discusses the cases given in the article you cited. After I further subnet one of my networks I no longer have masks of the same length so I'm wondering about this. Have you ever done what I'm asking about and had it work?

Bronze

Re: IP Unnumbered, RIP v2

This post is interesting. The suggested link mentioned that:

"This document explains the concept of IP unnumbered, and provides several configuration examples for reference. "

So there could be several possible setup.

I haven't tried your setup but I think it will work since you are using RIP2 and I guess you have automatic summarization disabled.

Goodluck.

Re: IP Unnumbered, RIP v2

I put this together quickly in the lab and it worked (one side 10.1.0.0/16 and the other 10.2.0.0/24):

Router#sh run

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

boot system flash

!

ip subnet-zero

frame-relay switching

!

!

!

interface Loopback10

ip address 172.16.1.1 255.255.255.0

no ip directed-broadcast

!

interface Ethernet0

ip address 10.1.0.1 255.255.0.0

no ip directed-broadcast

!

interface Serial0

ip unnumbered Ethernet0

no ip directed-broadcast

clockrate 64000

!

interface Serial1

no ip address

no ip directed-broadcast

shutdown

!

router rip

version 2

network 10.0.0.0

network 172.16.0.0

!

ip classless

!

banner login ^C^C

banner motd ^Cefault

'^C

!

line con 0

transport input none

line aux 0

line vty 0 4

!

end

Router#

Router#sh ip rout

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route, o - ODR

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 1 subnets

C 172.16.1.0 is directly connected, Loopback10

10.0.0.0/8 is variably subnetted, 4 subnets, 4 masks

R 10.2.0.0/24 [120/1] via 10.2.0.1, 00:00:26, Serial0

R 10.3.0.0/29 [120/1] via 10.2.0.1, 00:00:26, Serial0

R 10.0.0.0/8 [120/1] via 10.2.0.1, 00:00:26, Serial0

C 10.1.0.0/16 is directly connected, Ethernet0

R 192.168.1.0/24 [120/1] via 10.2.0.1, 00:00:26, Serial0

Router#

router2#sh run

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname router2

!

enable password cisco

!

ip subnet-zero

frame-relay switching

!

!

!

interface Loopback1

ip address 192.168.1.1 255.255.255.224

no ip directed-broadcast

!

interface Loopback2

ip address 10.3.0.1 255.255.255.248

no ip directed-broadcast

!

interface Ethernet0

ip address 10.2.0.1 255.255.255.0

no ip directed-broadcast

!

interface Serial0

ip unnumbered Ethernet0

no ip directed-broadcast

!

interface Serial1

no ip address

no ip directed-broadcast

shutdown

!

router rip

version 2

network 10.0.0.0

network 192.168.1.0

!

ip classless

!

!

line con 0

transport input none

line aux 0

line vty 0 4

login

!

end

router2#

router2#sh ip rout

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route, o - ODR

Gateway of last resort is not set

R 172.16.0.0/16 [120/1] via 10.1.0.1, 00:00:09, Serial0

10.0.0.0/8 is variably subnetted, 4 subnets, 4 masks

C 10.2.0.0/24 is directly connected, Ethernet0

C 10.3.0.0/29 is directly connected, Loopback2

R 10.0.0.0/8 [120/1] via 10.1.0.1, 00:00:10, Serial0

R 10.1.0.0/16 [120/1] via 10.1.0.1, 00:00:10, Serial0

192.168.1.0/27 is subnetted, 1 subnets

C 192.168.1.0 is directly connected, Loopback1

router2#

Steve

New Member

Re: IP Unnumbered, RIP v2

Thanks Steve. Unfortunately I don't have a lab in which to try this kind of stuff out. (I'm hoping that will change). I appreciate the time you put into this.

362
Views
0
Helpful
5
Replies
CreatePlease login to create content