Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Ipv6 routing rip

Hi,

Tryin to setup a ipv6 testlab with 2 cisco3600 routers(1serial,2ethernet) connected with 2 serial cables with 2 hosts on each side of network.

Assigned ipv6 addresses to all needed interfaces and on both sides all works wel exept the rip routing proces.(The basic setup works cause last week i did same setup with ipv4 and it worked fine.)

When working with ipv4 it was needed to add a route with the network command but where did it go in ipv6?

i enable a routing rip proces on the ethernet and serial interfaces but when i do a sh ipv6 routing rip no routes show up.All protocols and lines are up but i canot seems to go to the other side of the network.Any help would be appricited.txs.

8 REPLIES
Cisco Employee

Re: Ipv6 routing rip

The way to configure RIP under ipv6 is a bit different than under ipv4. You have to enable RIPv6 on a per interfaces basis in the following way.

int e0/0

ipv6 rip TEST enable

ipv6 router rip test

Do a "sh ipv6 rip" to see if RIPv6 has been interface on your all the desired interfaces.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Cisco Employee

Re: Ipv6 routing rip

I meant "if RIPv6 has been enabled on all the desired interfaces"

I haven't had my first coffee yet ;o)

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Anonymous
N/A

Re: Ipv6 routing rip

If i do a sh ipv6 rip it sais that its enablede on both interfaces (fastethernet & serial) ut that doesn't mean it works.. i have no connection to the other network.

Serial0/0 on router0:global uicast addres: 2001:b78::a1:b2:c3:1/32

serial 2/0 on router2:

2001:b78::a1:b2:c3:2/32

I can ping both serial interfaces from the console of the routers but if i try to ping beyond serial aka ethernet it wont go thru.. weird..If i look into the manuals its a piece of cake but i didn't had cake yet :) ... any other ideas?I'll try to post my run 2 night.

Txs

Cisco Employee

Re: Ipv6 routing rip

Please post your configs and IOS version used.

Thanks,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Anonymous
N/A

Re: Ipv6 routing rip

Router01 :

Building configuration...

Current configuration : 908 bytes

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname router01

!

enable password secret

!

ip subnet-zero

!

!

!

ipv6 unicast-routing

!

!

!

!

!

!

!

!

!

!

!

!

mta receive maximum-recipients 0

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed 100

ipv6 address 3FFE:C00:C18:C1::/64 eui-64

ipv6 enable

ipv6 rip ipsix enable

ipv6 rip ipsix default-information originate

!

interface Serial0/0

bandwidth 100000

no ip address

ipv6 address 2001:B78::A1:B2:C3:1/32

ipv6 rip ipsix enable

clockrate 8000000

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip classless

ip http server

!

!

ipv6 router rip ipsix

!

ipv6 router rip ipxsix

!

!

call rsvp-sync

!

!

mgcp profile default

!

!

!

dial-peer cor custom

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

password secret

login

!

!

end

router01#sh ver

router01#sh version

Cisco Internetwork Operating System Software

IOS (tm) 3600 Software (C3640-IK9S-M), Version 12.2(13)T5, RELEASE SOFTWARE (fc

1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2003 by cisco Systems, Inc.

Compiled Wed 28-May-03 13:34 by nmasa

Image text-base: 0x60008930, data-base: 0x61BAC000

ROM: System Bootstrap, Version 11.1(20)AA1, EARLY DEPLOYMENT RELEASE SOFTWARE (f

c1)

router01 uptime is 1 minute

System returned to ROM by power-on

System image file is "flash:c3640-ik9s-mz.122-13.T5.bin"

cisco 3640 (R4700) processor (revision 0x00) with 125952K/5120K bytes of memory.

Processor board ID 12906882

R4700 CPU at 100Mhz, Implementation 33, Rev 1.0

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

2 FastEthernet/IEEE 802.3 interface(s)

1 Serial network interface(s)

DRAM configuration is 64 bits wide with parity disabled.

125K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

16384K bytes of processor board PCMCIA Slot1 flash (Read/Write)

Configuration register is 0x2102

router01#

router01#sh ipv

router01#sh ipv6 RIP

RIP process "ipsix", port 521, multicast-group FF02::9, pid 127

Administrative distance is 120. Maximum paths is 16

Updates every 30 seconds, expire after 180

Holddown lasts 0 seconds, garbage collect after 120

Split horizon is on; poison reverse is off

Default routes are generated

Periodic updates 5, trigger updates 1

Interfaces:

Serial0/0

FastEthernet0/0

Redistribution:

None

router01#sh ipv6 route rip

IPv6 Routing Table - 6 entries

Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP

U - Per-user Static route

I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea

router01#

Anonymous
N/A

Re: Ipv6 routing rip

Router02:

Building configuration...

Current configuration : 861 bytes

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname rout

!

enable password supersecret

!

ip subnet-zero

ipv6 unicast-routing

!

!

!

!

mta receive maximum-recipients 0

!

!

!

!

interface FastEthernet2/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial2/0

no ip address

ipv6 address 2001:B78::A1:B2:C3:2/32

ipv6 enable

ipv6 rip ipsix enable

no fair-queue

!

interface FastEthernet2/1

no ip address

duplex auto

speed auto

ipv6 address 3FFE:C00:C18:C1::/64 eui-64

ipv6 enable

ipv6 rip ipsix enable

!

ip classless

ip http server

!

!

ipv6 router rip

!

!

call rsvp-sync

!

!

mgcp profile default

!

!

!

dial-peer cor custom

!

!

!

!

!

line con 0

password xxx

line aux 0

line vty 0 4

password xxxx

login

!

!

end

Anonymous
N/A

Re: Ipv6 routing rip

and to end it all :)

router02#

router02#sh interfaces serial 2/0

Serial2/0 is up, line protocol is up

Hardware is DSCC4 Serial

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input 00:00:03, output 00:00:02, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

73 packets input, 6016 bytes, 0 no buffer

Received 72 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

73 packets output, 6016 bytes, 0 underruns

0 output errors, 0 collisions, 5 interface resets

0 output buffer failures, 0 output buffers swapped out

2 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

router02#sh ver

Cisco Internetwork Operating System Software

IOS (tm) 3600 Software (C3640-IK9S-M), Version 1

1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2003 by cisco Systems, Inc.

Compiled Wed 28-May-03 13:34 by nmasa

Image text-base: 0x60008930, data-base: 0x61BAC000

ROM: System Bootstrap, Version 11.1(20)AA1, EARLY DEPLOYMENT RELEASE SOFTWARE (f

c1)

router02 uptime is 7 minutes

System returned to ROM by power-on

System image file is "flash:c3640-ik9s-mz.122-13.T5.bin"

cisco 3640 (R4700) processor (revision 0x00) with 125952K/5120K bytes of memory.

Processor board ID 12409883

R4700 CPU at 100Mhz, Implementation 33, Rev 1.0

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

2 FastEthernet/IEEE 802.3 interface(s)

1 Serial network interface(s)

DRAM configuration is 64 bits wide with parity disabled.

125K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

16384K bytes of processor board PCMCIA Slot0 flash (Read/Write)

Configuration register is 0x2102

router02#sh ipv

router02#sh ipv6 rip

RIP process "ipsix", port 521, multicast-group FF02::9, pid 127

Administrative distance is 120. Maximum paths is 16

Updates every 30 seconds, expire after 180

Holddown lasts 0 seconds, garbage collect after 120

Split horizon is on; poison reverse is off

Default routes are not generated

Periodic updates 18, trigger updates 1

Interfaces:

FastEthernet2/1

Serial2/0

Redistribution:

None

thanks.

Cisco Employee

Re: Ipv6 routing rip

You configured the same prefix (3FFE:C00:C18:C1::/64 ) on both LAN interfaces. RIPv6 advertises the prefix from one side to the other but it is not installed on the receiving router because of the connected route for that prefix. Try configuring 3FFE:C00:C18:C2::/64 on router02. This should fix it.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
135
Views
0
Helpful
8
Replies
CreatePlease to create content