Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

IPX GRE Tunnel and Netware & EIGRP errors

I've got a GRE tunnel setup between two sites. At either site PIX firewalls connect to the carrier IP network and I have a 2611 infront of the PIX (at both ends). The 2611 is doing the GRE tunnel and is configured as a "one armed tunnel router". That is PIX and 2611 are connected to corporate LAN together (parallel) and not is series. The second ethernet interface on the 2611 is shutdown.

The issue I have is that some IPX clients get BTRIEVE errors at random. There are no problems reported with IP between the sites. A ping with large payload shows no packet loss and RTT of about 13 ms.

Prior to this we has a WAN link between the site and was routing IP/IPX and everything worked fine.

Here is the config of the first 2611

!

!

interface Tunnel0

no ip address

ipx network BCBB000A

ipx hello-interval eigrp 100 10

ipx hold-down eigrp 100 60

tunnel source Ethernet0/0

tunnel destination 172.16.32.10

!

interface Ethernet0/0

ip address 151.123.123.4 255.255.0.0

half-duplex

ipx network 10056D7C encapsulation SAP

ipx network 6356555 encapsulation NOVELL-ETHER secondary

!

ipx router eigrp 100

network all

!

and the second 2611 is:

!

!

interface Tunnel0

no ip address

ipx network BCBB000A

ipx hold-time eigrp 100 10

ipx hold-down eigrp 100 60

tunnel source Ethernet0/0

tunnel destination 151.123.123.4

!

interface Ethernet0/0

ip address 172.16.32.10 255.255.240.0

half-duplex

ipx network 2

!

ipx router eigrp 100

network all

The other funny thing is that if I try and using IPX EIGRP, the neighbour adjacency keeps flapping. Here is the debug eigrp trace from the router:

00:19:30: %DUAL-5-NBRCHANGE: IPX-EIGRP 100: Neighbor BCBB000A.000a.b7ca.f280 (Tu

nnel0) is up: new adjacency

00:19:35: %DUAL-5-NBRCHANGE: IPX-EIGRP 100: Neighbor BCBB000A.000a.b7ca.f280 (Tu

nnel0) is down: peer restarted

00:19:35: EIGRP: Neighbor BCBB000A.000a.b7ca.f280 went down on Tunnel0

00:19:35: EIGRP: New peer BCBB000A.000a.b7ca.f280

00:19:35: %DUAL-5-NBRCHANGE: IPX-EIGRP 100: Neighbor BCBB000A.000a.b7ca.f280 (Tu

nnel0) is up: new adjacency

00:19:44: %DUAL-5-NBRCHANGE: IPX-EIGRP 100: Neighbor BCBB000A.000a.b7ca.f280 (Tu

nnel0) is down: peer restarted

00:19:44: EIGRP: Neighbor BCBB000A.000a.b7ca.f280 went down on Tunnel0

00:19:45: EIGRP: New peer BCBB000A.000a.b7ca.f280

00:19:45: %DUAL-5-NBRCHANGE: IPX-EIGRP 100: Neighbor BCBB000A.000a.b7ca.f280 (Tu

nnel0) is up: new adjacency

00:19:54: %DUAL-5-NBRCHANGE: IPX-EIGRP 100: Neighbor BCBB000A.000a.b7ca.f280 (Tu

nnel0) is down: peer restarted

00:19:54: EIGRP: Neighbor BCBB000A.000a.b7ca.f280 went down on Tunnel0

00:19:54: EIGRP: New peer BCBB000A.000a.b7ca.f280

00:19:54: %DUAL-5-NBRCHANGE: IPX-EIGRP 100: Neighbor BCBB000A.000a.b7ca.f280 (Tu

nnel0) is up: new adjacency

00:20:03: %DUAL-5-NBRCHANGE: IPX-EIGRP 100: Neighbor BCBB000A.000a.b7ca.f280 (Tu

nnel0) is down: peer restarted

00:20:03: EIGRP: Neighbor BCBB000A.000a.b7ca.f280 went down on Tunnel0

00:20:04: EIGRP: New peer BCBB000A.000a.b7ca.f280

Is this a bug in the IOS or an I doing something wrong?

  • Other Network Infrastructure Subjects
1 REPLY
New Member

Re: IPX GRE Tunnel and Netware & EIGRP errors

You could refer to the document "What Does the EIGRP DUAL-3-SIA Error Message Mean?". It is available at http://www.cisco.com/warp/public/103/18.html.

Your error messages indicate that the neighbor adjacency is flapping due to the router going into the SIA state (Stuck in Active). It is the state where an unacceptable amount of time has passed since the transmission of a Query with no reply received. The document talks about the reasons due to which a router might go into SIA and how you could resolve the issue. Bug CSCdp33034 deals with the same. Also, Cisco IOS 12.1(4.4)E has certain enhancements that help resolve the SIA problem. If the problem persists, you could consider a switchover.

186
Views
0
Helpful
1
Replies