Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

IPX not working with new Network Configuration

Here is my situation. I have been engaged with a customer that had the following equipment.

1x 3640 Router running IOS c3640-d-mz.121-3a.T1

1x 3550 L3 Switch running IOS 12.1.15 EMI

8 x 3548XL L2 Switches running IOS c3500xl-c3h2s-mz.120-5.WC13.bin

When I was asked to look at the network they were experiencing slow LAN speeds (10.8MB file between two LAN hosts around 12 minutes). This network consisted of 10 Class C networks 10.5.60.x - 10.5.69.x, these networks were based on the 3560 split between two interfaces. Odd ranges on FE 0/0 and Even on FE0/1. The router was acting as a stub router on a T1 from the client’s core network provider. This core provider has IPX services that my client has to be able to use. Under the old design there was no VLAN structure and basic network services such as DHCP barely worked.

Now the network is configured with the 3640 router as the edge routing device and the 3550-48-EMI is configured as the LAN routing devices. I have split the 10.5.60.x range in two using the lower segment for VLAN 60 and using the upper range as the communication network between FE 0/48 on the 3550 (ip addr 10.5.60.130 255.255.255.128) and FE 0/0 on 3640 (ip addr 10.5.60.131 255.255.255.128), these interfaces are connected via an ISL Trunk. Each VLAN is set at the 3550 with the gateway of 10.5.x.1. Each of the 8 3548XL switches is configured with all of the VLANS and are linked to the 3550 via 100 BaseT and 1000BaseT interfaces configured as dot1q trunks. Multicast routing is enabled on the 3550 to allow services like MDNS and Imaging to occur across VLANS.

With all this said IPX is not working. My 3640 edge router is still seeing all of its upstream IPX servers and networks. This router also sees the local IPX network as connected out of FE 0/0, based on this config setting (ipx network 1368023) FE 0/0. I'm guessing that this piece of the puzzle is based on my L3 changes on the LAN. But I just am not able to wrap my head around what it is. Any help that could be offered concerning this issue would be greatly appreciated.

Whatever the solution is it needs to happen with no more hardware and this new structure has to stay in place. I have been able to fix all ip network services such as DHCP and the customer reports a 1013% speed increase from the point when I first arrived. The 10.8 MB file mentioned above now transfers in about 8 to 10 seconds across the LAN.

Again Thanks.

6 REPLIES
Bronze

Re: IPX not working with new Network Configuration

ah - oh dear - the 3550 doesnt support IPX im afraid mate.

New Member

Re: IPX not working with new Network Configuration

I was pretty sure of that. Is there anyway to tag the IPX traffic to a VLAN from the 3600 as described in http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120t/120t1/ipx_vlan.htm Which so far hasnt worked...

Or is there a way that I can simply use broadcasts at a L2 level to accomplish connectivity? This was working like a charm under the bad network configuration that was purely L2 and 10 subnets drapped accross two router interfaces. It seems like there should be some sort of simple fix I'm missing.

Otherwise is there a way to have the VLAN clients talk up to the 3600 in order to get IPX information? In the end this is a short term fix. 3 weeks from now the IPX app is being replaced by and IP app. But I need it for 3 more weeks.

Thanks,

Josh

Bronze

Re: IPX not working with new Network Configuration

yeah mate but it kinda puts you back to the original design. Use the router as a router on a stick again. Trunk the vlans up to the 3640 and assign subinterfaces to each vlan. The IPX config will then be applied to the sub-interfaces and you are sorted. OR if there is a split in the applications (servers) then place the IPX servers in their own vlan and trunk that up to the router.

Re: IPX not working with new Network Configuration

How about Fallback Bridging? (Used to be IRB)

http://www.cisco.com/en/US/products/hw/switches/ps646/products_configuration_guide_chapter09186a00801cdf24.html

Route IP, and bridge everything else across SVIs.

Michael

Cisco Employee

Re: IPX not working with new Network Configuration

Michael's right. Fallback Bridging is definitely the way to go here.

HTH,

Bobby

New Member

Re: IPX not working with new Network Configuration

Hey Guys Thanks!! I have not had a chance to fully implement this yet but I have my EMI image on and I am setting up my multicast routing as we speak. I've read about fallback bridging and I think this will do the trick. I appreciate the input and time you gave my question.

130
Views
5
Helpful
6
Replies