Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

IPX Roting Issues

I have a customer with two 1700 Routers connecting their remote offices. Both routers configured for both IP and IPX Networks. IP network is up all the time. while IPX network is not. The server at each location will lose connectivity ever couple hours for 5 to 10 min. There are only 1 server and 2 printers in each location. I\any Ideas would be greatly appreciated

  • Other Network Infrastructure Subjects
7 REPLIES

Re: IPX Roting Issues

Please provide a bit more information on your issue:

What medium is between the routers? ( ISDN, Frame Relay, Leased Line)

What routing protocol do you use? (RIP/SAP, EIGRP or NLSP)

What do you observe when the problem occurs?

Do you see a change in the output for one of the commands below?

Please upload the output of:

sh ipx servers

and

sh ipx ro

Then we can try to help you.

Regards,

Leo

New Member

Re: IPX Roting Issues

Its ISDN connection and Using RIP. When the problem occurs, The clients loose connections to the remote server. But yet they can still IP ping the Workstations on the other side. The servers are running IPX only. We are using ARPA encapsulation. I will Upload the data as soon as I get it

Thanks

New Member

Re: IPX Roting Issues

Here's what the remote router sees and its config.

!

ip dhcp pool kcliff

network 192.168.72.0 255.255.255.192

dns-server 192.168.72.1

default-router 192.168.72.62

!

no ip domain-lookup

no ip finger

ipx routing 1897.a101.ae28

isdn switch-type basic-ni

isdn voice-call-failure 0

cns event-service server

!

!

!

!

!

interface Ethernet0

description connected to kCliff-LAN

ip address 192.168.72.62 255.255.255.192

no ip directed-broadcast

no keepalive

ipx network C0A84800 encapsulation ARPA

!

interface BRI0

description connected to Main

no ip address

no ip directed-broadcast

encapsulation ppp

dialer rotary-group 1

isdn switch-type basic-ni

isdn spid1 46995216360101

isdn spid2 46995216370101

no cdp enable

!

interface Dialer1

description Dialer to Main

ip unnumbered Ethernet0

no ip directed-broadcast

encapsulation ppp

no ip split-horizon

keepalive 15

dialer in-band

dialer map ipx C0A84801.1897.b158.c15c name Main broadcast 9729266722

dialer map ip 192.168.35.254 name Main broadcast 9729266722

dialer hold-queue 10

dialer load-threshold 10 outbound

dialer-group 1

ipx network C0A84801

no cdp enable

ppp authentication chap

ppp multilink

!

router rip

version 2

network 192.168.72.0

no auto-summary

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.35.254

!

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

!

!

!

snmp-server engineID local 00000009020000B0C28B04E7

!

line con 0

exec-timeout 5 0

password 7 0355481F121D20425D000D

login

transport input none

stopbits 1

line vty 0 1

exec-timeout 5 0

password 7 101F1A0D110513051F0D3E

login

line vty 2 4

exec-timeout 5 0

no login

!

end

kcliff#sh ipx serv

Codes: S - Static, P - Periodic, E - EIGRP, N - NLSP, H - Holddown, + = detail

U - Per-user static

19 Total IPX Servers

Table ordering is based on routing and server info

Type Name Net Address Port Route Hops Itf

P 4 FT-KCLIFF 3A68CCE8.0000.0000.0001:0451 2/01 1 Et0

P 4 FT-Main 20010104.0000.0000.0001:0451 8/02 2 Di1

P 77 TS@FT-Main 20010104.0000.0000.0001:0000 8/02 2 Di1

P 107 FT-KCLIFF 3A68CCE8.0000.0000.0001:8104 2/01 1 Et0

P 107 FT-Main 20010104.0000.0000.0001:8104 8/02 2 Di1

P 23F FT-Main 20010104.0000.0000.0001:907B 8/02 2 Di1

P 26B ATENC________ 20010104.0000.0000.0001:0005 8/02 2 Di1

P 278 ATENC________ 3A68CCE8.0000.0000.0001:4006 2/01 1 Et0

P 278 ATENC________ 20010104.0000.0000.0001:4006 8/02 2 Di1

P 30C 0001E631A3C302DGOPERA C0A84800.0001.e631.a3c3:400C 1/00 1 Et0

P 30C 0001E631A36D02DGHR C0A82300.0001.e631.a36d:400C 7/01 2 Di1

P 30C 00108306B49302CYTRAIL C0A82300.0010.8306.b493:400C 7/01 2 Di1

P 30C 001083BCF7F902D0PARTS C0A82300.0010.83bc.f7f9:400C 7/01 2 Di1

P 640 C68T00B C0A84800.00b0.d072.d3e6:E885 1/00 1 Et0

P 640 LARRYANO C0A84800.0010.4b69.6c65:E885 1/00 1 Et0

P 640 D68T00B C0A82300.00b0.d044.a01f:E885 7/01 2 Di1

Type Name Net Address Port Route Hops Itf

P 640 LAWANDA C0A82300.00b0.d075.b93b:E885 7/01 2 Di1

P 640 TINA C0A82300.00c0.4f0e.8259:E885 7/01 2 Di1

P 76C G1G100034716E2E8EXECU C0A82300.0003.4716.e2e8:900F 7/01 2 Di1

kcliff#sh ipx route

Codes: C - Connected primary network, c - Connected secondary network

S - Static, F - Floating static, L - Local (internal), W - IPXWAN

R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate

s - seconds, u - uses, U - Per-user static

6 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.

No default route known.

C C0A84800 (ARPA), Et0

C C0A84801 (PPP), Di1

R 20010104 [08/02] via C0A84801.1897.b158.c15c, 20s, Di1

R 3A68CCE8 [02/01] via C0A84800.00b0.d079.da4f, 54s, Et0

R C0A82300 [07/01] via C0A84801.1897.b158.c15c, 20s, Di1

R C0A84841 [07/01] via C0A84801.1897.b158.c15c, 20s, Di1

kcliff#sh ipx traffic

System Traffic for 0.0000.0000.0001 System-Name: kcliff

Time since last clear: never

Rcvd: 3404816 total, 4481 format errors, 0 checksum errors, 0 bad hop count,

4799 packets pitched, 246402 local destination, 0 multicast

Bcast: 246868 received, 177890 sent

Sent: 3328336 generated, 3150327 forwarded

7 encapsulation failed, 3288 no route

SAP: 1185 Total SAP requests, 0 Total SAP replies, 19 servers

0 SAP general requests, 0 ignored, 0 replies

651 SAP Get Nearest Server requests, 0 replies

534 SAP Nearest Name requests, 0 replies

0 SAP General Name requests, 0 replies

168522 SAP advertisements received, 88724 sent, 0 Throttled

12779 SAP flash updates sent, 0 SAP format errors

RIP: 465 RIP requests, 0 ignored, 126 RIP replies, 6 routes

76230 RIP advertisements received, 63712 sent 0 Throttled

12666 RIP flash updates sent, 0 atlr sent

0 RIP format errors

Echo: Rcvd 0 requests, 0 replies

Sent 0 requests, 0 replies

0 unknown: 0 no socket, 0 filtered, 0 no helper

0 SAPs throttled, freed NDB len 0

Watchdog:

0 packets received, 0 replies spoofed

Queue lengths:

IPX input: 0, SAP 0, RIP 0, GNS 0

SAP throttling length: 0/(no limit), 0 nets pending lost route reply

Delayed process creation: 0

EIGRP: Total received 0, sent 0

Updates received 0, sent 0

Queries received 0, sent 0

Replies received 0, sent 0

SAPs received 0, sent 0

Trace: Rcvd 0 requests, 0 replies

Sent 0 requests, 0 replies

kcliff#sh ipx spx-spoof

Local SPX Network.Host:sock Cid Remote SPX Network.Host:sock Cid Seq Ack Idle

kcliff#sh ipx ppp-c

Master Client(s)

kcliff#sh ipx interface

Dialer1 is up, line protocol is up

IPX address is C0A84801.1897.a101.ae28 [up]

Delay of this IPX network, in ticks is 6 throughput 0 link delay 0

IPXWAN processing not enabled on this interface.

IPX SAP update interval is 60 seconds

IPX type 20 propagation packet forwarding is disabled

Incoming access list is not set

Outgoing access list is not set

IPX helper access list is not set

SAP GGS output filter list is not set

SAP GNS processing enabled, delay 0 ms, output filter list is not set

SAP Input filter list is not set

SAP Output filter list is not set

SAP Router filter list is not set

Input filter list is not set

Output filter list is not set

Router filter list is not set

Netbios Input host access list is not set

Netbios Input bytes access list is not set

Netbios Output host access list is not set

Netbios Output bytes access list is not set

Updates each 60 seconds aging multiples RIP: 3 SAP: 3

SAP interpacket delay is 55 ms, maximum size is 480 bytes

RIP interpacket delay is 55 ms, maximum size is 432 bytes

RIP response delay is not set

Watchdog processing is currently disabled

SPX spoofing is disabled, idle time 60

IPX accounting is disabled

IPX fast switching is configured (disabled)

RIP packets received 44522, RIP packets sent 31857, 0 Throttled

RIP specific requests received 0, RIP specific replies sent 0

RIP general requests received 0, 0 ignored, RIP general replies sent 0

SAP packets received 69110, SAP packets sent 32119, 0 Throttled

SAP GNS packets received 0, SAP GNS replies sent 0

SAP GGS packets received 0, 0 ignored, SAP GGS replies sent 0

Ethernet0 is up, line protocol is up

IPX address is C0A84800.00b0.c28b.04e7, ARPA [up]

Delay of this IPX network, in ticks is 1 throughput 0 link delay 0

IPXWAN processing not enabled on this interface.

IPX SAP update interval is 60 seconds

IPX type 20 propagation packet forwarding is disabled

Incoming access list is not set

Outgoing access list is not set

IPX helper access list is not set

SAP GGS output filter list is not set

SAP GNS processing enabled, delay 0 ms, output filter list is not set

SAP Input filter list is not set

SAP Output filter list is not set

SAP Router filter list is not set

Input filter list is not set

Output filter list is not set

Router filter list is not set

Netbios Input host access list is not set

Netbios Input bytes access list is not set

Netbios Output host access list is not set

Netbios Output bytes access list is not set

Updates each 60 seconds aging multiples RIP: 3 SAP: 3

SAP interpacket delay is 55 ms, maximum size is 480 bytes

RIP interpacket delay is 55 ms, maximum size is 432 bytes

RIP response delay is not set

IPX accounting is disabled

IPX fast switching is configured (disabled)

RIP packets received 32175, RIP packets sent 44651, 0 Throttled

RIP specific requests received 465, RIP specific replies sent 465

RIP general requests received 0, 0 ignored, RIP general replies sent 0

SAP packets received 100604, SAP packets sent 69389, 0 Throttled

SAP GNS packets received 651, SAP GNS replies sent 0

SAP GGS packets received 0, 0 ignored, SAP GGS replies sent 0

Thanks

Re: IPX Roting Issues

Thanks for the data. One thing I noticed is that you have a default route for IP. This means that routing will continue to operate even if the RIP-updates are failing. For IPX there is no such mechanism.

In theory it should be possible that the line is overloaded with IP traffic. This may cause sequential RIP/SAP updates to be dropped. After missing 3 updates in a row, the route will be dropped from the routing table. Without a default route, traffic will be dropped also. When the traffic on the link drops, the updates will start to arrive again and the route is restored.

So you can check two things:

Do you see dropped packets on dialer1on either side?

Is it a possibility that the line overloaded with IP traffic on a regular basis?

Regards,

Leo

New Member

Re: IPX Roting Issues

Thanks for the Input. I doubt that IP traffic is saturating the Connection. Its being used only for Mail (Notes Mail Server) and that's only 3 or 4 employees at the remote site.

I'll check Dailer1 when we loose connection aghain and Let you know if we do.

'

Thanks

New Member

Re: IPX Roting Issues

I have checked Both servers and they have IPX Forwarding Disabled. and Here what the server would output once can not reach the Remote server

SYNC: Start sync of partition <[Root]> state:[0] type:[1]

SYNC: Start outbound sync with (#=2, state=0, type=0)

[0100017D]

land.FT-Dallas>

SYNC: Using version 5 on server

SYNC: sending updates to server

SYNC: Objects: 1, total changes: 1, sent to server

SYNC: update to server successfully completed

SYNC: End sync of partition <[Root]> All processed = YES.

(2003/06/05 14:54:12)

SYNC: Start sync of partition <[Root]> state:[0] type:[1]

SYNC: Start outbound sync with (#=2, state=0, type=0)

[0100017D]

land.FT-Dallas>

(14:56:08) SYNC: failed to communicate with server ERROR:

-625

SYNC: End sync of partition <[Root]> All processed = NO.

(2003/06/05 14:56:18)

SYNC: Start sync of partition <[Root]> state:[0] type:[1]

SYNC: Start outbound sync with (#=2, state=0, type=0)

[0100017D]

land.FT-Dallas>

(14:56:18) SYNC: failed to communicate with server ERROR:

-625

SYNC: End sync of partition <[Root]> All processed = NO.

During that time IP would be forwarded with no problem. and Here's what both Routers sees at that momment.

garland#sh ipx ser

Codes: S - Static, P - Periodic, E - EIGRP, N - NLSP, H - Holddown, + = detail

U - Per-user static

17 Total IPX Servers

Table ordering is based on routing and server info

Type Name Net Address Port Route Hops Itf

P 4 FT-GARLAND 20010104.0000.0000.0001:0451 2/01 1 Fa0

P 4 FT-OAKCLIFF 3A68CCE8.0000.0000.0001:0451 8/02 2 Di1

P 77 TS@FT-GARLAND 20010104.0000.0000.0001:0000 2/01 1 Fa0

P 107 FT-GARLAND 20010104.0000.0000.0001:8104 2/01 1 Fa0

P 107 FT-OAKCLIFF 3A68CCE8.0000.0000.0001:8104 8/02 2 Di1

P 23F FT-GARLAND 20010104.0000.0000.0001:907B 2/01 1 Fa0

P 26B ATE_RYDER_INC________ 20010104.0000.0000.0001:0005 2/01 1 Fa0

P 278 ATE_RYDER_INC________ 20010104.0000.0000.0001:4006 2/01 1 Fa0

P 278 ATE_RYDER_INC________ 3A68CCE8.0000.0000.0001:4006 8/02 2 Di1

P 30C 0001E631A36D02DGHR C0A82300.0001.e631.a36d:400C 1/00 1 Fa0

P 30C 00108306B49302CYTRAIL C0A82300.0010.8306.b493:400C 1/00 1 Fa0

P 30C 001083BCF7F902D0PARTS C0A82300.0010.83bc.f7f9:400C 1/00 1 Fa0

P 30C 0001E631A3C302DGOPERA C0A84800.0001.e631.a3c3:400C 7/01 2 Di1

P 640 D68T00B C0A82300.00b0.d044.a01f:E885 1/00 1 Fa0

P 640 TINA C0A82300.00c0.4f0e.8259:E885 1/00 1 Fa0

P 640 C68T00B C0A84800.00b0.d072.d3e6:E885 7/01 2 Di1

P 76C G1G100034716E2E8EXECU C0A82300.0003.4716.e2e8:900F 1/00 1 Fa0

garland#sh ipx route

Codes: C - Connected primary network, c - Connected secondary network

S - Static, F - Floating static, L - Local (internal), W - IPXWAN

R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate

s - seconds, u - uses, U - Per-user static

6 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.

No default route known.

C C0A82300 (ARPA), Fa0

C C0A84801 (PPP), Di1

C C0A84841 (PPP), Di2

RH 20010104 [02/01] via C0A82300.00b0.d079.b4f0, 192s, Fa0

R 3A68CCE8 [08/02] via C0A84801.1897.a101.ae28, 26s, Di1

R C0A84800 [07/01] via C0A84801.1897.a101.ae28, 26s, Di1

garland#exit

oakcliff#sh ipx route

Codes: C - Connected primary network, c - Connected secondary network

S - Static, F - Floating static, L - Local (internal), W - IPXWAN

R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate

s - seconds, u - uses, U - Per-user static

6 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.

No default route known.

C C0A84800 (ARPA), Et0

C C0A84801 (PPP), Di1

RH 20010104 [**/**] via C0A84801.1897.b158.c15c, 66s, Di1

R 3A68CCE8 [02/01] via C0A84800.00b0.d079.da4f, 26s, Et0

R C0A82300 [07/01] via C0A84801.1897.b158.c15c, 6s, Di1

R C0A84841 [07/01] via C0A84801.1897.b158.c15c, 6s, Di1

oakcliff#sh ipx serv

Codes: S - Static, P - Periodic, E - EIGRP, N - NLSP, H - Holddown, + = detail

U - Per-user static

17 Total IPX Servers

Table ordering is based on routing and server info

Type Name Net Address Port Route Hops Itf

P 4 FT-OAKCLIFF 3A68CCE8.0000.0000.0001:0451 2/01 1 Et0

P 4 FT-GARLAND 20010104.0000.0000.0001:0451

P 77 TS@FT-GARLAND 20010104.0000.0000.0001:0000

P 107 FT-OAKCLIFF 3A68CCE8.0000.0000.0001:8104 2/01 1 Et0

P 107 FT-GARLAND 20010104.0000.0000.0001:8104

P 23F FT-GARLAND 20010104.0000.0000.0001:907B

P 26B ATE_RYDER_INC________ 20010104.0000.0000.0001:0005

P 278 ATE_RYDER_INC________ 3A68CCE8.0000.0000.0001:4006 2/01 1 Et0

P 278 ATE_RYDER_INC________ 20010104.0000.0000.0001:4006

P 30C 0001E631A3C302DGOPERA C0A84800.0001.e631.a3c3:400C 1/00 1 Et0

P 30C 0001E631A36D02DGHR C0A82300.0001.e631.a36d:400C 7/01 2 Di1

P 30C 00108306B49302CYTRAIL C0A82300.0010.8306.b493:400C 7/01 2 Di1

P 30C 001083BCF7F902D0PARTS C0A82300.0010.83bc.f7f9:400C 7/01 2 Di1

P 640 C68T00B C0A84800.00b0.d072.d3e6:E885 1/00 1 Et0

P 640 D68T00B C0A82300.00b0.d044.a01f:E885 7/01 2 Di1

P 640 TINA C0A82300.00c0.4f0e.8259:E885 7/01 2 Di1

Type Name Net Address Port Route Hops Itf

P 76C G1G100034716E2E8EXECU C0A82300.0003.4716.e2e8:900F 7/01 2 Di1

Thanks for all your help.

Silver

Re: IPX Roting Issues

check the Novell box and make sure that ip forwarding and/or RIp is disabled. The novell box could be injecting bogus routes.

164
Views
0
Helpful
7
Replies
This widget could not be displayed.