Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IRB Feature on Cisco 2621 with a Trunk to a Catalyst 3550

Hi,

i have a problem with a Catalyst 3550 and a Cisco 2621 connected over a trunk. On the Router is IRB configured to bridge betwen two Vlans and two route between the other. Here the relevant configuration:

ROUTER 2621 Configuration

bridge irb

interface FastEthernet0/1

description TRUNK TO CATALYST

no ip address

speed 100

full-duplex

interface FastEthernet0/0.21

encapsulation isl 21

ip address 192.168.1.1 255.255.255.0

no ip redirects

interface FastEthernet0/0.22

encapsulation isl 22

no ip redirects

bridge-group 66

interface FastEthernet0/0.23

encapsulation isl 23

no ip redirects

bridge-group 66

interface BVI66

ip address 192.168.2.254 255.255.255.0

bridge 66 protocol ieee

bridge 66 route ip

CATALYST 3550 Configuration

interface FastEthernet0/6

description TRUNK TO LANR001 FAS 0/1

switchport trunk encapsulation isl

switchport mode trunk

no ip address

duplex full

speed 100

interface Vlan23

ip address 192.168.2.1 255.255.255.0

When i try to reach the Catalyst from an station in VLAN 22 with ip address 192.168.2.2 it doesn't work, same when i try to reach the station from the switch. The only station where it works ist the Cisco 2621 with the trunk.

Same configuration on a Catalyst 5000 works.

Any help welcome!!

Regards

2 REPLIES

Re: IRB Feature on Cisco 2621 with a Trunk to a Catalyst 3550

Is your station plugged into a port on the 3550 in VLAN22 ?

Can you do a show int fa0/6 switchport and paste results here?

If you have the EMI image on the 3550 you can set up a interface vlan22 as well and route for all the VLANs.

New Member

Re: IRB Feature on Cisco 2621 with a Trunk to a Catalyst 3550

Yes the station is plugged into to a port on he 3550 VLAN22.

Here ist the show output:

CAT3550#sh int fas 0/6 switchport

Name: Fa0/6

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: isl

Operational Trunking Encapsulation: isl

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Protected: false

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Voice VLAN: none (Inactive)

Appliance trust: none

I know that i can route betwenn VLANs with the EMI image, but the SMI image is running. The other point is why it works with a Catalyst 5000 and not with the 3550?

Regards

254
Views
0
Helpful
2
Replies