Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

IS-IS to OSPF Redistribution

I am facing a problem while redistributing between IS-IS and OSPF. I try to explain you below

A--------B-----------C

A and C has 3 Physical (2Serial and 1Fastethernet) and a loopback interface. B has only 3 Physical interfaces and no loopback interfaces.

B and C are in same ISIS network so I made L2-only adjecency between them.

A has all its interfaces are completely in OSPF. B and C has all its interfaces in IS-IS.

On C I used passive interace loopback X to advertise loopback interaface. On physical interfaces I used ip router isis (Level-2 only).

On B I can see connected interfaces of C as IS-IS learned and vice-versa. Problem is as below

When I redistribute between ISIS and OSPF on B. Router A can see only IS-IS learned routes in B. I mean I cant see connected interfaces of B though I enabled ISIS and redistributed in to OSPF.

Any idea???

Tanks,

Martin

23 REPLIES
New Member

Re: IS-IS to OSPF Redistribution

Hi,

Correction....Adjecency is L1 only not L2.

I tried with L2 only too but same result. I could not see ISIS interfaces of Router B

Thanks,

Martin

Bronze

Re: IS-IS to OSPF Redistribution

Martin,

A is not learning of the routes connected to B because your redistribution tells B to redistribute routes learned via IS-IS into OSPF. However, B does not learn of its connected routes via IS-IS, it sees them as connected. Have B redistribute "connected" into OSPF, with subnets, and A should learn of these networks.

HTH

Mark

New Member

Re: IS-IS to OSPF Redistribution

Mark,

But ISIS is enabled on the interface. If you see any other routing protocol like EIGRP, RIP and also OSPF....They redistribute if you enable routing protocol on it in to other protocol.

So you mean to say......While redistribution do we have to redistribute conencted networks always in addition to routing protocol?

Thanks,

Martin

Bronze

Re: IS-IS to OSPF Redistribution

Martin,

Yes, any redistribution goes from the redistributing router's routing table - not a routing process's database - into the second protocol. Your router B will redistribute routes learned via IS-IS, shown as "i" in its routing table, to OSPF. B's routing table shows its connected networks as "C", not "i".

You have another option. You can run OSPF on B's connected interfaces. You can make them passive interfaces if you want.

HTH

Mark

New Member

Re: IS-IS to OSPF Redistribution

Mark,

You mean if I redistribute connected in router B, does all connected networks shows as with tag i instead of c? I dont think so.....Connected always have admin distance of 0 which is the lowest. So how connected interfaces vanishes and appear as learned from isis with the command redistribute connected.

Have you ever tried above? It is impractical and voilates the basic rules.

Thanks,

Martin

Bronze

Re: IS-IS to OSPF Redistribution

No, the connected routes still show up as C in router B. I mentioned two different things here - redistributing connected networks into OSPF, and including B's connected networks in its OSPF configuration. These are two methods of getting B's connected networks advertised into OSPF. I've done this with other protocols, never IS-IS. It is very practical, and what rules does it violate?

Mark

Gold

Re: IS-IS to OSPF Redistribution

So, the problem here is in the way IS-IS treats the IP routing table. Each route in the routing table has a set of markers that correspond to routing processes. So, for instance, a connected route is marked "C", so the routing table knows that route was inserted by, or is "owned by" a connected interface.

If a route is installed in the routing table by a given OSPF route, that OSPF process' marker will be attached to the route in the routing table. When the routing table displays routes, it uses this set of markers to determine what letter to put beside the route. If an ospf process installed the route, put an O out there, or an E1, or E2--as needed.

What normally happens when you configure a network statement which "covers" an interface on the router, is the process which now "owns" that route sets the marker in this data structure. Thus, while the route shows conencted in the output of show ip route, it has two markers, one for connected and one for the process with the network statement covering it. Since the connected marker has "higher precedence," it's the only one displayed. When you redistribute from this process to another routing process on the same router, it is picked up by the receiving process out of the routing table, since the route has been marked by the source process.

I hope this much makes sense.

IS-IS doesn't set these markers for local interface routes--only for routes IS-IS actually installs in the routing table. This makes sense, if you think about it, because IS-IS doesn't use network statements, it uses interface configuration commands to enable routing. The other protocols work through the routing table to determine which interfaces to run on, based on the entered network statement (excetpt BGP). IS-IS doesn't.

Does this make sense?

Russ.W

New Member

Re: IS-IS to OSPF Redistribution

Russ,

Thanks...It makes sense.

So do I have to redistribute conencted in ISIS to make these routes to appear in OSPF upon redistribution? or anythign else?

What exactly the command ip router isis in interface mode does......This comamnd does not enable ISIS Process on it?

Could just give a single URL on CCO for this?

Thanks,

Martin

New Member

Re: IS-IS to OSPF Redistribution

Russ,

...But my question is not answered. How do I get these conencted interfaces of Router B in to router A??? My customer doesnot agree to enable ospf on it though I enable passive interface on it.

He wants the interfaces should be in ISIS demarcation (This is a kind of boundary between 2 Vendors and I cant convince him on this)..........

Can somebody help me on this? How do I make it happen?

I built a test bed and tried hell lott of R and D but finally question is remains same.

Is there any solution for this question other than enabling OSPF on the interface?

Thanks,

Martin

Gold

Re: IS-IS to OSPF Redistribution

Can't you use redistribute connected with a distribute list? OSPF and IS-IS are both already running on the box, right?

Russ.W

New Member

Re: IS-IS to OSPF Redistribution

Russ,

I tried redistributing connected in to ISIS but no use. Is redistributing the connected in to OSPF is the only solution other than enabling OSPF and making it passive? or any other way is possible?

I could not find a sample confiuration document even on CCO. I appreicate is you can send show me the URL for this kind of configuration.

Thanks alott,

Martin

Gold

Re: IS-IS to OSPF Redistribution

There are two issues, most likely. Are you configuring a metric? Some routing protocols will pick up the metric for a redistribute connected from the local interfaces themselves, others won't. Try a metric ont he redistribute command. The second is that you cannot redistribute into an L1 routing domain, only an L2 routing domain, by default. You have to use the command:

redistribute connected level-1 metric 10

I'd still change to a single IS-IS process, as troubleshooting and maintaining two different IS-IS processes, one for level 1 routes, and one for level 2 routes, and then attempting to redistribute between the two, is going to be painful. In fact, you're going to end up having to run L1 on the L2 side anyway, since you have to have L1 routing to reach other routers within the L@ routing domain.

Russ.W

New Member

Re: IS-IS to OSPF Redistribution

Russ....Thanks and I apreciate your help

Tried with your guidelines but problem remains same.

Shall I conclude that there is no way to achieve the above via ISIS?

Appreciate anybody can help on this if you u come across this kind of problem...

Thanks,

Martin

Gold

Re: IS-IS to OSPF Redistribution

Can you post your current configuration?

Russ.W

Bronze

Re: IS-IS to OSPF Redistribution

Everyones comments so far are correct but you dont seem to get the picture. Look at the routing table in B. It uses the routing table to determine what routes are in the source protocol and all connected networks are in the routing table as Connected, regardless of what protocols they are being advertised. This isnt an isis thing. This is a fact with most routing protocols. You have the same problem if you were redistributing ospf int isis on B.

In a clean design the border router between the two networks would be a dedicated router, with no user networks attached. Then your redist between the two protocols would be all you would need. If you have to know about the networks on the border router then you have to:

1. redistribute connected or

2. add those networks to both protocols

Gold

Re: IS-IS to OSPF Redistribution

Wrong. :-) EIGRP will pick up interfaces in this situation. For instance:

!

router eigrp 100

redistribute ospf 100 metric 10000 1 255 1 1500

network 208.0.16.0

no auto-summary

!

router ospf 100

log-adjacency-changes

network 208.0.6.0 0.0.0.255 area 0

network 208.0.12.10 0.0.0.0 area 0

!

router isis foo

net 49.0001.0001.0001.0001.00

redistribute ospf 100 metric 10

!

Note that eigrp is redistributing ospf, not connected. IS-IS is also redistributing ospf, not connected.

Now, looking at the routing table:

2651A#sho ip route conn

C 208.0.12.0/24 is directly connected, Serial0/2

C 208.0.7.0/24 is directly connected, Serial0/0

C 208.0.6.0/24 is directly connected, FastEthernet0/0

C 208.0.0.0/24 is directly connected, FastEthernet0/1

208.0.6.0/24 is connected, and is covered by an OSPF network statement. EIGRP should not be picking this route up, right? Let's look at EIGRP's topo table:

2651A#sho ip eigrp topo 208.0.6.0

IP-EIGRP (AS 100): Topology entry for 208.0.6.0/24

State is Passive, Query origin flag is 1, 1 Successor(s), FD is 256256

Routing Descriptor Blocks:

0.0.0.0, from Redistributed, Send flag is 0x0

Composite metric is (256256/0), Route is External

Vector metric:

Minimum bandwidth is 10000 Kbit

Total delay is 10 microseconds

Reliability is 255/255

Load is 1/255

Minimum MTU is 1500

Hop count is 0

External data:

Originating router is 208.0.12.10 (this system)

AS number of route is 100

External protocol is OSPF, external metric is 0

Administrator tag is 0 (0x00000000)

It's redistributed, with an origin of 0.0.0.0, which is this router. I'm not learning it from another router, I'm redistributing it from OSPF, locally. Which means EIGRP is looking at the routing table, seeing the OSPF process has a network statement covering the 208.0.6.0/24, even though it's directly connected, and picking it up through the redistribute OSPF. Not through redistribute connected.

I'm certain RIP acts the same way. IS-IS is even doing this here:

2651A#show isis data detail

IS-IS Level-1 Link State Database:

LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

2651A.00-00 * 0x00000268 0x866B 520 0/0/0

Area Address: 49.0001

NLPID: 0xCC

Hostname: 2651A

IP Address: 208.0.7.10

Metric: 10 IP 208.0.7.0 255.255.255.0

IS-IS Level-2 Link State Database:

LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

2651A.00-00 * 0x00000267 0xC347 692 0/0/0

Area Address: 49.0001

NLPID: 0xCC

Hostname: 2651A

IP Address: 208.0.7.10

Metric: 10 IP-External 208.0.12.0 255.255.255.0

Metric: 10 IP 208.0.7.0 255.255.255.0

Metric: 10 IP-External 208.0.6.0 255.255.255.0

Note the 208.0.6.0/24 included as in IP external!

It's all in how the routing table works, and how the protocols pull redistributed routes, and how IS-IS interacts with the routing table.

:-)

Russ.W

New Member

Re: IS-IS to OSPF Redistribution

Russ,

I am away from the site....but believe me there is no problem in the configuration apart from what I explained above. I can type all configuration if you want, I became very familar with the current configuratiuon as I am dealing with this for past one week.

Jacakson,

Thanks for your comment on this scenario......While redistributing OSPF in to ISIS(At ROuter A), I am getting all connected interfaces of Router A where I enabled OSPF in ISIS router (ROuter B). I can see this problem as one-way i.e only redistributing ISIS in to OSPF. I am sorry this is only problem with ISIS all other IGP protocols beahve as we expect and they redistrinute if I enable IGP protocol with network command.

May be Russ comment is true on how ISIS advertise the routes ( I could not check the RFCs though)...As you mentioned in your second paragraph, may be that is true in most SPs regarding a dedicated boarder router but my customer has this scenario and demarcation is very important (This is between 2 vendors).........I have even BGP Peering betwen loopbacks which is not happeing due to this reason as connected loopback interface is not getting advertised.

I tried redistributing connected in to ISIS and then in to OSPF but it was not happening.....So far only the configuration worked was I have to either enable OSPF with network command or redistribute in to OSPF from connected directly.

Thanks for all your support I really appreciate it,

Martin

Gold

Re: IS-IS to OSPF Redistribution

Are you trying to get the conencted routes into the level 2, or level 1 side of the network? Can you check show isis database detail and make certain the connected routes are showing up in the database? If the peer you're trying to get the routes to is an L2 peer, then try using level-2 in the redistribute command, rather than level-1.

Russ.W

New Member

Re: IS-IS to OSPF Redistribution

Russ,

This is from a test-bed. This is similar to production one

!

interface Loopback0

ip address 192.168.3.1 255.255.255.0

!

interface Loopback1

ip address 192.168.4.1 255.255.255.0

!

interface FastEthernet0/0

ip address 192.168.5.1 255.255.255.0

ip router isis

speed auto

half-duplex

!

interface Serial0/0

no ip address

encapsulation frame-relay

!

interface Serial0/0.2 point-to-point

ip address 172.16.1.2 255.255.255.0

frame-relay interface-dlci 111

!

interface Serial0/0.3 point-to-point

ip address 172.16.2.1 255.255.255.0

ip router isis

isis circuit-type level-1

frame-relay interface-dlci 112

!

router ospf 1

no log-adjacency-changes

redistribute isis level-1 metric 20 subnets

network 172.16.1.0 0.0.0.255 area 16

network 192.168.3.0 0.0.0.255 area 16

!

router isis

redistribute connected metric 20 level-1

redistribute ospf 1 metric 10 level-1

passive-interface Loopback1

net 49.0001.0000.0000.0001.00

!

B#sh isis database det

B#sh isis database detail

IS-IS Level-1 Link State Database:

LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

B.00-00 * 0x0000000D 0x4245 1009 0/0/0

Area Address: 49.0001

NLPID: 0xCC

Hostname: B

IP Address: 192.168.4.1

Metric: 10 IP 192.168.5.0 255.255.255.0

Metric: 10 IP 172.16.2.0 255.255.255.0

Metric: 0 IP 192.168.4.0 255.255.255.0

Metric: 10 IS B.01

Metric: 10 IS C.00

Metric: 20 IP-External 172.16.1.0 255.255.255.0

Metric: 10 IP-External 192.168.1.1 255.255.255.255

Metric: 10 IP-External 192.168.2.0 255.255.255.0

Metric: 20 IP-External 192.168.3.0 255.255.255.0

C.00-00 0x0000000A 0x6315 1084 0/0/0

Area Address: 49.0001

NLPID: 0xCC

Hostname: C

IP Address: 192.168.6.1

Metric: 10 IP 192.168.7.0 255.255.255.0

Metric: 10 IP 172.16.2.0 255.255.255.0

Metric: 0 IP 192.168.6.0 255.255.255.0

Metric: 10 IS C.01

Metric: 10 IS B.00

IS-IS Level-2 Link State Database:

LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

B.00-00 * 0x0000000A 0x7689 1051 0/0/0

Area Address: 49.0001

NLPID: 0xCC

Hostname: B

IP Address: 192.168.4.1

Metric: 10 IS B.01

Metric: 10 IP 172.16.2.0 255.255.255.0

Metric: 0 IP 192.168.4.0 255.255.255.0

Metric: 10 IP 192.168.5.0 255.255.255.0

Metric: 10 IP 192.168.6.0 255.255.255.0

Metric: 20 IP 192.168.7.0 255.255.255.0

C.00-00 0x00000007 0x4EAA 228 0/0/0

Area Address: 49.0001

NLPID: 0xCC

Hostname: C

IP Address: 192.168.6.1

Metric: 10 IS C.01

Metric: 10 IS B.00

Metric: 20 IP 172.16.1.0 255.255.255.0

Metric: 10 IP 172.16.2.0 255.255.255.0

Metric: 10 IP 192.168.4.0 255.255.255.0

Metric: 20 IP 192.168.5.0 255.255.255.0

Metric: 0 IP 192.168.6.0 255.255.255.0

Metric: 10 IP 192.168.7.0 255.255.255.0

Metric: 20 IP 192.168.3.0 255.255.255.0

B#

B#

B#

B#

B#

B#

B#sh ip os

B#sh ip ospf da

OSPF Router with ID (192.168.100.12) (Process ID 1)

Router Link States (Area 16)

Link ID ADV Router Age Seq# Checksum Link count

192.168.100.11 192.168.100.11 802 0x8000000A 0x3E53 4

192.168.100.12 192.168.100.12 694 0x80000013 0xE621 3

192.168.100.13 192.168.100.13 2105 0x80000006 0x3504 5

192.168.100.14 192.168.100.14 2644 0x80000003 0xBE83 5

192.168.100.15 192.168.100.15 2674 0x80000003 0xCB4A 5

192.168.100.16 192.168.100.16 2666 0x80000006 0x1A51 8

Net Link States (Area 16)

Link ID ADV Router Age Seq# Checksum

172.16.9.2 192.168.100.14 2644 0x80000001 0x22BD

Type-5 AS External Link States

Link ID ADV Router Age Seq# Checksum Tag

192.168.6.0 192.168.100.12 694 0x80000001 0xE076 0

192.168.7.0 192.168.100.12 694 0x80000001 0xD580 0

B#

B#

B#

B#

B#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0 255.255.255.0 is subnetted, 2 subnets

C 172.16.1.0 is directly connected, Serial0/0.2

C 172.16.2.0 is directly connected, Serial0/0.3

C 192.168.4.0 255.255.255.0 is directly connected, Loopback1

C 192.168.5.0 255.255.255.0 is directly connected, FastEthernet0/0

i L1 192.168.6.0 255.255.255.0 [115/10] via 172.16.2.2, Serial0/0.3

i L1 192.168.7.0 255.255.255.0 [115/20] via 172.16.2.2, Serial0/0.3

192.168.1.0 255.255.255.255 is subnetted, 1 subnets

O 192.168.1.1 [110/65] via 172.16.1.1, 00:04:56, Serial0/0.2

O 192.168.2.0 255.255.255.0 [110/74] via 172.16.1.1, 00:04:56, Serial0/0.2

C 192.168.3.0 255.255.255.0 is directly connected, Loopback0

B#

New Member

Re: IS-IS to OSPF Redistribution

A#

!

!

interface Loopback0

ip address 192.168.1.1 255.255.255.0

!

interface FastEthernet0/0

ip address 192.168.2.1 255.255.255.0

speed auto

half-duplex

!

interface Serial0/0

no ip address

encapsulation frame-relay

no ip mroute-cache

!

interface Serial0/0.2 point-to-point

ip address 172.16.1.1 255.255.255.0

frame-relay interface-dlci 103

!

router ospf 1

no log-adjacency-changes

network 172.16.0.0 0.0.255.255 area 16

network 192.168.1.0 0.0.0.255 area 16

network 192.168.2.0 0.0.0.255 area 16

!

!

A#

A#sh ip ospf database

OSPF Router with ID (192.168.100.11) (Process ID 1)

Router Link States (Area 16)

Link ID ADV Router Age Seq# Checksum Link count

192.168.100.11 192.168.100.11 479 0x8000000A 0x3E53 4

192.168.100.12 192.168.100.12 374 0x80000013 0xE621 3

192.168.100.13 192.168.100.13 1783 0x80000006 0x3504 5

192.168.100.14 192.168.100.14 2323 0x80000003 0xBE83 5

192.168.100.15 192.168.100.15 2352 0x80000003 0xCB4A 5

192.168.100.16 192.168.100.16 2344 0x80000006 0x1A51 8

Net Link States (Area 16)

Link ID ADV Router Age Seq# Checksum

172.16.9.2 192.168.100.14 2323 0x80000001 0x22BD

Type-5 AS External Link States

Link ID ADV Router Age Seq# Checksum Tag

192.168.6.0 192.168.100.12 373 0x80000001 0xE076 0

192.168.7.0 192.168.100.12 373 0x80000001 0xD580 0

A#

A#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0 255.255.255.0 is subnetted, 1 subnets

C 172.16.1.0 is directly connected, Serial0/0.2

O E2 192.168.6.0 255.255.255.0 [110/20] via 172.16.1.2, 00:06:18, Serial0/0.2

O E2 192.168.7.0 255.255.255.0 [110/20] via 172.16.1.2, 00:06:18, Serial0/0.2

C 192.168.1.0 255.255.255.0 is directly connected, Loopback0

C 192.168.2.0 255.255.255.0 is directly connected, FastEthernet0/0

192.168.3.0 255.255.255.255 is subnetted, 1 subnets

O 192.168.3.1 [110/65] via 172.16.1.2, 00:06:19, Serial0/0.2

A#

A#

New Member

Re: IS-IS to OSPF Redistribution

C#

!

!

!

!

interface Loopback0

ip address 192.168.6.1 255.255.255.0

!

interface FastEthernet0/0

ip address 192.168.7.1 255.255.255.0

ip router isis

speed auto

half-duplex

!

interface Serial0/0

no ip address

encapsulation frame-relay

no ip mroute-cache

!

interface Serial0/0.1 point-to-point

ip address 172.16.2.2 255.255.255.0

ip router isis

isis circuit-type level-1

frame-relay interface-dlci 163

!

router isis

passive-interface Loopback0

net 49.0001.0000.0000.0002.00

!

ip classless

no ip http server

no ip pim bidir-enable

!

C#

C#

C#

C#sh isis dat

C#sh isis database det

C#sh isis database detail

IS-IS Level-1 Link State Database:

LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

B.00-00 0x0000000D 0x4245 527 0/0/0

Area Address: 49.0001

NLPID: 0xCC

Hostname: B

IP Address: 192.168.4.1

Metric: 10 IP 192.168.5.0 255.255.255.0

Metric: 10 IP 172.16.2.0 255.255.255.0

Metric: 0 IP 192.168.4.0 255.255.255.0

Metric: 10 IS B.01

Metric: 10 IS C.00

Metric: 20 IP-External 172.16.1.0 255.255.255.0

Metric: 10 IP-External 192.168.1.1 255.255.255.255

Metric: 10 IP-External 192.168.2.0 255.255.255.0

Metric: 20 IP-External 192.168.3.0 255.255.255.0

C.00-00 * 0x0000000A 0x6315 606 0/0/0

Area Address: 49.0001

NLPID: 0xCC

Hostname: C

IP Address: 192.168.6.1

Metric: 10 IP 192.168.7.0 255.255.255.0

Metric: 10 IP 172.16.2.0 255.255.255.0

Metric: 0 IP 192.168.6.0 255.255.255.0

Metric: 10 IS C.01

Metric: 10 IS B.00

IS-IS Level-2 Link State Database:

LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL

C.00-00 * 0x0000000E 0x4615 530 0/0/0

Area Address: 49.0001

NLPID: 0xCC

Hostname: C

IP Address: 192.168.6.1

Metric: 10 IS C.01

Metric: 30 IP 172.16.1.0 255.255.255.0

Metric: 10 IP 172.16.2.0 255.255.255.0

Metric: 10 IP 192.168.4.0 255.255.255.0

Metric: 20 IP 192.168.5.0 255.255.255.0

Metric: 0 IP 192.168.6.0 255.255.255.0

Metric: 10 IP 192.168.7.0 255.255.255.0

Metric: 20 IP 192.168.1.1 255.255.255.255

Metric: 20 IP 192.168.2.0 255.255.255.0

Metric: 30 IP 192.168.3.0 255.255.255.0

C#

C#h

C#

C#

C#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0 255.255.255.0 is subnetted, 2 subnets

i L1 172.16.1.0 [115/30] via 172.16.2.1, Serial0/0.1

C 172.16.2.0 is directly connected, Serial0/0.1

i L1 192.168.4.0 255.255.255.0 [115/10] via 172.16.2.1, Serial0/0.1

i L1 192.168.5.0 255.255.255.0 [115/20] via 172.16.2.1, Serial0/0.1

C 192.168.6.0 255.255.255.0 is directly connected, Loopback0

C 192.168.7.0 255.255.255.0 is directly connected, FastEthernet0/0

192.168.1.0 255.255.255.255 is subnetted, 1 subnets

i L1 192.168.1.1 [115/20] via 172.16.2.1, Serial0/0.1

i L1 192.168.2.0 255.255.255.0 [115/20] via 172.16.2.1, Serial0/0.1

i L1 192.168.3.0 255.255.255.0 [115/30] via 172.16.2.1, Serial0/0.1

C#

C#

C#

C#

New Member

Re: IS-IS to OSPF Redistribution

I pasted Router B,A and C respectively above.

Thankyou,

Martin

Gold

Re: IS-IS to OSPF Redistribution

This appears to be operating properly.... If you want the connected interfaces off of B at A, you need to redistribute connected into OSPF, not IS-IS. OSPF won't pick up the IS-IS routes from B's routing table, since they are locally originated.

Russ.W

203
Views
0
Helpful
23
Replies
CreatePlease to create content