Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Is it possible to do dialer watch + callback

Here's what I want to do:

I've got a core router with about 60 sites hanging out of it with HDLC links. I'm want to use ISDN for backup, run dialer watch at each remote sites so when a route dissapear the remote site will initiate DDR, but I would also like to implement callback in this equation so that when the remote site initiate the call the core router would hang up and call back. Does anybody has ever tried something like this?

Regards,

2 REPLIES
Cisco Employee

Re: Is it possible to do dialer watch + callback

You should be able to do that..Dialer watch and callback is two different functions at two different layer..Dialer watch is used to initiate a call once the watched route is not in the routing table while callback is at LCP layer negotiation..So it should work..Tejal

New Member

Re: Is it possible to do dialer watch + callback

The problem I have is with the two dialer map on the remote site that does the Dialer Watch. One of them point to one pri interface on the core router and the second one point to the route I'm watching, therefore when I try to invoke callback it actually connect but the OSPF adjencency never get updated. Could this be due to the fact that the second call is issued by the core router, bypassing the second dialer map statement on the remote site?

If someone have any sample configs for this kind of scenario, they would be more than appreciated.

Here's the config I'm using to test this

Remote site:

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname bgota01

!

enable password 7 050F030328404F01

!

username lbpg03 password 7 04580A080E254D

ip subnet-zero

!

isdn switch-type basic-ni

!

fax interface-type fax-mail

mta receive maximum-recipients 0

!

interface FastEthernet0/0

ip address 160.106.136.129 255.255.255.128

speed 10

half-duplex

!

interface Serial0/0

no ip address

shutdown

!

interface BRI0/0

ip address 160.106.177.130 255.255.255.128

encapsulation ppp

dialer idle-timeout 30

dialer watch-disable 15

dialer map ip 160.106.177.129 name lbpg03 broadcast xxxxxxx

dialer map ip 160.106.180.128 name lbpg03 broadcast xxxxxxx

dialer load-threshold 1 either

dialer watch-group 8

dialer-group 1

isdn switch-type basic-ni

isdn spid1 xxxxxxxxxx00 xxxxxxx

isdn spid2 xxxxxxxxxx00 xxxxxxx

no cdp enable

ppp authentication chap

ppp multilink

!

interface FastEthernet0/1

ip address 160.106.240.78 255.255.255.252

duplex auto

speed auto

!

router ospf 10

log-adjacency-changes

network 160.106.136.128 0.0.0.15 area 0

network 160.106.177.128 0.0.0.15 area 350

network 160.106.240.76 0.0.0.3 area 350

!

ip classless

no ip http server

no ip pim bidir-enable

!

access-list 101 deny ospf any any

access-list 101 permit ip any any

dialer watch-list 8 ip 160.106.180.128 255.255.255.128

dialer watch-list 8 delay disconnect 15

dialer-list 1 protocol ip list 101

!

call rsvp-sync

!

!

mgcp profile default

!

dial-peer cor custom

!

line con 0

exec-timeout 0 0

password 7 0502140A2D4D400D

login

line aux 0

line vty 0 4

password 7 0502140A2D4D400D

login

line vty 5 15

login

!

end

Core router:

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname lbpg03

!

enable password 7 045F0E0A062D4D46

!

username bgota01 password 7 020505550A020E

ip subnet-zero

!

no ip domain-lookup

!

isdn switch-type basic-ni

!

fax interface-type fax-mail

mta receive maximum-recipients 0

!

interface FastEthernet0/0

ip address 160.106.180.129 255.255.255.128

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

interface BRI0/0

no ip address

encapsulation ppp

dialer rotary-group 1

dialer-group 1

isdn switch-type basic-ni

isdn spid1 xxxxxxxxxx00 xxxxxxx

isdn spid2 xxxxxxxxxx00 xxxxxxx

no cdp enable

ppp authentication chap

!

interface FastEthernet0/1

ip address 160.106.240.77 255.255.255.252

duplex auto

speed auto

!

interface Dialer1

ip address 160.106.177.129 255.255.255.128

encapsulation ppp

dialer in-band

dialer enable-timeout 5

dialer map ip 160.106.177.130 name bgota01 broadcast

dialer hold-queue 10

dialer-group 1

no peer default ip address

no cdp enable

ppp authentication chap

ppp multilink

!

router ospf 10

log-adjacency-changes

network 160.106.177.128 0.0.0.15 area 350

network 160.106.180.128 0.0.0.15 area 0

network 160.106.240.76 0.0.0.3 area 350

default-information originate

!

ip classless

no ip http server

no ip pim bidir-enable

!

access-list 101 deny ospf any any

access-list 101 permit ip any any

dialer-list 1 protocol ip list 101

!

call rsvp-sync

!

mgcp profile default

!

dial-peer cor custom

!

line con 0

exec-timeout 0 0

password 7 121017121E0A0200

line aux 0

line vty 0 4

password 7 130C0517070D0A2E

login

!

end

Regards,

Mario Laniel

83
Views
0
Helpful
2
Replies