Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Is it possile to have different default routes for different networks ?

I cant understand how I configure my Catalyst to use different default routes for different networks. (in the same catalyst 2948G router)

lets say I have 2 Fasteth interfaces with 2 different networks 10.0 and 11.0

interface FastEthernet10

ip address 10.0.10.1 255.255.255.0

interface FastEthernet11

ip address 10.0.20.1 255.255.255.0

How can I route 10.0.10.0 to internet via 192.168.100.1 AND route 10.0.20.1 to internet via 192.168.200.1 ?

when: ip route 0.0.0.0 0.0.0.0 192.168.0.1

Please help me.. I cant find the answer of this solution anywhere.. Maybee the answer is you cant. :)

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Is it possile to have different default routes for different

In general the answer to your question is called policy routing. See link: http://www.cisco.com/en/US/products/sw/iosswrel/ps1828/products_configuration_guide_chapter09186a00800ca590.html

eg. route-map test permit 10

match ip add 1

set ip default next-hop 192.168.100.1

route-map test permit 20

match ip add 2

set ip default next-hop 192.168.200.1

!

access-list 1 permit ip 10.0.10.0

access-list 2 permit ip 10.0.20.0

But I am doubtful the 2948G can do this. Have you router perform this.

Hope it helps.

Steve

1 REPLY

Re: Is it possile to have different default routes for different

In general the answer to your question is called policy routing. See link: http://www.cisco.com/en/US/products/sw/iosswrel/ps1828/products_configuration_guide_chapter09186a00800ca590.html

eg. route-map test permit 10

match ip add 1

set ip default next-hop 192.168.100.1

route-map test permit 20

match ip add 2

set ip default next-hop 192.168.200.1

!

access-list 1 permit ip 10.0.10.0

access-list 2 permit ip 10.0.20.0

But I am doubtful the 2948G can do this. Have you router perform this.

Hope it helps.

Steve

87
Views
5
Helpful
1
Replies
CreatePlease login to create content